10 Replies Latest reply: Mar 11, 2008 2:49 AM by steve copeland
steve copeland Level 1 Level 1 (55 points)
I have a 24" iMac with a Belkin external USB hub. My iPhone has stopped connecting via the hub but will connect if connected directly. All other devices work normally on the USB Hub including both of my iPods. The iPhone used to work fine on it!

iTunes gives an error saying that there is an error with the device and then needs to have a force quit as it hangs.

iMac, Macbok Pro, Mac OS X (10.4.10)
  • jia10 Level 4 Level 4 (1,715 points)
    Hi Steve,

    This is a well-documented problem. It seems to work well for some but not for others. In general, the advice from Apple is to avoid using USB hubs. It may be that since a recent update, the USB hub functionality is more erratic.
  • steve copeland Level 1 Level 1 (55 points)
    Doh! Thanks for the reply.

    What a strange problem. I have ordered another USB hub to see if that works. My friends works fine on his 3Com hub.

    It is just a bit of a pain as it means the phone has to be connected to the back of the machine rather than up on my shelf away from the speakers that chirp like mad now!
  • jia10 Level 4 Level 4 (1,715 points)
    Couldn't agree with you more. Hope the new hub works.
    Cheers.
  • Lawrence Finch Level 7 Level 7 (28,640 points)
    Does your hub have its own power supply, or is it powered from the USB port that it is connected to? If it does not have its own power that is likely the problem. An unpowered hub can place a limit of 400 ma per port, which appears to be insufficient to power an iPhone.

    If you have a powered hub this should not be your problem, although there have been some people who have issues using powered hubs. Ideally the hub should be able to supply the battery charging specification of 1.5 amps on each port.
  • steve copeland Level 1 Level 1 (55 points)
    It's a powered Belkin Hub. It worked fine until recently and still charges the iPhone bit it just won't connect it. There is some sort of issue with the hub, maybe drivers? If I pug the iPhone cable directly into the port on the mac it works fine. What is weird is that all the other stuff work fine, modem, iPod etc.
  • Lawrence Finch Level 7 Level 7 (28,640 points)
    Have you recently added some other device to the hub? Someone reported last week that their iPhone stopped syncing when they plugged their Nuvi into the same hub.
  • steve copeland Level 1 Level 1 (55 points)
    nope nothing changed at all.
  • j0r0b0 Level 1 Level 1 (0 points)
    I have found that some devices only work well when plugged directly into the computer usb hub. So, I put the other devices into the external one so that there is room for the 'difficult' ones.
  • steve copeland Level 1 Level 1 (55 points)
    I have encountered it before eyeTV does not work with this hub either. But is the fact that it was working and stopped rather than it never worked that bothers me.
  • steve copeland Level 1 Level 1 (55 points)
    Got hold of a new Belkin 7 port USB2 HUB and everything is working fine now. All I can assume is the last mac update must have changed something. The best bit is the eyeTV now works through it as well. So if nothing else I have now managed to get all 5 of my USB devices working through the new hub. I have a fitted office so everything is hidden behind the kick boards. Got rid of a load of cables!

    So if anyone else has the problem try a different hub before anything else even if other devices are working. I suspect it might have been something to do with charging current even though the Belkin Hub was powered.