4 Replies Latest reply: Mar 3, 2008 4:53 PM by iGarry
lhayward Level 1 Level 1
Please help! I recently tried to update my iPhone with the latest software. When I plugged my phone into the computer, it was recognized by iTunes, contacted the iTunes Store and successfully downloaded the new software. However the update, for whatever reason has failed (error 6). Now the phone is stuck in recovery mode!! When I plug it into iTunes it recognizes the phone, explains that it is in "Recovery Mode," extracts the software, but stalls when it "Prepares iPhone for Restore."

To try and remedy the problem I have done the following:

The phone spent six hours plugged into the wall charger for a solid charge, I have ensured I am running the latest version of pre-leopard OS (10.4.11), and iTunes (7.6.1), I have rest both the computer and phone many time and I have swapped USB cables and tried USB ports on both the front and back of my tower with no luck.

If anyone has some suggestions on how to resolve this issues I am all ears and much obliged...


Mac Book & Mac Pro, Mac OS X (10.4.11)
  • Lawrence Finch Level 8 Level 8
    Mac OS X
    Does your computer have USB 2 ports? USB 1.1 frequently won't work for Restore or Recovery.

    Are you using a hub? Sometimes the iPhone can't maintain a connection through a hub.

    Have you restarted your computer?
  • lhayward Level 1 Level 1
    Thanks for your prompt response!

    I checked, and my MacPro has USB 2.0. I have plugged the phone in directly (no hubs or keyboards) to USB ports on both the front and back of the machine to rule out a malfunctioning USB port. I have also used separate cables to rule out a faulty wire. Other devices I have tested (printers etc.) have worked just fine.

    I have restarted the phone and computer several times.

    An interesting note, this is not the first time I have experienced this problem. In fact my previous iPhone had the same diagnosis (error 6), that had to be swapped out at the Apple store for a new unit. I am hoping to avoid that procedure again. I will try restoring it from my MacBook laptop to see if that will kick-start it. If that doesn't work, I am afraid a trip to the Genius Bar will be my only resort... unless anyone has more suggestions?
  • lhayward Level 1 Level 1
    I needed to use a different computer to perform the restore. Very odd, but it worked...
  • iGarry Level 1 Level 1
    same here Restored on a diffrent computer