10 Replies Latest reply: Apr 8, 2008 2:40 PM by RDame
John Eriksson Level 1 Level 1 (35 points)
I've installed Boot Camp (Windows XP) on a MacBook air, and its not working that great.
the trackpad button is not always working, it can't connect to my wireless network and it can't use the USB to ethernet adapter.

When I try to use the boot camp partition with parallels desktop, it won't start, talking about some problem not being able to start windows.

Has anyone similar problems with the MacBook Air? Is the Boot Camp drivers not finished yet? Is there a problem running parallels from boot camp partition on MacBook Air?

MacBook, Mac OS X (10.5.2), More than maximized.
  • Michael Seelye Level 1 Level 1 (40 points)
    I don't think there's been a boot camp update since the mba release. They usually include the needed windows drivers. I'm sure the new trackpad would need the drivers. . .
  • tscales Level 1 Level 1 (5 points)
    I use bootcamp with my MBA and the wireless works fine under XP. Did you put in the first Mac OS disk and let it install all the updated drivers for the air?

    Haven't tried the USB Ethernet yet.

    By Bootcamp partition works native or under Parallels. No problems
  • John Eriksson Level 1 Level 1 (35 points)
    Yes I've installed the the boot camp drivers
  • Brian Caslis Level 3 Level 3 (795 points)
    I'm not familiar with parallels but I didn't think that you could use a bootcamp partition with it. I thought you had to create a different windows image for parallels. Could this be the problem?
  • John Eriksson Level 1 Level 1 (35 points)
    Yes on other computers you can use the boot camp installation with parallels or Fusion. I've done it on tons of computers. That is why I ask if there is something specific with the macbook air, that parallels requires a optical drive or something to link to the virtual system, but that is apparently not the issue since the user tscales have it working on his MacBook air.

    (however, earlier versions with parallels from boot camp partition had issues if you suspended the machine. you need to properly shut down windows before quitting parallels)
  • Brian Caslis Level 3 Level 3 (795 points)
    I've not used bootcamp on the MBA (although I have used it in the past on the MBP). My understanding is that the USB to ethernet adaptor does not work in Windows at least yet. Not sure about the other issues.

    My understanding is an environment like parallels needs to allocate resources (like drives, etc) before it starts the VM since it is emulating the hardware. Maybe a resource is missing? Have you tried running parallels with the superdrive attached to see if it makes a difference?
  • John Eriksson Level 1 Level 1 (35 points)
    I have not tried with the super drive attached since I don't have any optical drive...
  • Christian Greenberg Level 1 Level 1 (25 points)
    I installed Windows Vista Home Premium with Boot Camp, no problems whatsoever.
    I even updated to Vista Service Pack 1, again no problems.
    It works great, no issues at all, even with third party hardware drivers.
    Only bad thing is: Vista occupies 16 GB of my precious storage space (64GB SSD), so I have only 10 GB storage space left on my Macbook Air OSX partition. Not really a problem but anyway.
    I need to use Windows because of a high security level banking software incl. a special hardware but I have to admit that Vista runs great on the Macbook Air, no issues at all and very fast.

    I bought another Macbook Air 1.8/80 for my office to use it mainly with Windows(office applications), it is really very suprising to see how good the performance is with Boot Camp/Vista.
  • donluca Level 1 Level 1 (0 points)
    In order to make the USB ethernet adapter work under windows xp as of now you need a hacked version of a third party driver.
    I have it and it works flawlessly.
    Anyway I'd recommend you to wait for Apple to bring a proper driver.
  • RDame Level 1 Level 1 (0 points)
    I am using Boot Camp (Windows XP) on MacBook Air. Wireless network and USB to Ethernet adapter work fine. Of course, I found a driver on the web for the Ethernet connector. I have one problem with the trackpad that randomly freeze in any applications. To solve this issue I need to plug a mouse in the USB port. My problem is when I use the external drive or ethernet connector (only one USB port). Any one else solved a freezing trackpad under Windows XP.