2 Replies Latest reply: Mar 5, 2008 5:03 AM by Jason Trindade
Markus Oliver Level 1 (0 points)
I think I found a bug in Leopard:

I have got access to two wireless lans in my apartement. One is of my university, the other one my private. The one of the university is protected with cisco vpn.

When I sit in my living room (where the wlan of uni is strongest) and I am connected to my private wlan it will happen that the connection breaks and the macbook connects to the uni wlan by itself.

I take notice of it everytime I try to do something in the internet, because the page of my uni appears and demands to be connected via vpn. I have to reconnect to my private wlan manually.

Mac Book 2.16, Mac OS X (10.5), 2 GB RAM, 160 GB HD
  • Kappy Level 10 (263,335 points)
    What, exactly, is the bug? If you wish to report a bug you should do so here.
  • Jason Trindade Level 4 (2,925 points)
    This was happening to one of my machines recently. I tried moving around the different access points in the network preferences pane, but nothing seemed to work. Even though the signal strength to my first and desired AP was basically 100%, the system seemed to be switching to the one with lower encryption and a much weaker signal (it was also b vs b/g/n) . In the end I just deleted the two APs that were causing trouble and added them in the order that I wished the connections to occur.

    I think you might be onto something with this being a bug, but I can't figure out why it happens. I set up 2 machines exactly the same way with the only differences being the names and one of them always hit the correct AP while the other one exhibited the behavior I mentioned above.

    If you can figure out why it happens and a fix that doesn't require entering the passwords and re-adding all the access points please post it. I didn't dig to deeply into this because my fix worked and has been stable for weeks, but it seems like there may be a hardware component involved. The machine with problems has a replacement airport module and it stutters when speed testing. It's the only machine I have that stutters. Try running a few speed tests and see if the connection maintains a constant speed. I'd also try using a different machine in the same situation and see if you can duplicate the problem. I think it might be an issue with the wifi on your machine.

    Good Luck,