5 Replies Latest reply: Mar 6, 2008 3:03 PM by Aperture Anne
Aperture Anne Level 1 Level 1 (5 points)
I upgraded to 2.01 this morning and am having multiple problems since. Tried to make an adjustment in an image and either spinning beach ball or everything froze and wouldn't even force quit. Had to re-boot my computer several times using the power button since nothing else was working. Cropping was also buggy -cropping vertical when I had given the measurements to be horizontal, cropping down to just a few pixals showing, etc. After repairing disk permissions, rebooting several times, etc., I was able to make adjustments without crashing, but then got a lot of weird artifacts.

Now, I have tried exporting some images and am getting weird things happening. I started with an 8.4MB raw file. Exporting as a full-size original JPEG I am getting an 8kb file (basically it looks like it is just exporting a thumbnail). Exporting as a 50%JPEG, I am getting 636kb. Exporting as an original size 16-bit TIFF, I am getting a 57.9MB file.

I didn't have any problems when I upgraded to 2.0, so these are new for me. Thanks for any help you can give.

Any help would be greatly appreciated.

15" MBP, Mac OS X (10.4.11)
  • steebow Level 2 Level 2 (330 points)
    *SERIOUS ISSUES HERE TOO.*
    never had any problems with aperture 1.x, and 2.0 worked perfectly. now since 2.01 i have frequent crashes. about every 3rd time aperture crashes on launch. selecting multiple images in smart albums crashes aperture etc.
  • ArkiGigi Level 1 Level 1 (0 points)
    Good morning everyone
    I've problems with Aperture only since I've upgraded to 2.0.1. Specifically when I work to compose a photobook Aperture crashes unexpectedly.

    Any solutions?
    Thanks
  • Barry Fisher Level 3 Level 3 (655 points)
    So far so good w/2.01, faster, and doesn't seem to bog as much over time. No book making problem. Certain tools like the spot remover now work properly when resizing the brush to small sizes. I think it's a good improvement, good job.
  • Jeyell Level 2 Level 2 (250 points)
    A good tidy-up from 2.0.
  • Aperture Anne Level 1 Level 1 (5 points)
    I'm happy for those for whom the 2.01 update has worked, but that knowledge doesn't really provide a solution for those of us who are still having problems.

    Here is what I have tried so far:

    1. Delete the Aperture.plist
    2. Rebuild the Library Database (holding down Option/CMD on launch).
    3. Restarting the machine and Aperture.
    4. Repaired Permissions in Disk Utility (odd, but this has fixed some crashing issues).
    5. Re-installed ProKit 4.5 update
    6. Made a new Aperture library with just newly imported images. The same problems happened in it.

    I am not having crashing issues or bad artifact issues anymore, but still can't export a full-sized JPEG and can't crop to the ratio that I want which isn't a great problem, but way better than crashing.

    For the others who are having crashing issues, maybe trying the above things will help.