8 Replies Latest reply: Mar 5, 2008 4:52 PM by Ernie Stamper
wasiii Level 1 Level 1 (0 points)
I have 2 pop mail accounts

1. non-isp hosted account
incoming and outgoing server address mail.domain.com
no authentication, incoming port 110, outgoing port 25

2. isp mail account
incoming address; pop-server.ca.rr.com
outgoing address; smtp-server.ca.rr.com
no authentication, incoming port 110, outgoing port 25

Under Boot Camp WindowsXP Outlook both accounts work just fine
Under Leopard non isp account outgoing returns;

Cannot send message using server XXXXXX (outgoing mail.domain.com address)
Connection doctor succeeded to the this server

Non isp account incoming works fine
Isp account incoming and outging works fine

All connections on net with Time Warner RR service

I would start trying to troubleshoot the ISP or the Network but under WindowsXP Outlook works just fine and the settings in Mail are identical.

Anyone run into this?

Thanks in advance,

WAS

MBP 2.4, Mac OS X (10.5.2)
  • Ernie Stamper Level 8 Level 8 (37,555 points)
    WAS,

    First open Mail Preferences/Accounts/Account Information. Does the name of the smtp include any portion of your email address/Username? Click on the up/down arrows beside the name of the SMTP, and choose Edit Servers. Then with the SMTP setup so displayed, click on the Advance Tab, and confirm that the Authentication is None, as you expect? And on Port 25?

    Are you located at home, connected to RoadRunner, when this is happening?

    Ernie
  • wasiii Level 1 Level 1 (0 points)
    Ernie,

    Thanks for the reply.
    The only thing that is common between my email address and the server address is the domain name. Also no authentication and port 25.
    Using the system at home (on net).

    Like I said the odd thing is that it works fine from bootcamp under XP so the ISP is accepting sends on port 25. I thought it might be someting that Leopard was doing that I wasn't aware of. The format of the address for both incoming and outgoing servers for the non isp hosted domain is mail.domainname.com

    Thanks,

    WAS
  • Ernie Stamper Level 8 Level 8 (37,555 points)
    WAS,

    Rereading your earlier posts, it seems likely that because the SMTP related to your non-ISP account is not authenticated, it is your ISP that is blocking your use of the non-authenticated SMTP. Why this is not happening with XP is not clear. Have you tried selecting the SMTP of your ISP related account, as the outgoing server for your other account? Are you sure that in XP this has not taken place automatically?

    Ernie
  • wasiii Level 1 Level 1 (0 points)
    Ernie,

    If I select the ISP account for outgoing, it works just fine. However that is a problem when I need to send mail off net. XP (Outlook) faithfully forwards the mail.domain.com address to the hosted server with no problem.

    Here's another wrinkle. If I send an email to myself (wasiii@domainname.com)(or for that matter to my wife who has an address at this domain) Leopard will send it without a problem, if I send an email to any other domain, Apple Mail will block it. Very strange

    WAS
  • Ernie Stamper Level 8 Level 8 (37,555 points)
    WAS,

    I think it likely that it is the SMTP of your hosted domain that is rejecting the messages addressed to those outside that domain -- this is sometimes seen for security. What it may mean is that you are not being seen as connected to the POP3 server, when you are trying to send via the associated SMTP, which may be different while in XP.

    Try this: compose a message for sending that you know will fail, but before sending, check for new mail in that account, and either while that check is taking, or immediately after, click the Send button. This is strictly for a test, and no workaround intended. Have the Mail Activity window open while this is going on.

    Ernie
  • dechamp Level 4 Level 4 (3,490 points)
    Every non-isp account I've set up with various hosted domain sites recommends you use your own ISP's SMTP server to send mail. These email accounts are hosted on machines that are also hosting other sites and the domain host's figure the ISP's SMTP server is probably more robust. I've always followed this advice.

    That's not an answer to why XP is working and Leopard not, but may explain why Leopard fails so often with these accounts.

    Many people have fixed several kinds of trouble sending emails from Leopard by just adding their ISP's DNS numbers to the Network Prefs>Advanced settings. It can help Leopard begin sending emails quicker and seems to also settle down problems that may be caused by part of the link "timing out". I don't have a real understanding of why the solution is required for Leopard, when Tiger didn't need it, but it's working for me and a couple of my clients.

    The numbers are easy to add, and remove if there is no improvement.
  • wasiii Level 1 Level 1 (0 points)
    Ernie,

    Thanks for your help. I have solved the problem by requiring password authorization on the non ISP outgoing server. (for some reason Outlook handles this.. go figure)

    My son suggests that this is a pretty standard requirement for off net domains as a spam precaution. (He is usally right on such matters).

    WAS
  • Ernie Stamper Level 8 Level 8 (37,555 points)
    Yes, you are of course correct, which is why I suggested that earlier. But it does remain a problem to try to use a non-authenticated SMTP when connected on another network where your ISP's SMTP is not recognized as safe. This is what I understand WAS' last comment to mean, and why using the SMTP associated with the hosted domain is desirable.

    Thanks,

    Ernie