7 Replies Latest reply: Sep 17, 2005 3:57 PM by Robert Warner
Daniel Kaplan Level 1 Level 1 (55 points)
Because my boot partition was getting full I moved my Mail 2.0.3 application to a different partition. Now the icons on the Mail toolbar have disappeared! How can I get them back?

Also, the flag that displays whether a message has been read or not (I think it was a fat blue dot) no longer appears.

I tried restarting Mac OS X but this did not help. Is there a solution?
  • Daniel Kaplan Level 1 Level 1 (55 points)
    I also tried moving Mail back to the Applications folder in the boot partition - didn't help.

    Actually, it's behaving as if the icons are there but invisible. If I click in the space on the toolbar that they used to occupy (above their names: "Delete Junk Reply" etc.), the actions happen. Also, I tried playing with the settings in Mail's "View/Customize Toolbar" menu, switching back and forth between "Show Icon & Text" and Show Text Only," but it made no difference. And the icons are all invisible on the "View/Customize Toolbar" as well as on the toolbar itself.

    HELP!!!
  • Robert Warner Level 1 Level 1 (105 points)
    Yep - as of a few minutes ago mine are missing too!
  • Robert Warner Level 1 Level 1 (105 points)
    I may have figured it out. Try this:

    In MAIL go to the VIEW menu. From there go to CUSTOMIZE TOOLBAR. Select SHOW ICON & TEXT,

    That should do it!
  • Daniel Kaplan Level 1 Level 1 (55 points)
    Thanks for trying! But you didn't see my second post. I had already tried what you suggest and it didn't work for me. (Glad it worked for you, though.) Rather than not being displayed, my icons seem to have turned invisible.
  • Robert Warner Level 1 Level 1 (105 points)
    I did see your second post - just did not read is as closely as I should have.

    Hopefully, someone here will come up with a solution for you - if I discover anything I will let you know.

    Again, apologies for not having read your second message more closely.

    Regards, Bob
  • Daniel Kaplan Level 1 Level 1 (55 points)
    Problem solved! It turned out that in copying Mail from the Applications folder on my boot partition to the other partition, some files failed to be copied. I had deleted the original application, so those files were nowhere on my hard drive. When I control-clicked on Mail and looked in the Resources folder (in Contents), the .tiff files up to first-lettter "s" were there, but when I compared to Mail on a different Mac I saw a bunch of files that came later in the alphabet, including a bunch of "TB_..." tiff files - these evidently were the ToolBar icons. When I copied them from the other Mac and restarted Mail, my missing icons were back.

    This leaves the following mystery. Before I did the above I tried reinstalling Mail onto my boot partition from the Tiger install DVD. For some reason the newly installed version was still lacking those icons. Is this a surprise to anyone else? Why wouldn't installing an application install all of its contents?
  • Robert Warner Level 1 Level 1 (105 points)
    Glad to hear you solved it.

    As to your second paragraph regarding the "mystery". As too often, the answer may be that there is no answer.

    Anyhow, glad you solved the immediate problem.

    Regards, Bob