6 Replies Latest reply: Sep 10, 2008 12:41 PM by hauper
Mike.S Level 1 Level 1 (0 points)
Time Machine has been working fine since I fitted it up with a G-Tech G-Drive at the beginning of February. Now, suddenly when the hourly back up comes along....if I watch the progress in the Time Machine System Preferences ....it starts a back up of around 370MB then when it gets to the 370MB it just carries on going and the 370MB steadily gets bigger and bigger. So basically it just keeps on backing up.
What has happened suddenly?
Any ideas about what to do?

24"iMac intel core 2 duo, Mac OS X (10.5.1)
  • stevewhitemd Level 1 Level 1 (110 points)
    Could well be a corrupted file. Plenty of reports of TM gagging when a file is corrupted a certain way.

    1) run Repair Permissions (Disk Utility)

    2) verify/repair both the drive being backed up and the drive holding the TM backup. You may need to boot from your Leopard DVD to repair the internal drive.

    If this doesn't work search the archives on corrupted files and TM.
  • Mike.S Level 1 Level 1 (0 points)
    Thanks for the reply.
    Before you posted this I reformatted the drive which did the trick but obviously I lost all my backups ( which wasn't that much really). So it does indeed sound as though there was a corrupt file somewhere along the line.
    If it happens again (God forbid) I will make a note of what you suggested and give it a try.
    I did run verify/repair but only on the drive holding the backup and I didn't reboot from the Leopard DVD.
    thanks again.
  • NathanCG Level 1 Level 1 (0 points)
    I am having this same problem. the ever expanding back up. It says something like "2.0Gb of 2.0Gb" and won't stop backing up, with both numbers getting bigger in parallel. This is now the second time this happened. The first time was solved with a reformat of the back up drive and restarting of time machine. it worked great for a while, until I actually used the time machine feature to restore a file, now this problem again. Is time machine corrupting it's own .dmg file?
  • J D Knight III Level 4 Level 4 (3,415 points)
    I'm having the same problem. My 46.2MB backup is still running at 12.4GB and growing, while the Available space on the backup driver is getting larger as well! Reformatting the drive and loosing all the data should be the very LAST solution!
  • J D Knight III Level 4 Level 4 (3,415 points)
    So here I am again after completely reformatting the partition that my back up was on (and loosing all of the old data) I'm getting the same problem again. Not even a week later.

    Message was edited by: J D Knight III
  • hauper Level 1 Level 1 (0 points)
    The only option might is probably to erase the partition and then delete <com.apple.TimeMachine.plist> from main Library/Preferences (not User library). If you erase the partition without deleting the .plist, the problems continues, if you delete the .plist without erasing the partition, you're stuck in the mud.

    Message was edited by: hauper