2 Replies Latest reply: Mar 17, 2008 1:18 AM by MichaelFlynn
Gary buscombe Level 1 Level 1 (0 points)
installed windows xp with sp2 on my new Imac (10.4.11) and want to run MS Flight Simulator X. Will it load right out of the box using my Mac's ATI video card? What changes/installations do I need to make first?

imac, Mac OS X (10.4.11)
  • mac_paint Level 1 Level 1 (65 points)
    I'm a graphic designer for a addon developer for FSX and have used a 2.33GHz Core 2 Duo MacBook Pro to do the design work and load the addon in FSX to check my work. On the 2.33GHz I had to setup FSX with most of the graphic sliders to the left or midpoint to get acceptable frame rates with our computational heavy simulator. I've now move up to the 2.5GHz Penryn MacBook Pro and I can now run with all sliders to the right, addon AI set at 50% and still have plenty of frames without any stuttering.
    I'm not sure which processor and graphic card is in your iMac but you should have acceptable performance with the default aircraft included with FSX. I think FSX runs better on Macs than on similar configured PC's but that's just my opinion
  • MichaelFlynn Level 1 Level 1 (0 points)
    Hi,

    I have iMac 24" 2.8GHz 2 GB ram. XP SP2 in Bootcamp. FSX runs fine. Get the latest ATI drivers for Bootcamp from the ATI site. Biggest frame hog seems to be the AA. Choose the minimum setting with the ATI utility supplied. You might want to play with Mipmapping etc as well.

    From memory, I was getting around 20FPS minumum pretty consistently at mostly maxed out settings. A couple of strange things happen occasionally. Going from 3d cockpit to 2d cockpit (or vice versa) can slow down the the works. Either restarting FSX or changing some video settings and hitting OK seems to work.

    One other thing, FSX SP1 is good - multicore support etc. FSX SP2 has a couple of problems - lose menu text and so on. Unless it's been fixed, stick with FSX SP1.

    Lastly, I was getting strange artifacts after changing screen resolution etc, and going back into FSX. Once again, if this happens, go back into video settings (FSX that is), uncheck filtering, check it again, then click OK. Works fro me. Haven't got the foggiest idea why, and your experience may be totally different. When you feel like a change, install IL2 Sturmovik, and have some fun!