11 Replies Latest reply: Mar 19, 2008 7:00 AM by OIT
OIT Level 1 Level 1 (20 points)
For about the past two weeks, Finder requires me to supply my password when I want to delete a file from e.g. my downloads folder. (This is the one Leopard created, in my Home folder, but outside my documents folder.)
I have repaired permissions. Doesn't help.
When I Get Info on the folder, it states that I have "custom access", and that I can read and write.
I have selected my name and selected "apply to all enclosing folders." Still doesn't help.
My account IS an administrator account.
I do have Office 2008 installed, and I have run the updater, successfully.
Advice would be very welcome.

Dual 2GHz 2GB RAM PPC G5, Mac OS X (10.5.2)
  • Michael Conniff Level 7 Level 7 (33,125 points)
    Hi OIT

    Let's see what "custom access" on your Downloads folder actually means. Open the Terminal (from /Applications/Utilities) and copy and paste the following into the Terminal window followed by a return:
    ls -alde ~ ~/Downloads/

    You should get two lines of output: copy and paste them from the Terminal window to a post here.
  • OIT Level 1 Level 1 (20 points)

    Here's the Terminal output.

    drwxr-xr-x+ 16 dbogart staff 544 4 Mar 11:53 /Users/dbogart
    0: group:everyone deny delete
    drwxr-xr-x+ 685 dbogart staff 23290 18 Mar 14:22 /Users/dbogart/Downloads/
    0: group:everyone deny delete

    Seems to explain the problem; how do I change it?

  • V.K. Level 9 Level 9 (56,110 points)
    first run the following command in terminal

    chmod -R -N ~/Downloads

    This should remove all ACLs from ~/Downloads and anything in it.
    Since ~/Downloads is a system folder and really shouldn't be deletable
    next run the following

    chmod +a "everyone deny delete" ~/Downloads

    This should protect the Downloads folder itself from being deleted.

    In the future, don't use "apply to enclosed items" for permissions on System created folders. They typically have those deny delete ACLs and you would just pass them along to all their contents.

    Message was edited by: V.K.

    oops, make that downloads instead of Library.
  • Michael Conniff Level 7 Level 7 (33,125 points)
    OIT wrote:
    Seems to explain the problem; how do I change it?


    Well no it doesn't necessarily, since Terminal tells me
    drwxr-xr-x+ 34 michaelc staff 1156 17 Mar 17:35 /Users/michaelc
    0: group:everyone deny delete
    drwx------+ 97 michaelc staff 3298 18 Mar 17:03 /Users/michaelc/Downloads/
    0: group:everyone deny delete
    while Finder tells me about my Downloads folder:
    You have custom access
    user(me) Read & Write
    everyone No Access

    However the Terminal command only looked at the Downloads directory, not anything inside. So it may be worth doing what V.K. suggested, but here's a way of doing it with just one command:
    chmod -RN ~/Downloads/*

    That will leave the correct ACL on the ~/Downloads directory. It's worth a try, but I'm not convinced it will work, so please give us feedback
  • Christoph *** Level 2 Level 2 (255 points)
    I have a fix, separate from what Michael or V.K. said. If their's doesn't work, then try these:

    Fix 1:

    chmod -R -a "everyone deny delete" ~/

    Note: This will remove the 'everyone deny delete' ACE (access control entry) from all files and folders in your home directory, the next command will add it back to where it needs to be
    And then
    chmod +a "everyone deny delete" ~/ ~/Desktop ~/Documents ~/Downloads ~/Library ~/Movies ~/Music ~/Pictures ~/Public ~/Public/Drop\ Box ~/Sites

    Note: This only applies the 'everyone deny delete' ACE to the folders listed, not their contents. These folders are required by the system, this ACE prevents you (or anyone else) from renaming, moving or deleting them (because they are required by the OS).

    Just copy/paste the bold text, one at a time, into a Terminal window (/Applications/Utilities) and press return. That should do it.

    This is not my solution (I don't know terminal) but this is the petrock fix for the issue.
    Good luck!

    Fix 2 (something more major):

    1. Insert your Leopard install DVD.
    2. Shut down, then start while holding "C".
    3. Select a language.
    4. Click Utilities>Reset Password.
    5. Click "Reset" at the bottom, and reset all affected accounts EXCEPT "System Administrator (Root)".
    6. Restart. All home folder permissions will be reset to default.

    (And don't use the "apply to enclosed items" feature).


    C h r i s t o p h

    Message was edited by: Christoph *
  • V.K. Level 9 Level 9 (56,110 points)
    this is a serious overkill. there is absolutely no reason to mess with permissions on files outside the Downloads folder. what you describe would make sense if someone clicked on "apply to enclosed items" on permissions for the whole home folder. This is not the case here so why do this?

    Message was edited by: V.K.
  • OIT Level 1 Level 1 (20 points)
    Well, VK, I think I DID click “apply to enclosed items” on the entire home folder, in a fit of desperation, after having no joy on the Downloads folder, as well.
    I was also having to supply my password when I wanted to remove something from my Documents folder in my Home folder.

  • V.K. Level 9 Level 9 (56,110 points)
    ok, in that case the commands provided by Christoph are useful.
    First run
    chmod -R -a "everyone deny delete" ~/

    This will remove the "deny delete" ACEs from everything in your home folder.

    Next run

    chmod +a "everyone deny delete" ~/ ~/Desktop ~/Documents ~/Downloads ~/Library ~/Movies ~/Music ~/Pictures ~/Public ~/Public/Drop\ Box ~/Sites

    This will restore "deny delete" ACEs on those folders in your home folder which ought to have them such as the Desktop folder and the Downloads folder.

    Hopefully, this will fix things.

    and Oh, yes. As I said before, in the future DO NOT use "apply to enclosed items" on system folders!
  • Christoph *** Level 2 Level 2 (255 points)
    I have given this solution, for I thought it very unlikely that only the downloads folder was messed up. As it turns out, I was correct so the entire home folder needs work on.tiger

    C h r i s t o p h
  • OIT Level 1 Level 1 (20 points)
    Thanks everyone.
    Tried Christop's solution, which didn't solve the problem. When I ran
    +chmod -R -a "everyone deny delete" ~/+
    I got:
    +chmod: No ACL present+
    Same result with his second suggested command.

    So I tried Michael's suggestion to run
    +chmod -RN ~/Downloads/*+
    And that solved the problem for the Downloads folder. And my Home/Documents folder doesn't ask for a password, either.

    So thanks for your help and interest.

  • OIT Level 1 Level 1 (20 points)
    And by the way, here is the Terminal output, after running:
    +ls -alde ~ ~/Downloads/+

    +drwxr-xr-x 16 dbogart staff 544 4 Mar 11:53 /Users/dbogart+
    drwxr-xr-x 682 dbogart staff 23188 19 Mar 09:38 /Users/dbogart/Downloads/+
    +0: group:everyone deny delete+

    So thanks again.