1 2 Previous Next 19 Replies Latest reply: Jan 26, 2009 5:35 PM by doug pennington
Kaz18 Level 1 Level 1 (0 points)
Firstly, sorry if I'm posting this in the wrong spot, I'm new. But I also heard this problem may be due to leopard.

I was emailed a .zip file that I really want to open but when I try to unzip it only creates a .cpgz file then then ..cpgz or another ..2.zip
I've tried double clicking the .zip and opening normaly and stuffit and opening it in windows xp
BTW it's a file I'll need to open in my xp partition if that makes a difference, (unfortunately I sometimes need to use xp as some apps such as autocad don't run mac) i just don't connect xp to the internet.

mbpro, Mac OS X (10.5.1), 1.83GHz, 2GB ram
  • 1. Re: can't open .zip, only starts .cpgz cycle
    Tony T1 Level 6 Level 6 (8,385 points)
    Try a 3rd party app like BetterZip or Springy
  • 2. Re: can't open .zip, only starts .cpgz cycle
    Kaz18 Level 1 Level 1 (0 points)
    Thanx, but it didn't work the same thing just keeps happening. Nothing happens when I extract the .zip file, it doesnt even ask for an extraction location, just doesn't do anything. But when I extract the .cpgz file it just extracts another .zip file that i cant extract
  • 3. Re: can't open .zip, only starts .cpgz cycle
    MacNut2 Level 1 Level 1 (5 points)
    I just encountered the same problem. In my case, the original file was surely a PC user and the zipped extension is .pptx. I use Stuffit to unzip and get the .cpgz cycle.

    I just tried changing the original extension of .pptx to .zip and it unzipped properly!

    Message was edited by: MacNut2
  • 4. Re: can't open .zip, only starts .cpgz cycle
    dechamp Level 4 Level 4 (3,495 points)
    Are you saying that all zip files are having problems or is just one file failing to unzip?

    Maybe the file is corrupt or was made by a pc user with a proprietary zip format that is not compatible?

    Make your own zip file and see if you can open it.

    Download another zip file and see if you can open it.
  • 5. Re: can't open .zip, only starts .cpgz cycle
    Antonio Leites Level 1 Level 1 (0 points)
    I got the same problem with all zip files. I tried with differents appl and always I get a cpgz file.... and
  • 6. Re: can't open .zip, only starts .cpgz cycle
    pvangage Level 1 Level 1 (0 points)
    Can do 1 better.
    File downloaded off ftp server using Transmit. Downloaded in Binary format. Filename XXXX.ZIP and it unzipped. Copied this file and the enclosing folder to another mac so that folders could be renamed to our filenaming convention (File was untouched). Folder copied back and now it goes into .cpgz.

    Checked the original download to the "copied" version - exact same mod dates, exact same permissions, exact same file size - yet run a tail or head command in shell and I get nothing from the renamed file. Tried to open files in BBEdit to see if there anything -- the "copied file" displays nothing, not even gibberish I would have expected!
  • 7. Re: can't open .zip, only starts .cpgz cycle
    Stephen Kay Level 1 Level 1 (95 points)
    Speaking of this automatic unzipping, is there anyway to disable this?

    For example, say I want to download a .zip archive, and have it stay a .zip archive so I can upload it somewhere else? The problem with re-zipping it is that I don't want it to be a Mac .zip file with bogus resource files and DS_STORE files in it for Windows users. If I download a Windows .zip, I want to keep it as a .zip that was zipped on Windows, if you follow me.
  • 8. Re: can't open .zip, only starts .cpgz cycle
    Stephen Kay Level 1 Level 1 (95 points)
    OK, I'll answer my own question for anyone who sees this:

    You can either disable the automatic opening of "safe" files in the General Preferences section of Safari, or I also discovered that, even when you have the Preferences set to automatically unzip the files, you can override this by control-clicking on the file and choosing "Download Linked File as..."
  • 9. Re: can't open .zip, only starts .cpgz cycle
    onthow Level 1 Level 1 (0 points)
    My user just encountered this zip/cpgz cycle as well, and I think this is what happened.

    He was attempting to download a zip file that was only available via BitTorrent. So he downloaded the corresponding 24 KB torrent file and double clicked it. This opened Opera (his default application for torrent files), and the actual 62 MB zip file started downloading. But unlike a conventional downloading file that ends in .download and shows a small progress bar in the icon, the BitTorrent downloading file looks indistinguishable from a completely downloaded file: it ends in .zip and has the zip icon even though it is still downloading. So my user was attempting to unzip a 62 MB file when only about 50 MB had downloaded.

    As of this writing, the file is still downloading. But I suspect once completely downloaded, he will be able to unzip the file normally using Stuffit Expander.
  • 10. Re: can't open .zip, only starts .cpgz cycle
    carlomac Level 1 Level 1 (0 points)
    this worked for me too. when you double click on the original .zip file and get a .cpgz , alter the file extension of the newly created .cpgz to be .zip. then double click on this and it should extract properly. dont know whats going on but at least it works.
  • 11. Re: can't open .zip, only starts .cpgz cycle
    euskir Level 3 Level 3 (715 points)
    I had the the "unzipping" problem with Quicksilver (the launcher), the downloaded file was "QS.3815.dmg.bz2", and trying to open that, well, the "cycle with no end", but just removing the"bz2" was enough to solve the issue.
  • 12. Re: can't open .zip, only starts .cpgz cycle
    Victoria Herring Level 2 Level 2 (290 points)
    sad to say, I'm now having this issue and nothing seems to work = cpgz files and zip files replicate like rabbits -- I did change a cpgz file back to a zip file and rename it but it still replicated it...I'm downloading from a business website and it should work, but it's probably created by a Windows zipper and not easily openable by me [using Leopard] - this is the very first time this has happened.
  • 13. Re: can't open .zip, only starts .cpgz cycle
    Victoria Herring Level 2 Level 2 (290 points)
    mea culpa = I downloaded latest Stuffit Expander 12.0.2 and it opens the zips just fine
  • 14. Re: can't open .zip, only starts .cpgz cycle
    frred Level 1 Level 1 (0 points)
1 2 Previous Next