Previous 1 2 3 4 5 Next 70 Replies Latest reply: Dec 23, 2009 10:11 AM by lmorris99 Go to original post
  • RonAnnArbor Level 4 Level 4 (2,695 points)
    I'll repeat--

    Make sure you delete REALPLAYER 11 and rollback to no newer than 10.1 if you have it.

    I see this problem in all variety of Macs in my office all day long -- and in every instance, deleting Realplayer did the trick.
  • shokunin Level 1 Level 1 (0 points)
    I have a similar issue, where browsing gets really slow, clicking on a link results in waiting and waiting, that is until I click on the wifi icon on the menu bar and bingo, link refreshes. Checking the logs on our business router I see lots of deauth/deassoc responses. Of course, of all the other machines on the network, my MBA Rev B is the only one doing this.

    Out of curiosity, I opened terminal and did a ping of our router aka ping 192.168.99.1 and kept it looping. I can now surf without any issues and instant response. The minute I stop pinging then the wireless goes back to its random nature. For some reason Leopard is deauthorizing after a short period of inactivity and doesn't seem to reauthorize until I click on the wifi icon.

    Since it works while pinging, this appears to be a software issue in Leopard. I'm running 10.5.6.
  • ltackmann Level 1 Level 1 (0 points)
    I can confirm this workaround on my MacBook Air (second edition). From time to time, my Air will stop detecting any networks and will drop connections, but if I manage to get back on and start pinging the default gateway then it becomes rock solid. Also it works flawlessly under Linux on the Air, so I am now confident that this is a Mac OS X software issue.
  • benja85 Level 1 Level 1 (0 points)
    This is so frustrating. Having the same problem with my MBA (1st generation) at my university - we have a Cisco Wi-Fi and a 802.1X network and both are a pain for the MBA. Had an iBook G4 before (Tiger) and everything was running just perfect.

    There seems to be a definite link between MBA - WiFi - Leopard and it's about time that Apple addresses this issue.

    What can I do? I live in Germany and we don't even have a technical helpline (well, there is one but don't expect professionals working there). I had my Airport Card AND the mainboard exchanged by a technician. Problem still there...

    Can I send back my MBA to Apple and expect to get a new one (or a MacBook that will work properly)???
  • wifiguru Level 2 Level 2 (230 points)
    Could you post the output of these commands here when you see this happening?

    Step 1:
    Command 1: ( In Terminal)

    '/System/Library/PrivateFrameworks/Apple80211.framework/Resources/airport --scan'

    Paste the results here.

    Step 2:
    Now Open console->system.log. Clear the display and Insert Marker.

    Command 2: ( In Terminal)

    'sudo /usr/libexec/airportd -d '

    Now reproduce the wireless issue you see and monitor the system log in Console.
    Wait for a few minutes so you see this issue happening.
    Then, Turn AirPort off and on a couple times to see if this issue still happens.

    Copy paste the system.log output here.



    Step 3:

    Next, when you see this issue happening, hold the option key down and click on the AirPort menu icon and get the RSSI and Transmit rate details and post them here.
  • Juan Avila Level 1 Level 1 (0 points)
    Well, after toying around with many of the settings on the MBA, I then began to work on the AirPort Extreme (Gigabit Version) and I discovered that the MBA would only connect when I selected "Interference Robustness" when configuring the MBA. This made a difference no matter what "Wireless Mode" the AE was in, be it 802.11n(b/g) Support, plain 802.11n(5Ghz), ect. So, try that out if you have an AirPort Extreme and MBA, and post your results. The MBA is running 10.5.5 with only update remaining (10.5.6).

    {This has posted in various threads by me, myself, and I, and I am only reposting so that many threads are aware of this. Hope it helps at least someone.}
  • Christopher Twomey Level 1 Level 1 (70 points)
    Hmm, I had the same problem on a MBA (rev A) with my home Time Machine (but not other wifi at office or coffee shops, etc. ). It would drop the connection every few minutes; sometimes get it back on its own, sometimes not. I could always manually re-acquire by going to the airport fan pull down and selecting my Time Machine. But it was a real hassle.

    (I didn't have Real Player, had already tried "Interference Robustness" and manually setting the channel to 9; all to no avail).

    I force quit "iTunes Helper" from within Activity Monitor. That solved it, and did not noticeably affect iTunes (perhaps fewer Genius suggestions or something? I don't know). Weird. Someone mentioned it on this or another thread. Anyhow, perhaps worth a try for some of you.

    (If that solves it, you may want to check your login items to see if it is automatically starting upon boot.)
  • nddaveman Level 1 Level 1 (0 points)
    YEah, I think if that was the answer this thread wouldn't be so highly visited. Just dealt with the same issue on a brand new MBA (timeout and incorrect password - even though it was the correct password), and it mysteriously just fixed itself after an hour of yelling at it.
  • Kuma0226 Level 1 Level 1 (0 points)
    I have the same problem !! BUT YOUR SOLUTION DOESN'T APPLY ON MY MBA : (
    I tried many other solutions, such as keychain repair and then default the keychain.
    or stick on one channel without using auto.

    I was quite happy with my MBA since last summer.
    Just few weeks ago, my 80GB HD failed right after i upgrade to 10.5.7
    I had Kernel issue first, the OS X couldn't boot up, always asked me to force turn off the power!
    I then went to Apple store to backup my important files then i sent in for exchange a new HD.
    I just get back my MBA for few days and suddenly i have this Wifi connection issue!!!
    Exactly like everyone else's problem

    I'm testing out if it's the hardware issue, ex. Airport, mainboard, or the connector of the antenna inside.
    I have one MB right beside, i can do cross testing and compare the result.
    I was aiming on the Airport Extreme that i just upgraded the firmware to 7.4.1
    (This version has bug for sure), because the MB has connection lost issue with this firmware.
    I load back to 7.3.2 firmware and everything back to normal except my MBA still on and off every minute! I did research on internet and found out so many users out there have the same issue!
    Now i'm thinking to do a fresh new install to double check and narrow down the possibilities on this issue, since the OS X on my new HD was installed by Apple store. I know they just do a clone install from maybe a retail version OS X because i found some settings are different then before ( i have FIREWIRE on my MBA ! ) and the keychain has been modified.

    I now thinking maybe the OS X version issue. I have to make sure this point so i need to do installation myself from the DVDs came with MBA.
  • menajemh Level 1 Level 1 (0 points)
    looks like after the new updated came to me the same problem again, and i found a post saying that apple uses a generic installation disk for all the computers they make. means they don;t use the proper installation way for the mba. so i reinstalled the whole os again from the air disks and updated the mba to the latest updates. after one week i had no problems so far
  • Chris_UCB Level 1 Level 1 (0 points)
    i've had this same problem connecting to a Netgear FWG114P. pinging the gateway didn't help, changing the channel didn't help. disabling IPv6 didn't help, static IP the MBA, no joy. all windows & linux machines do not suffer this problem.

    what seems to be happening at this site with the MBA is a WPA rekey timing issue. its reproducible. when the WPA rekey timeout was set to 30 minutes, the MBA would reliably disconnect at 30 minutes and stay offline until manually disabling, waiting and enabling the airport.

    changing the timeout to 90 minutes produced the same symptoms at 90 minutes. same result when changing the rekey timeout to 240 minutes.

    based on my understanding of how WPA works (differing the encryption for each frame), a simple solution is to set the rekey timeout to a period longer than one expects to be connected to wifi and use a really good password.

    there must be something going on during the rekey that causes the MBA airport to hiccup and fail.
  • rick sterback Level 1 Level 1 (0 points)
    I had to chime in on this one. I've been complaining about my MBA dropping my internet connection for months. I tried everything everyone tried, by the way I'd like to thank "Elk" for his multiple responses to my queries. Anyway, as a last resort I simply bought an Airport Express and replaced my Belkin 54G router. That was three weeks ago, not a single lost connection since.
    It works fine with the MBA, Pro, Windows, and even my Linux boxes. Doesn't address the problem directly, but it does eliminate the frustration, immediately. Apple does need to recognize the problem and correct it, but they don't seem to be too concerned, unless they're depending on the new OS to address the problem. But all of the solutions I've tried listed here failed, yet the simple addition of and Express solved it, end of story. Might want to try it rather than continue to deal with constant lost connections.
  • Layfield Level 1 Level 1 (0 points)
    my MBA was working fine with my Airport Extreme, however the other day I downloaded the firmware update to 7.4.2 and now my MBA has all of the problems described above. It says it cannot connect, for me to enter the password (even thought it already has the password filled in). When it does finally see the Airport Extreme it then says in the system preference / network under the Airport icon the following "Self-Assigened IP" and "airport has self assigned IP and may not connect to the internet". After a bit of turning on and off of airport it will then connect and comes up with "Airport is connected to NAME OF EXTREME and has the IP address 2002:3elf:364a:0000:0225:00ff:fef8:9954" Now I also have a MB on the same network. Firstly it connects no problem, secondly it say "airport is connected to NAMES OF EXTREME and has the IP address 10.0.1.1. So I turn Aiport on and off again on my MBA and sometimes it comes up with the 10.0.1.1 IP and works but 80% of the time it does not. I am now on the MBA connected via Ethernet.

    I wanted to roll back my Airport Extreme Firmware but where the **** do you download old firmware?

    HELP
  • dcl Level 1 Level 1 (0 points)
    This is likely a configd issue, see this thread:

    http://discussions.apple.com/thread.jspa?messageID=9738319&#9738319

    Try disabling the firewall or making changes to its setting to allow traffic.


    David
  • Bob Abendroth Level 1 Level 1 (5 points)
    Thank you menajemh.

    Yes, your post helped me. I read a few posts and first tried just changing to channel 9 (from automatic.) That didn't provide much help. Than I did what you said, I turned the IPv6 to "off" and things got much better.

    With my MBA, I have two airport problems (using Time Capsule). First, I get dropped. Second, file transfers to my MBA from Time Capsule are very slow. Changing IPv6 to "off" got the file transfer speeds up to "I can live with it" file transfer speed. It's still not great. I am guessing the MBA will now quit dropping the signal. All I can say about the problem is "yuk." Apple should really put some effort into helping those of us with this problem. (I don't appear to have these dropping problems with other wireless routers, only my Apple Time Capsule.)