Skip navigation
This discussion is archived

macbook air airport disconnecting solution for lots of people.

71339 Views 70 Replies Latest reply: Dec 23, 2009 10:11 AM by lmorris99 RSS
  • Harrison Spain Calculating status...
    menajemh wrote:

    Go to System Preferences/Network/Airport/Advanced and under the TCP/IP tab change >the Configure IPv6 to "off". Use WPA encryption, no WEP, i had this problem of >dropping the wireless connection on my macbook pro, my imac and my macbook air, >then changed this configuration and no more problems.


    Recently (I'm not sure if it was because of the recent massive update to Leopard), my Wifi connection from my Macbook to my Airport (GB) became VERY unreliable. When it was connected, the performance was terrible.

    I turned off IPv6 as per the article above, and the Macbook locked onto the Airport right away, and everything has been solid so far.

    Thank you!
    Macbook, Mac OS X (10.5.8)
  • Harrison Spain Level 1 Level 1 (5 points)
    menajemh wrote:
    This kind of solution u will find it on many topics in this forum, just i wanted to make it available for all of u that are having the drop wireless connection. sorry for my english.

    Go to System Preferences/Network/Airport/Advanced and under the TCP/IP tab change the Configure IPv6 to "off". Use WPA encryption, no WEP, i had this problem of dropping the wireless connection on my macbook pro, my imac and my macbook air, then changed this configuration and no more problems.

    I use a netgear router, changed router channel to 6, WPA encryption.

    I do not know if this is a Leopard problem or routers problems, and is not our job to do this, it's Apple's. We have to make apple know about this problem and help one each other on the best way we can. i've seen lots of people that have airport routers from apple and they are experiencing this issue also. so i believe we have to set things under last standards most frequently used. This kind of dropping connection happened to me everywhere till now, that i fixed those configurations.

    Please post other solutions or details that may help others.
    Thanks



    Recently (I'm not sure if it was because of the recent massive update to Leopard), my Wifi connection from my Macbook to my Airport (GB) became VERY unreliable. When it was connected, the performance was terrible.

    I turned off IPv6 as per the article above, and the Macbook locked onto the Airport right away, and everything has been solid so far.

    Thank you!
    Macbook, Mac OS X (10.5.8), Gigabit Airport Extreme
  • fearles1 Calculating status...
    I've also had the MacBook-Airport-OS X 10.5.?-Disconnect/NoConnect problem. I have found an interesting work-around - interesting in that it provides some direction regarding the nature of the problem. I've tried all the posted solutions other than going to WEP.

    When powering up with OS X default I get no connection or a seemingly weak connection ( 1-2 bars). If any, it only shows my network whereas there are a half-dozen networks in my neighborhood that used to consistently show up.

    I do a restart bringing up Windows XP. It also does not establish a connection. When I look at the list of available networks it only shows mine and with good signal strength. I then do a Repair Connection and it does its thing and makes a good connection. Also all the neighborhood networks pop up on the list of available networks.

    I then restart OS X and the system comes up with a solid five-bar connection and showing the other local networks. The connection is solid until I power off or sleep.

    What's with Apple? I've patiently waited through a couple of updates figuring that they would clean up the mess. I hate it, but Windows, it seems, is doing a better job than OS X. Hmmm....
    Macbook + G5 +Dell, Mac OS X (10.4.7)
  • j2222 Calculating status...
    Well, having owned a Macbook air for about 3 months, this may well be amy first and last Apple.

    Worked fine for about 2 months, but over the last month WiFi connectivity has just got worse and worse until now it seems to have stopped working. I've tried editing keychanges, disabling IPv6, changing channels, ping'ing routers etc and nothing works.

    I've had PCs for over 20 years (and have worked in IT all that time) and used WiFi since it first came out and have never had this sort of problem on a PC.

    It is a real shame because the MBA is a sweet little device.

    (Written from my trusty HP WinXP)
    MacBook Air
  • vandainfrance Calculating status...
    I have also bought my FIRST MacBook last April in the US. Since 1989 I have always used Windows but after Vista I got tired of it and I bought a Mac.
    I am deeply disappointed because the Airport constantly disconnects and Apple does not offer patches or any kind of support!!!
    Apple is supposed to be the ELITE company in computer technology but it just another money-making ruthless company like most of them!
    I will NEVER recommend this company and its technology again!
    MacBook5,1, Mac OS X (10.5.7), Airport DOES NOT WORK properly!
  • vandainfrance Level 1 Level 1 (0 points)
    I have also tried the tips some of you posted (thank you! At least "someone is out there"!) but my airport is still doing the same.
    I wish that Apple, instead of ignoring the problem, would find a solution!
    Thank you all.
    MacBook5,1, Mac OS X (10.5.7), Airport malfunction
  • j2222 Level 1 Level 1 (0 points)
    Well, after more fiddling around, I am beginning to think that maybe the airpot is just very intolerant of interference. I get reliable connection in certain parts of my house (15m away, through floors/walls) and bad sitting in my sitting room 3m from the base station, though my TV and 1 wall.

    Try moving around your location and/or moving the base station ... It wind of works for me - I just can't sit on my sofa and use my MBA! Sit on the floor 1m away and I get a solid connection!
    MacBook Air
  • applecore_eater Level 1 Level 1 (0 points)
    I just tried this now but it made my internet connection stop. I had been having problems with the internet dropping out every ten seconds but it seemed to have fixed itself after I restarted the computer. I think it has something with the computer going to sleep - all the internet connection problems started then when the computer woke up.

    So I thought I would try this out to prevent the problem of dropping out again. However, when I went into "Advanced" and "TCP/IP" the option was "Configure IPv4" not IPv6. But I turned it to "Off" anyway. As soon as I did this, the internet connection stopped.

    Still, I hope Apple fixes this problem because I want to put my computer to sleep often, to save power etc and if I have the internet connection dropping out every time I put it to sleep, it's going to be very inconvenient.
    MacBook Air 1.86GHz, Mac OS X (10.5.6), Nil
  • applecore_eater Level 1 Level 1 (0 points)
    I'm sorry. I changed the IPv4 and not IPv6. I didn't see the IPv6. Now I see it and have turned the configure part to off. I will see how it goes. I keep having problems with the internet not working after I put the computer to sleep and wake it up. Brand new computer too - MacBook Air 1.86 GHz. I never had this trouble before on my Powerbook G4.

    I will put the computer to sleep and see if the internet works properly afterwards with this change.

    If not, Apple should fix it. It is unacceptable. Don't they test a new computer's internet connection after it wakes from sleep during the testing stage?

    It's annoying. I expect a new computer to work properly from the get-go. I don't want to spend hours and days of my precious time calling support or hassling internet providers or browsing support forums when I buy a new computer. I did actually anticipate difficulties after buying a new computer (from experience) and put off buying a new computer for a long time because of the headaches. And it came true! I have spent the last three days setting up and working out the bugs (mainly the internet connection) to my new computer. I am studying for an important exam soon and so I have lost important time due to a faulty product of Apple's. Great. And now I am worried about putting Snow Leopard on MacBook Air because of the shortening of battery operation time. Wow! As I said, don't Apple test its products out????!!!!!!!!!
    MacBook Air 1.86GHz, Powerbook G4, Mac OS X (10.5.6), Nil
  • hansulrik Calculating status...
    I've inherited my sons MacBook. He got tired of the problem you so elegantly solved for me;-) Thank you
    MacBook Pro, Mac OS X (10.6.1)
  • lmorris99 Calculating status...
    Turning off Realplayer and realplayer downloader seemed to work for me.
    Macbook Air, Mac OS X (10.5.7)
1 2 3 4 5 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.