Previous 1 2 Next 20 Replies Latest reply: Jun 1, 2008 5:35 PM by Perrodulce
Robert Mccarter Level 1 Level 1 (0 points)
I continually get a window when syncing something to the effect that "iPhone cannot sync because is has disconnected". Of course, it is not disconnected and still shows up in iTunes. I have done the reset sync history described elsewhere on these forums, and that seems to work, for about a day. Do I have to reset the sync history every time that I want to sync my phone?

Running on MacBook Pro, intel processor, iTunes most recent version as well as Leopard up to date, most recent version of iPhone operating system too.

MacBook Pro Intel, Mac OS X (10.5.2)
  • Lawrence Finch Level 7 Level 7 (33,370 points)
    Have you tried reinstalling iTunes, especially if it has not been updated since installing Leopard?

    You might also look at other USB devices plugged in at the same time that could be drawing power.
  • Robert Mccarter Level 1 Level 1 (0 points)
    Yes, I've reinstalled iTunes 3 x's in the last 2 weeks. No other USB devices plugged in. Now, it won't even sync, it just says its syncing but stays this way indefinitely. Now I have to cancel the sync.
  • Lawrence Finch Level 7 Level 7 (33,370 points)
    The other cause of that error is bad data in the address book or calendar on the desktop. It is usually one or more badly formed records in the address book. There is a fix for this that involves finding the bad records, but I have not personally used it. Let's home someone who has jumps in.
  • Tammy Rasmussen Level 1 Level 1 (5 points)
    I am also having the same problem, can not sync contacts it tells me the phone is disconnected
    Tried different ports, powered off & back on, iTunes & iPhone have the most current updates,even stopped syncing all other info leaving only contacts.
    Really is a pain as I tried to call someone from the road earlier & the information on the phone was old info/wrong number.
  • Nathan C Level 5 Level 5 (6,260 points)
    Tammy Rasmussen,

    Try creating a group within Address Book. Set iTunes to Sync that group only to the iPhone, and then add contacts 10 or so at a time to that group and sync. When it stops working, add the contacts in smaller groups until you isolate which contacts might be causing an issue.

    If it happens with any contact in the group at all, the corrupted data could be on the iPhone.

    Hope this helps,

    Nathan C.
  • Robert Mccarter Level 1 Level 1 (0 points)
    I think I have this figured out, for those of you with this syncing issue: I think that if you are in the process of syncing and a phone call comes in, it corrupts the record being synced between iphone and itunes. Turn on airplane mode whenever you sync the phone, just to be safe.
  • zcattell Level 1 Level 1 (0 points)
    I am having this same problem, but it seems to stop syncing during the iPhoto import. I tried deleting the cache, but all that did was make the iPhone reload the selected photos and then the iPhone mysteriously disconnected again seemingly at the same point.

    Any insight?
  • Stuart Moore Level 1 Level 1 (0 points)
    I was encountering this issue and read the suggestions here. My iPhone was disconnecting during the "Syncing Photos" operation so I thought it might be something with iPhoto or one of the pictures. When I read that it could be something in Address Book I remembered that I had added 1 address from my "All" to my "Mobile Contacts" (the group I use for my iPhone) just before the last sync. When I removed that contact from the "Mobile Contacts" group everything worked fine. I even added a new contact with the same info but created from scratch and everything worked again. I'm not exactly sure what was different about that particular contact but it was definitely the problem.
  • zcattell Level 1 Level 1 (0 points)
    Stuart - thanks for that insight. I will try that when I get home tonight and report back.

    Message was edited by: zcattell
  • spatial Level 1 Level 1 (0 points)
    OK, well here's a wrinkle to this discussion and maybe some useful technical information. My wife and I both have iPhones. She has the 4GB and I have the 8GB. Because she has less room on hers, I limited her address book sync to certain groups but I have all the contacts on my phone. Her phone has been giving the "disconnect" problem but my phone has not. I reset her phone last night and synced successfully last night and this morning she asked to have all the contacts available on her phone so I set her phone to have all the contacts. When I synced the phone it gave the disconnect error again. I'm going to now reset her phone again to see if I can gat all the contacts onto her phone but I'm assuming that after the first sync its going to start failing again.

    Once again, my phone doesn't fail even with the same contact database.
    If its a corrupt contact database one would think her phone as originally set up would have been more likely to work correctly and my phone should have been failing.

    Could there be a memory availability issue? her phone is like 95% full whereas my phone is only about 80%.
  • Stuart Moore Level 1 Level 1 (0 points)
    My phone 8GB is about half full (or a bit less) so I don't think it has to do with the memory being too full.
  • spatial Level 1 Level 1 (0 points)
    So I've fixed our problem at least. When I rest the phone the first time I did a restore from backup and the problem persisted. The second time I did a restore to a "new" phone and I had to go in a reload all the music playlists and photo albums, etc. Turns out one of the music playlists that had previously been assigned to the phone was WAY too huge to fit but I never got a message saying that the music was a problem, alway the contacts. When I fixed the offending playlist and got rid of everything I know my wife was never going to listen to (AC/DC, Led Zepellin, you get the picture) everything started working fine. Our whole problem seems to have been that the sync function wasn't identifying (or notifying) that the amount of music I wanted on the iphone was impossible and it didn't start telling me that until I reset the phone.
  • Stuart Moore Level 1 Level 1 (0 points)
    This is definitely a "bug". The error I got was occurring during the iPhoto sync but the problem was with a bad card in Address Book.
  • jvanschoick Level 1 Level 1 (0 points)
    I had this issue as well and I solved it by removing the bad data.

    The easiest way I found to do it:
    1. Setup a new group in the address book (I called it "Temp")
    2. Set the iPhone to not sync the group (in iTunes, under the iPhone config, on the Info tab, in the contact section, select "Sync Address Book Contents" and then the radio button for "Selected Groups"; uncheck your new group)
    3. Look a the contact that might be trouble - it will be in the ones you added last
    4. Move that contact to "Temp"
    5. Delete it from your regular group (the Address Book will prompt you to either "Delete" it completely or "Remove From Group" - select "Remove From Group")
    6. Go back to iTunes and Sync again - if you found the bad address book entry, problem solved - otherwise, repeat

    This will help you isolate the individual entry causing the issue.

    Once you find it, delete the entry completely and then create a new card. Re-enter the new information. Be sure to type all the information in on your own - don't copy & paste. In my case, I suspect copy & pasting from a web page into the address book entry is what caused the problem.

    Hope that helps!

Previous 1 2 Next