12 Replies Latest reply: Apr 16, 2008 6:46 PM by kureno
Nobitasan Level 1 Level 1 (0 points)
I have the Japanese version of Windows XP but would like to run the English Safari version. However, whether I download Safari through the UK, US, German, or French site - the downloaded file is the same, and it will install the Japanese version of Safari.

I never had this problem with any other program.

Does anybody know how I can set the program language? With other programs, I could usually choose the language before downloading but I couldn't find any such feature with Safari.

Many Thanks,
Andreas

Windows XP
  • DZGH_Operator Level 1 Level 1 (105 points)
    It's very easy:

    - Quit Safari
    - Go to your "Safari\Safari.resources"-folder
    - Search your language folder (I think it's ja.lproj) and either delete or rename it
    - Start Safari again and it should now be in English
  • sapper Level 1 Level 1 (70 points)
    Hi,
    Hopefully, you should be able to select the preferred language you wish to work in.
    Go into System Preferences and Click on International in the 'Personal' section. In the 'Language' pane, you should be able to set the preferred language. Note the wording to the right of the list of languages
    which reads 'Drag languages into the order you prefer for use in application menus, dialogs and sorting...' with the button below "Edit List". Clicking on this will open a pane 'Select the languages that appear in the Languages list'.
    I'm not sure what will happen, but if you uncheck all languages except English, this could be the desired or preferred language chosen to correct your problem. Hope this helps.
  • Nobitasan Level 1 Level 1 (0 points)
    Thanks to both of you. Sapper's response sounds promising. It didn't work immediately, but I will try to reinstall Safari under the new setting and see whether that helps.
    DZGH_Operator's unconventional method worked for the menu, thank you! But other items (e.g. Google search) still remain Japanese. Any ideas?
    Many Thanks again.
  • Gran Maestro Level 3 Level 3 (685 points)
    Hi there everybody.
    I have the opposite problem here.

    I am running an american/english system and want my Safari version to speak Italian, rather than English.
    I tried renaming the it.lproj folder in en.lproj after having removed the latter but that didn't work.
    Interestingly, upon starting Safari after the hack, I get the setup/installer window popping up asking me to wait for installation to complete, in Italian language.
    When finished, Safari starts, again in English.
    In the resources folder however, I find that a new folder it.lproj has been rebuilt...

    System language preferences are all set to Italian, not really sure where to dig in further, as Windows isn't really my cup of coffee...

    Perhaps some experienced Safari/windows users can shed some light into dll-****...

    Thank you

    /P
  • DZGH_Operator Level 1 Level 1 (105 points)
    Gran Maestro, please try the following:

    Copy everything inside the it.lproj folder to your en.lproj folder and see if it works. If this don't work, then copy the files of it.lproj also to en_AU.lproj, en_CA.lproj and en_GB.lproj.

    Hope this is working for you
  • Gran Maestro Level 3 Level 3 (685 points)
    Hi there DZGH_Operator.

    Copying all files from it.lproj into en.lproj did the trick.
    A horrible hack, but very effective indeed.

    Thank you a ton for suggesting, let's hope Apple will fix this otherwise superb application.

    BTW, as I posted somewhere else already, iTunes on the same computer and settings works using the proper settings (Italian) without any external fix whereas QuickTime doesn't.

    Looks like an obvious bug of the installer.

    Ciao

    /P
  • forever8always Level 1 Level 1 (0 points)
    I tried doing this, but it doesn't work.
    When I reopen Safari, the language changes back to what I had before and when I look at the resource folder, it recreates the folder I had deleted.
  • DZGH_Operator Level 1 Level 1 (105 points)
    @ Gran Maestro: I'm glad it's working now

    @ forever8always: Please try to copy the content of the language you want to use (*.lproj-folder) to the en.lproj folder.
  • tangv3 Level 1 Level 1 (0 points)
    Where do I find 'System Preferences'? Is it somewhere in Safari or somewhere in Windows?
  • hopkapi Level 2 Level 2 (150 points)
    The System Preferences sapper is referring to is the one in Mac OS X, which isn't much use if you're on Windows.
  • SAMuel B Level 1 Level 1 (0 points)
    I deleted the folder of the language I didn't desire and I got it back to English -it worked. I think Safari should have the option to do though, like itunes does for example.
  • kureno Level 1 Level 1 (0 points)
    Thanks a lot. This post saved me a lot of time.