8 Replies Latest reply: Jun 17, 2008 8:43 AM by klong
klong Level 1 Level 1 (25 points)
Since I use Leopard, Once I plugin a Firewire harddrive, it is not possible to unmount it unless I reboot the computer.
Tried to repair permissions, tryed to rebuild Directory tried… tried…
Drives (several) mount/unmount normally on my other computers (G4 Panther).
Has anyone seen this?
Thanks for your help.

OSX10.5.2, MacBook Pro 2,5GHz.

macbook pro 2.5GHz, Mac OS X (10.5.2)
  • 1. Re: can't unmount a hard drive
    V.K. Level 9 Level 9 (56,120 points)
    try doing it from disk utility.
  • 2. Re: can't unmount a hard drive
    Dak Level 2 Level 2 (365 points)
    i recently had this problem. what happened to mine was the hard drive was corrupted. u mentioned you repaired permissions but try repairing the disk. also, what exactly is the reason you cannot unmount the disk? does it say the disk is in use, or something else?
  • 3. Re: can't unmount a hard drive
    smithrj Level 4 Level 4 (1,540 points)
    Hi, is is a Western Digital?

    Ray
  • 4. Re: can't unmount a fw hard drive
    klong Level 1 Level 1 (25 points)
    Yes, it says the disk is in use. The only way to unmount is to reboot the computer. Problem occurs on several FW drives.
    When I try to repair with Disk Utility, it just hangs. Disk Warrior, Drive Genius can't find a problem. But, strangely, Drive Genius doesn't even allow to rebuild/repair the internal drive and DiskWarrior won't allow me to look at it either. If I try to repair it with Disk Utility, it does not work (hangs). If I also try to repair with Disk Utility once booted from the installation CD system, same thing. Doesn't get past a certain point and hangs.
    Seems to me all this is related to the internal drive, even though some FW drives can mount/unmount without problem.
    All external FW drives have been checked and/or fixed with another computer (G4/OSX10.3.9) and function perfectly with it. Not on Macbook Pro/Leopard.
    Any help someone. After reading some posts it seems related to the same "unknown" problem…
    Thanks
  • 5. Re: can't unmount a hard drive
    klong Level 1 Level 1 (25 points)
    no not a WD but a Seagate 200Gb/7200 internal and a La Cie 500Gb FW external
  • 6. Re: can't unmount a hard drive
    Richard Shanks Level 1 Level 1 (50 points)
    I have the same problems with firewire drives not being able to unmount.

    At this point, I want to wipe the drive and start over but Disk Utility, Disk Warrior, and Tool Tech Pro 4 won't let me because they won't unmount. Disk Warrior says "files still in use" but nothing is open.

    This happened to me on about 3 or 4 different firewire external drives now... thought it was a Maxtor problem but it seems to do this with Wester and Seagate too.

    I just want to wipe the freakin drive.
  • 7. Re: can't unmount a hard drive
    John Lehet1 Level 1 Level 1 (5 points)
    I have this problem too, but it's not tied to any drive or any corruption, as far as I can tell. Sometimes I can kill the process -- with lsof I can see "cwd" running on that disk. Sometimes nothing helps. As I use Firewire 800 every day, this is a big problem. I've had it with every version of leopard, never with Tiger. I hope 10.5.3 fixes it!
  • 8. Re: can't unmount a hard drive
    klong Level 1 Level 1 (25 points)
    For all the ones who answered. I recently got a workaround (if not a definite solution).
    Spotlight is the faulty one.. So in Spotlight preferences, disable the hard drives you do not want it to index.
    Of course searching them is harder, but at least you can mount-unmount them at will without restarting the computer.
    Thanks to the 'Apple Genius' who told me!
    bm