8 Replies Latest reply: Mar 27, 2008 1:07 PM by Woodwyn
Woodwyn Level 1 Level 1 (0 points)
With Verizon I used selective unblocking of my caller ID with contacts in my Address Book. Basically "*82" entered before the number. Evidently GSM devices like iPhone can't use *82, but instead "*31#"

The problem is, my Address book is populated with phone numbers that begin with *82.

Is there any way to do a mass find and replace in Tiger's Address Book and replace all "*82" with "*31#"?

If not, before I start the laborious process of manually replacing *82, is there a better way to deal with this? Maybe some kind of custom prefix feature?

Does Leopard improve this functionality?

MacBook Core Duo 2.0, Mac OS X (10.4.11), 2GB RAM/160GB 7200 HD
  • AppleMan1958 Level 7 Level 7 (27,405 points)
    If you had Leopard, there is an inexpensive Database program called Bento that is able to access the Address Book and the Calendar through database tables.
  • karmalaw Level 1 Level 1 (0 points)
    I am on AT&T and my iphone uses *82 just fine... no need for 31# or whatever.

    BUT, the code you use is dependent on your carrier, not your phone.
  • DaVBMan Level 6 Level 6 (9,265 points)
    I always used *67 for cell and land lines. Thought that was the universal "Private Number" prefix.
  • karmalaw Level 1 Level 1 (0 points)
    He's not trying to block his clocks.. he's trying to UNblock them. AT&T and some other carriers offer a feature (you have to call in for it) that makes ALL Of your outgoing calls blocked/private. BUT, when you want to call someone so they know it's you, you use *82 as a prefix to the number.
  • karmalaw Level 1 Level 1 (0 points)
    oops that's "not trying to block his CALLS""

  • DaVBMan Level 6 Level 6 (9,265 points)
    Ah. Thanks for clarification.
  • Woodwyn Level 1 Level 1 (0 points)
    Obviously anybody who has an iPhone in the US has ATT or they have cracked it. Also, I never meant to imply that it had anything to do with the iPhone, nevertheless, the issue is joined at the hip as I need a way to modify all of my *82 access codes on my iPhone.

    Where in the US do you live? I tried *82 in Los Angeles and it definitely did not unblock my outbound calls. However when I used *31# as described an another post, the calls unblocked just fine.

    Since *82 obviously doesn't work in Los Angeles, it must be location centric as well as carrier specific.
  • Woodwyn Level 1 Level 1 (0 points)
    Finally called ATT regarding caller ID blocking. Regardless of whatever else works, i.e. *31# to unblock caller ID, ATT tells me *82 is the only official UNIVERSAL method to do it.

    They eventually told me it was a device issue that *82 did not work and sent me to Apple. Apple told me this:

    The iPhone controls its own caller ID broadcast. If you turn the iPhone Show Caller ID off, it will override any setting you may have with the carrier. So *82 simply will not work, because the iPhone won't send the caller ID with the call, or it will countermand the *82 code, however it works.

    Even though this sounds counter-intuitive, you have to have the carrier ATT BLOCK your number at their end. Then, you have to set the iPhone's Show Caller ID to ON. This way, the iPhone sends your number no matter what. It's the carrier ATT that actually does the blocking now. When you dial *82 on the iPhone under these conditions, the code tells the carrier ATT to unblock the settings in their computer. If you don't dial *82 on your iPhone, your number will NOT be unblocked regardless of whether your Show Caller ID setting is on or not.

    Confusing? You bettcha.

    Somehow *31# will override the iPhone's blocking feature, but if you want to keep things standardized across the board with *82, call ATT, have them block your number at the switch. Then turn your iPhone Show Caller ID to ON. All numbers dialed from the iPhone will now be blocked. When you dial *82, the number will now be selective UNBLOCKED.

    The reverse is also true. If you want your number unblocked all the time and only selectively blocked from time to time, which seems to be ATT's default settings, make sure the iPhone is set to Show Caller ID On. Then *67 will block the specific number as you dial it, no need to run back to the settings menu to switch it back & forth.