4 Replies Latest reply: Nov 11, 2005 1:07 PM by Keith Fletcher
Keith Fletcher Level 1 (5 points)
I have a Packard Bell Ixtreme IX9708 P4 2.0 Ghz desktop PC (Operating system Windows XP and Service Pack 2)directly connected to my Powerbook by an Ethernet cable. The PC is also connected to an HP officejet v45 inkjet printer/copier/scanner/fax machine, a Maxtor One Touch External Hard Drive and the Internet via a NTL cable modem. I am the Administrator on both computers.

With the Powerbook and PC connected, I can access files drives etc on the PC from the Powerbook and vice versa. I am, however, unable to access the internet from either machine. Each time I click Network Status in System Preferences/Network it says “Built in Ethernet is currently active and has the IP address You are connected to the Internet via Built in Ethernet”.

I also experience two problems when I try to print documents on the Powerbook using the printer attached to the PC. The first (despite the printer action dialog box on the PC showing that the document is in the printer’s print queue) was that the printer printed page after page and I had to stop the print job. Some of the pages were blank. Others had lines reading something like
42/FontType resourcesstatus {pop pop false} {true}ifelse
%APLsfnt Begin
{current file 0(%APLsfntEnd\n)/SubFileDecode filter flushfile}if /FontType 42 def.
I have tried deleting the printer from the Mac software and adding it afresh to no avail. I am now told the printer is “Stopped” when I try to print. This happens despite the PC showing the printer’s status as “Ready”.

The Powerbook printer configuration says “Print using “Generic Postscript Printer””. Some support and discussion websites

1)refer to this in relation to laser printers and

2)seem to suggest that you need a printer driver on both the PC and the Powerbook. Neither the HP website nor linuxprinting.org have drivers for my printer that I could use on my Powerbook.

I should appreciate any help that I can get to solve the above problems.
  • Henry B. Level 9 (78,690 points)
    The "Generic Postscript Printer" driver will of course not work with your non-Postscript OfficeJet V45. If you do this, you will get reams of printout of raw Postscript code - which is exactly what has happened to you.

    You need to use the MacOS printer driver provided by HPIJS found at http://www.linuxprinting.org/macosx/hpijs/ . I don't see a listing specific for the V45, but perhaps the driver for one of the other V40 series printers will work - it has to, because there are no other options.
  • Keith Fletcher Level 1 (5 points)
    Thank you Henry B.

    I have downloaded and installed the Officejet v40 driver you suggest. However, I am still unable to print a laptop document. I am told the printer is "Stopped" despite the Windows PC saying that the printer is ready. I am also told "Unable to connect to SAMBA host foomatic-rip version $ Revision followed by "NTStatus_NOMemory". Disabling the Windows PC firewalls has no effect.

    As regards accessing the Internet, changing a firewall rule on my Windows PC has allowed me to access the web from that computer when it is networking with the laptop. I am, however, still unable to access the internet from my Powerbook when they are connected to each other.

    Any help on these outstanding matters would be very much appreciated.
  • Rick Van Vliet Level 5 (6,370 points)
    Keith, Hi...

    So, you're using your Windows to enable internet connection sharing? is that what you mean?
    A few more details on how you're actually connecting these two computers (direct with ethernet? Wireless? Through a router? Is there an Airport base station involved?)

    And how does this PC get to internet? dialup? DSL? Cable? who's your Internet provider?

    Are you running any Norton protection on the PC? What antivirus/security are you using on PC...? (this 'NO_memory' error may point to norton.)
  • Keith Fletcher Level 1 (5 points)
    Hi Rick and Henry B

    Thank you both for taking the time to think about my Powerbook problems. You will no doubt be pleased to hear that your replies prompted me to resolve the situation.

    The problem I had printing documents on the laptop using the printer attached to the PC was caused by me forgetting that computers are case sensitive when you enter such things as passwords. The the PC's computer name and the name of the workgroup as they appeared in the PC's My Computer Properties window were "MYPC" and "MSHOME", respectively. The equivalent entries in My Network on the laptop were "Mypc" and "Mshome". I made the mistake of using MYPC and MSHOME in the laptop's Printer Setup Utility. The problem ceased after I used Mypc and Mshome.

    The Internet access problem was caused by something similar. The PCs Ethernet (D-Link DGE-528T Gigabit Ethernet Adapter) Internet Protocol (TCP/IP)settings "Use the Following DNS server address" option was selected. The contents of the "Preferred DNS server" and "Alternate DNS server" boxes were and The equivalent settings for the Powerbook Built in Ethernet were, and Again ensuring that I used identical DNS IP addresses in relevant boxes on both computers solved the problem.

    In closing I would like to thank you both for making me review what I had done. And to say to Henry B he was right when you said the Mac OS printer driver provided by HPIJS for the HP V40 series found at http://www.linuxprinting.org/macosx/hpijs/ would work.