6 Replies Latest reply: Apr 14, 2008 7:53 AM by AndyO
MacMiniSandrine Level 1 Level 1 (0 points)
It used to work fine, I have Tiger, no major update or any changes lately. The Mac Mini will not "swallow" any discs, if I push it in with my nails, the eject mechanism works and ejects the disc but it won't take it in. Do you think it's a hardware problem? Thank you for any help!

Mac Mini, Mac OS X (10.4.11)
  • AndyO Level 6 Level 6 (17,050 points)
    Welcome to Apple Discussions!

    First thing to check is that there is not a disk already in the drive - it is possible even if it doesn't appear on the desktop, and the symptoms you describe are not dissimilar to what you would expect if the drive is already occupied. Reboot your system while holding the (left) mouse button down. If there's a disk in there, it'll attempt to spit it out during the startup process.

    Assuming no disk, make sure you are feeding the disk far enough for the mechanism to grasp it (it needs to be almost all the way in).

    After that, I would try a PMU reset if it is a PPC Mac mini, or an SMC reset if an Intel model - instructions as follows:

    To reset the PMU +(PPC mini only)+
    -Unplug all cables from the computer, including the power cord.
    -Wait 10 seconds.
    -Plug in the power cord while simultaneously pressing and holding the power button on the back of the computer.
    -Let go of the power button.
    -Press the power button once more to start up your Mac mini.

    To reset the SMC +(Intel mini only)+
    -From the Apple menu, choose Shut Down (or if the computer is not responding, hold the power button until it turns off).
    -Unplug all cables from the computer, including the power cord and any display cables.
    -Wait at least 15 seconds.
    -Plug the power cord back in, making sure the power button is not being pressed at the time.
    -Then reconnect your keyboard and mouse to the computer.
    -Press the power button on the back to start up your computer.
  • MacMiniSandrine Level 1 Level 1 (0 points)
    Thank you for your help. Resetting the PMU helped get the CDs/DVDs in but now it ejects them after a second or 2 of loud noise. I tried a few CDs and DVDs (some that worked in the past)with no luck. The sound while it's trying to read the CDs is much louder than in the past which makes me afraid that it's hardware failure??
  • AndyO Level 6 Level 6 (17,050 points)
    It could indeed be a hardware failure, though the fact the system attempts to read the disk before it spits it back out suggests that it may also be little more than a dirty lens. Thus I would be inclined to try a lens cleaner before assuming the drive itself is at fault.

    After that, make sure that the drive appears correctly in the System Profiler (go to About This Mac in the Apple menu, then click the 'More Info' button. The optical drive should be listed under the ATA tab). If it's shown correctly there by make and model then the hardware is correctly recognised by the system.

    If it does turn out to be the drive, rather than replacing it internally, it might be worth considering an external firewire optical drive. That way you can get a DVD burner of somewhat better performance and reliability without having to open the system and at a lower cost than a repair is likely to be. http://eshop.macsales.com/shop/firewire/optical-drives/ has some possible options to consider. The only downside of adding an external drive is that you may need a (free) utility called PatchBurn to get the drive recognised correctly by iDVD.
  • MacMiniSandrine Level 1 Level 1 (0 points)
    Thank you so much, I will follow your advice, it does sound like it's dirty, I didn't know they had lens cleaners. I called Apple Care and my 3-year protection plan expired 20 days ago, ins't that the way it always go!
  • zurbo Level 1 Level 1 (0 points)
    I am having a similar problem. My Mac Mini will not allow me to insert any discs. I've tried all methods for ejecting any disc that may be in there, to no avail. I followed your instructions and do not see the optical drive listed under ATA. Does this mean the drive has failed? Any other troubleshooting steps to follow before I throw this thing in the garbage. It's basically brand new and I've had many problems with it already.

    Thanks for your help.
  • AndyO Level 6 Level 6 (17,050 points)
    Welcome to Apple Discussions!

    If there is no entry for an optical drive under the ATA tab of the System profiler, then it means the drive is not visible to MacOS. Further, if there is no sign of life from it when you attempt to insert a disk, then it means the drive itself has a problem, and is likely failed.

    Before you toss it in the trash, it might be worth checking into replacing the faulty optical drive with a firewire connected external burner. More reliable, easier to install and set up of course, and actually cheaper than a repair. Have a look at http://eshop.macsales.com/shop/firewire/optical-drives/ for options.

    Of course, if it's under warranty, contact Apple or a local approved service provider to have it repaired.