6 Replies Latest reply: Feb 13, 2009 9:00 AM by simbag
nilrem Level 1 Level 1 (0 points)
I have recently purchased a Time Capsule and use it as a home router and network access storage. It works great wirelessly with my MAC notebook, and wired with my Windows Vista Desktop. However, none of my Widows devices will access the wireless network. One device (Dell desktop) bluescreens on reboot when the Linksys wireless g card attemps to load (it is fine if I turn off the Time Capsule or disable the card). Latest firmware, fresh install. Another laptop with an SMC wireless g "sees" the network, but will not connect after entering the password. No IP address assigned. Latest Driver. My Windows Mobile device does not connect either. All of these devices connect fine to my old router, a $16 Netgear router. I spent a lot of money on this device and it was listed as compatible with Windows XP SP2, which I am using. Any suggestions. Firmware 7.3.1 (previous firmware as bought had the same problem).

Dell Dimension, Windows XP Pro
  • nilrem Level 1 Level 1 (0 points)
    Well, here is an update to anyone who may also have difficulties with the Time Capsule and Windows. Dell: Unistalled the Linksys card and installed a D-Link. No more blue screen, but no internet even though an IP was assigned. Changed the encryption to WPA from WEP and it worked. HP with Intel PRO/Set 2100: Removed the Intel connection software and let Windows handle wireless connections. Now it worked. HP PDA: Still no luck. Am I the only one with Windows issues?
  • nilrem Level 1 Level 1 (0 points)
    Further update: The SMC wireless g pc card will connect to Time Capsule if you uninstall the connection manager, then load the driver only. It seems that many of the third party connection managers are not compatible with Time Capsule.
  • Reinis Traidas Level 1 Level 1 (0 points)
    Good thread.

    I am having similar issues with TWO separate TC units, a 500GB and a 1TB one at different locations. Everything works fine except there always is a rogue Windows laptop that sees the network, but is simply unable to connect to it. The signal is strong, but nothing happens after entering the WPA/WPA2 password. I've tried different configurations, WEP and all kinds of things - no luck.

    All the macs on the network are able to connect well. But the IBM ThinkPad T41 just won't connect. Same for another Fujitsu-Siemens laptop at another place, who was able to connect up until I re-installed XP. Now it's the same issue. Can see the network, but can't connect.

    Any ideas?

    Message was edited by: Reinis Traidas
  • VA2020 Level 4 Level 4 (3,450 points)
    Can't think of any except to try re-entering the WPA2 password "very carefully" during TC setup of the wireless network and entering the password again on the XP machines.
  • diegodevil Level 1 Level 1 (0 points)
    I have also the problem of connecting my Windows xp to a Time Capsule.
    I've tried with a Linksys wireless "n" card and my computer always hangs up just when it connects to the network. No problems with other router.
    Then I tried with another card, just an USB D-Link wireless "b/g" card and it connects OK. But i want to use the speed of the Time Capsule, not just 54 mbps.
    No problem with my iMac.
  • simbag Level 1 Level 1 (0 points)
    Just a suggestion, as I have had problem finding my TC after installing Parallels 2.5, and Windows XP. Couldn't work out for life of me why I couldn't find the TC but I could connect to the internet. Then i had a lightbulb moment!
    Have you installed Airport Utility? Did this, lo and behold, there's my TC!!!
    Download from here:

    http://www.apple.com/downloads/macosx/apple/application_updates/airportutility53 1forwindows.html