0 Replies Latest reply: Mar 28, 2008 1:38 AM by MrSteveee
MrSteveee Level 1 Level 1 (70 points)
Frequently (always?) when I purchase a TV show on AppleTV it will prompt me that it is ready to start playing, but then shows a blank screen (white). Then none of the rest of my shows will play, with AppleTV claiming that they are not authorized to play. Later, when the show is totally downloaded, my purchased content will still not play. This causes me to have to power cycle the Apple TV to view anything I've purchased. After cycling the power-which causes all shows to work--the new show doesn't appear in the menu at all.

I've also tried restart, restore, factory restore, de-authorizing, reauthorizing, re-syncing, manual sync... but nothing brings back my missing show(s). I checked my iTunes account and I've been billed for the shows, but I don't get to view them as they magically disappeared. I've registered a problem with iTMS but I'm frustrated that I can't watch what I've purchased. This is a recurring problem to the point of predictability. Any suggestions?

Message was edited by: MrSteveee

BlackBook 2.2gHz Core Duo, Mac OS X (10.5.1), 4 GB RAM, Superdrive, 150 Gig HD