4 Replies Latest reply: May 22, 2008 1:20 AM by Justin Ancheta
Bugs Nelson Level 1 Level 1 (0 points)
I have a MacBook Pro purchased December 2007 which still has the embedded numeric keypad and "num lock" on F6.
I added an external silver numeric Targus USB keypad (Model: PAUK10U Item: 10 from Office Depot) and initially had a problem with the MBPro recognizing it. It now is functioning normally. Here's how I did it:
When you first plug it in, the MBP will recognize a keyboard was added via USB. The "press the key to the right of the fn key" instruction will not work since there is no fn key on the external keypad as there would be on a keyboard.
If you have already gone through this step or closed out the dialog box accidently, you can find it in Apple>System Preferences>Keyboard & Mouse>Keyboard>[Change Keyboard Type]>[Continue]>(hit any key)>[Skip]>[ANSI(United States)]>[Done]. Follow these steps if you are currently at this initial newly found keyboard dialog box as well.
You may notice that when in Excel, a number will appear momentarily, but not register. To correct this, press the Num Lock key ON THE EXTERNAL KEYPAD and while holding it down, press a number key. Then release the Num Lock key. The Num Lock LED will remain on during this procedure and you hopefully will find that all keys function normally as marked in or out of Num Lock mode.
Best wishes, Bugs

MacBook Pro 12/2007, Mac OS X (10.5.2)
  • acm1941 Level 1 Level 1 (0 points)
    This post was invaluable to me and worked like a charm. I use Quickbooks, and had the same issue as within Excel where the number appears momentarily but does not register. Pressing the Num Lock and a number simultaneously on the external keyboard worked in Quickbooks as well.
    Thanks again!
  • Eliexer13 Level 1 Level 1 (0 points)
    Well, I tried what you said, but It did not work. I am using a compaq numeric keypad, Model: CPQ19nkp, and It does not have num lock ligth, just the key. Can you help me?
  • mathfrank Level 1 Level 1 (0 points)
    This tip was great. I was wondering if something was wrong with my keypad, and this tip did the trick. Thanks so much for figuring this out and posting the answer.
  • Justin Ancheta Level 1 Level 1 (10 points)
    Eliexer13 wrote:
    Well, I tried what you said, but It did not work. I am using a compaq numeric keypad, Model: CPQ19nkp, and It does not have num lock ligth, just the key. Can you help me?


    I actually have the exact same external USB keypad as you do (Compaq CPK19NKP) and the "hold the Num Lock" trick didn't work for me - but the trick at the Mac OS X Hints forums (http://forums.macosxhints.com/showthread.php?t=44298) did:

    "Opening the Keyboard viewer (from the input menu in the menubar; set this up via System Preferences-->International-->Input Menu) and pressing the affected keys on the keypad shows the problem; depressing "7" shows keypad 7 pressed, and releasing it shows "clear" (top left of the keypad) pressed. I don't know why this double input occurs, but I have fixed the issue, at least for Excel. I created a keyboard layout that re-maps "clear" to give no input. This was fairly easy using Ukelele: http://scripts.sil.org/cms/scripts/page.php?site_id=nrsi&id=ukelele

    I started with a standard US keyboard layout in Ukelele and pressed <function> to show the keypad-within-the-macbook-keyboard keys; double-clicked the "clear" key (in place of "6" on the QWERTY keyboard); and deleted the character code in the resulting pop-up. Save this layout to ~/Library/Keyboard Layouts/ (or /Library/Keyboard Layouts/); log out and back in; use the International preferences to include your saved layout in the Input Menu; and then select this input mapping. My Targus keypad now works fine in Excel."

    After following his instructions, I can verify that this allowed me to use my keypad in Excel.