1 Reply Latest reply: Mar 31, 2008 10:18 PM by Niel
Scott Mosher Level 1 Level 1
Hmmmm... so I"m going from the default iTunes (v.6) on OS 10.4.2 and trying to upgrade to the downloaded version of iTunes 7.6(.1) and though the documentation says minimum system requirements of 10.3.9, here I am running a newer operation system, but getting an error message from the installer that I need to run 10.4.9 or later. This seems to be ridiculous. To make matters worse, I can't seem to find other locales to download iTunes 7.2, etc.

Any help would be appreciated.

Powermac G4, Mac OS 9.2.x, I'm also running OS 9.2.2 on my other (external) drive!
  • Niel Level 10 Level 10
    The current version of iTunes has only been qualified on Mac OS X 10.39 and Mac OS X 10.49 and newer. Apple often only tests new software on the current version of Mac OS X and the last version of the previous revision.

    (31171)