Previous 1 2 Next 17 Replies Latest reply: Aug 13, 2008 1:22 PM by Bill Fishman
r-macho Level 1 Level 1 (0 points)
Printing over wireless networks, either over a windows environment at the office, or at home on my airport always gives me an "network host busy problem". Plugging the printer directly into my macbook via usb cable will work, but never wirelessly. Also my failed document seems to prevent other macbooks without problems, until I clear my list or restart the printer.

help!

macbook, Mac OS X (10.5.2), my white baby
  • dougup Level 1 Level 1 (0 points)
    Bump!

    We have an Airport Extreme and Airport Express(original)-extended wireless network. I have been able to print to our networked printer (Phaser 6120) plugged into Airport Extreme without problems until today. It just stopped working. Tried deleting the printer and now it doesn't show up when I try to re-add. When I add it as an IP Printer and try to print, I get the network host busy message.

    We just realized we're now getting the same messages from our Mac Pro as well which is wired to the Airport Extreme. So seems like a Printing issue, not a wireless/wired issue at this point for us.

    Doug
  • Mark92691 Level 1 Level 1 (5 points)
    I have the same error message, with one of my two wired network printers. See my thread:

    http://discussions.apple.com/thread.jspa?threadID=1474517&tstart=15

    My guess is that there is a subtle defect in Leopard that causes it to "believe" that a busy status exists when, in fact, it doesn't. The local Apple store is claiming that my problem lies with my router, but the same router works between my MBP and the other network printer, and between a PC and this printer. Also, everything worked perfectly under Tiger, which has lead them to claim that manufacturers must modify their code/firmware to keep up with Apple upgrades.
  • greg sahli Level 7 Level 7 (24,595 points)
    r-macho,
    Please give us more details - what printer? Is it hooked to a Windows PC and you're using Windows Printing? Has it ever printed that way?

    tag-alongs,
    You will get more help if you post a new topic - go to the top of the Printing Forum and click "Post New Topic." (upper left area above topics)
  • r-macho Level 1 Level 1 (0 points)
    Greg Sahli,
    Detials: It's hooked up to a linux server at work,
    and it's the same problem at home, where I have my printer hooked up to a airport express base station connected to a Samsung ML-2010 Laser Printer.

    It used to print fine, and it was easy to see bonjour printers in 10.4, but ever since I upgraded to 10.5 it's not as easy to just select bonjour printers from the new menu, and... it always gives me the error message "Network Host Busy Problem". I have to plug my printer into my computer directly to print.
  • greg sahli Level 7 Level 7 (24,595 points)
    As a workaround at work, I suggest you find out the queue name and IP address of the server and print via IP printing > IPP protocol. That will also help troubleshooting.

    There have been other mDNS (Bonjour) problems reported here - I don't remember the fixes.
  • dougup Level 1 Level 1 (0 points)
    FYI...I upgraded my Xerox Laser Printer drivers and was able to install it via IP Printer method. Still not showing up in Bonjour, but it's working now.

    Doug
  • Tommy Moore Level 1 Level 1 (20 points)
    I don't think this is a Leopard issue. I am getting the same "network host ... is busy" printer message using 10.4.11. What is new in my work flow is an Airport Extreme. I have also been having ftp issues since replacing my Airport Express with the Airport Extreme. My HP laserjet 1200 is plugged into the Extreme. I have deleted and re-added the printer numerous times with some success, but the printing problem keeps coming back.
  • drekosh Level 1 Level 1 (0 points)
    I am having exactly the same problem. Network printing to an airport express connected printeris a bust, printing directly from USB port to the machine works every time. What I have discovered is that if I reconfigure the printer setup a second time, it will work again once, but then the same error message appears. I even setup the printer as a shared printer through the USB to a second wirelessly connected computer. It worked once, but then even in that configuration I started to get the same error message.

    I believe this started when I installed Leopard, so I am partial to the notion that it is a Leopard problem. Everything was working fine with Tiger for almost 6 months. Help!!!!
  • drekosh Level 1 Level 1 (0 points)
    taking your advice, I started a second thread...see.

    http://discussions.apple.com/thread.jspa?messageID=7047378&#7047378
  • Tommy Moore Level 1 Level 1 (20 points)
    As a follow up. If I reboot the Airport Extreme, the printer works again without issue, so I am thinking it's a Airport Extreme firmware issue.
  • drekosh Level 1 Level 1 (0 points)
  • ptroxler Level 1 Level 1 (5 points)
    I believe it is not a apple problem -- had the same issue with a brother HL5250DN
    looking at the DNS lease table i noticed the printer having a lease time of 14 seconds just after switching it on :-o

    manually set lease time on dhcp router to somewhat longer
    (on the zyxel routers you need to use a manual command like ip dhcp enif0 server leasetime 999999)

    this seems, so far, to have cured the problem
  • HABU_3+ Level 1 Level 1 (0 points)
    Try using the LPD protocol vs. the IPP in the add printer config. menu.
    This fixed my could not print with the infamous "Network Host 'xxx.xxx.xxx.x' is busy.." error message. I deleted my previous printer setup with the IPP (Internet Printing Protocol) and changed out to LPD (Line Printer Dameon) in add printer menu protocol configuration, inserted my printer's IP address, I left queue field blank, and it pulled up my installed printer driver automatically for me in the "Print Using" field. Please reply if this does or does not solve your problem.
  • vonStemmington Level 1 Level 1 (0 points)
    I've tried the LPD protocol, IPP, and HP Jetdirect (I'm trying to use an HP Deskjet 1220c wirelessly) and each one has a different problem.
    When I use IPP, I get the "Network host 192.168.2.200 is busy". When I try LPD, the printing job pauses every time I try to start it. When I try HP Jetdirect, it just doesn't do anything.

    Any ideas? I figure my problem's the same as the one in this thread so it wouldn't make sense to start a new thread over it.
Previous 1 2 Next