6 Replies Latest reply: Jul 14, 2008 12:39 PM by FNS
Mike Rice Level 1 Level 1 (5 points)
I am trying to burn CD's and get this error message. Then I replaced the CD with a DVD and tried again ad get the same error code. Thanks for any advise......... mike

iMac G5, Mac OS X (10.4.2)
  • Mike_in_Detroit Level 1 Level 1 (0 points)
    Try going to the Applications--->Utilities--->Disk Utility and on your start up disk click "repair disk permissions"

    That is what worked for me.
  • Redlava Level 1 Level 1 (5 points)
    I have been getting the same error message when attempting to burn to a CD or DVD. I have tried repairing disc permissions, burning from iDVD, iPhoto and the Finder to no avail.

    I am at a loss and would welcome any other thoughts.
  • Jorn Ake Level 1 Level 1 (0 points)
    Here's what worked for me:

    In Disk Utility, I repaired permissions on the boot disk. Not sure if that is what did the trick, but it was the first step.

    Then, also in Disk Utility, I selected my DVD drive (PIONEER DVD-RW DVR-K06A) and did a COMPLETE erase of the DVD with which I was having problems with and receiving the aforementioned error code message (0x80020022). The erase, even though you when you select "completely" for the type, is very quick, I would imagine because the DVD is empty.

    A dialogue box pops up immediately after the erase is completed (in seconds in my case) asking you what you want to do with this blank disk. I selected, "Open in Finder Window". Which it didn't do, but it did create a burn folder on the desktop. Hmm.

    So I copied all the information I wanted to burn from my original named burn folder over to that new un-named burn folder, then opened that folder, clicked burn and presto, everything clicked along. The disk finished and it seems to play fine (I was copying a collection of non-ITunes, non-DRM, music - relax Apple.)

    Hope that helps and is clear. I would guess that the disks I was using, Sony Gold DVD-RW, had some piece of something on them that the DVD or the driver didn't like. Erasing the DVD completely got rid of it, and everything could start unbotched.
  • FNS Level 1 Level 1 (0 points)
    I think we are just all users with problems talking to other users with problems.

    No one at Apple is listening, and/or no one at Apple knows what the error means. I've got the SAME problem -- and getting tired of screwing CDs. (Tried all the solutions above.)
  • Klaus1 Level 8 Level 8 (46,490 points)
    Back when I tried to use Sony CDs/DVDs I had a 50% failure rate.

    Since using better brands like Verbatim and Maxell I have not had a single failure.
  • FNS Level 1 Level 1 (0 points)
    I don't think it's a media problem since the error says "Lost communication with the device."