Skip navigation
This discussion is archived

USB Printer not Recognized

6589 Views 9 Replies Latest reply: Mar 5, 2009 6:36 PM by Ryan Vetter1 RSS
TRON Level 1 Level 1 (20 points)
Currently Being Moderated
Apr 3, 2008 9:13 AM
TC does not recognize my Samsung ML-1710. Airport Utility says "none" under the TC's "printers" tab. The printer was working with Airport Extreme Base Station, but I can't get it recognized at all when connected to the TC usb port.

Has anyone found a way to get TC to recognize their ML-1710?
MacBook Pro, 15", Mac OS X (10.5.2), 2.4 GHz Intel Core 2 Duo
  • R. Berardi Level 4 Level 4 (2,020 points)
    Currently Being Moderated
    Apr 3, 2008 9:45 AM (in response to TRON)
    open your system preferences
    go to print and fax

    is your printer listed there?

    click to + sign to add it
    bonjour should find it.
    Quicksilver G4 733MHz | MBP 2.4 15" | G5 2.0 DP | 1st gen MB 2.0, Mac OS X (10.5.2), 10 GB iPod | 4 GB Mini | 4 GB Nano
  • adlib Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 10, 2008 2:46 AM (in response to TRON)
    I had a problem printing when I first set up TC. The Airport Utility indicated that TC recognised the printer OK, but attempts to print returned 'Printer not responding'.

    In System Prefs, Printer and Fax, the printer was also listed, but it was still marked as connected directly via USB - which was correct before TC arrived on the scene, but wrong now.

    Removing the printer from the list in System Prefs, then adding it again fixed the problem. I had to select the driver from the list manually. Although the system knew the name of the printer, it couldn't select the appropriate driver automatically.

    Interestingly, as a result, the Airport Utility now reports that there is no printer attached to the TC - but there is, and it now prints fine.
    TC 500GB, Mac OS X (10.4.10), TC Firmware 7.3.1 Airport Utility 5.3.1
  • uk-must-have-iphone Level 1 Level 1 (15 points)
    Currently Being Moderated
    Apr 10, 2008 3:16 PM (in response to TRON)
    I would recommend ditching the idea of allowing Bonjour to sort out the configuration and try setting up the printer manually from the IP tab on the mac's printer setup dialogue.

    First turn off the TC plug the printer into the TC, then turn the TC on. This should have the TC see the printer.

    Then open the print and fax preferences in the mac and ctrl-click in the printers pane to reset the printing system.

    then click on the "+" to add a printer, then the IP 'WORLD" icon. Choose hp-jetdirect socket, port 9100 probably, then choose drivers, from 'other' and select your driver from /Library/Printers/PPD's/Contents/Resources

    This worked for me with a different samsung model.

    So much for Apple's "it just works!"
    Most, Mac OS X (10.5.2)
  • iTCB13 Calculating status...
    Currently Being Moderated
    Apr 10, 2008 3:19 PM (in response to TRON)
    I have the same problem with my Brother MFC-3420C, but when I install the brother's drivers on all machines connectd to TC the printer appear and work!!

    And yes... on airport utility the printer isn't recognized...
     iMac 2GB Ram 160 HD  MacBook 2GB Ram 320 HD  Time Capsule 1 TB , Mac OS X (10.5.2), || Waiting for 3G iPhone ||
  • neilgader Calculating status...
    Currently Being Moderated
    Apr 30, 2008 8:08 AM (in response to TRON)
    having same probem with canon i9100. has latest driver-is it just too old?
    MacBook, Mac OS X (10.5.2)
  • BigToeII Calculating status...
    Currently Being Moderated
    Dec 26, 2008 8:18 PM (in response to neilgader)
    Hello,

    Same problem here with the Airport Extreme. It recognized my brother MFC-685CW printer for a while and then stopped.

    Tried to delete and reinstall the printer via Bonjour throughPrint and Fax preferences "+" icon but it is not recognized.
    Tried to turn printer off/on
    Tried to reset airport extreme base station

    Any help?
    MacBookPro 2.4 GHz, Mac OS X (10.5.2), Brother MFC-685CW, AirPortExtreme 7.3.2
  • Ryan Vetter1 Level 2 Level 2 (460 points)
    Currently Being Moderated
    Mar 5, 2009 6:36 PM (in response to BigToeII)
    Add me to the list... Brother 540 was recognized, now, after about 1 year, no go. And people are referring to TC... well, I don't have TC, I have an Aiport Extreme Basestation, and it is not recognized, and therefore Bonjour is useless (not picking up the Printer on the network). Even after latest update nothing.

    Trashing the print preferences might work? I will try.
    MacBook Pro, Mac OS X (10.4.10)

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.