3 Replies Latest reply: Apr 8, 2008 6:02 PM by ScottK22
Wesley Level 2 Level 2 (265 points)
I've been searching for a straight-forward tutorial on how to connect Leopard home computer to a Windows Vista home server. Although I've found tons of website articles and forums telling pieces on how to do this I've yet found a simple straight-forward list of steps saying to do this-and-this-and-this on your Mac and make sure these settings are set on your Windows server.

Is it best to just use the OS X 10.5 Help using these topics?:
http://docs.info.apple.com/article.html?path=Mac/10.5/en/11404.html

And to follow these steps?:
http://docs.info.apple.com/article.html?path=Mac/10.5/en/8203.html
http://docs.info.apple.com/article.html?path=Mac/10.5/en/8201.html

I don't have 10.5 and finding this info for a family member.

Thanks!

PowerMac G4 1GHZ AGP, Mac OS X (10.4.11), DSL, Safari 3, Pioneer DVD-RW DVR-108, 2Gb Ram, Two 120gb Hard Drives
  • Kappy Level 10 Level 10 (251,085 points)
    Those are indeed good information sources. Here's some others:

    Mac-Windows File Sharing
    Mac OS X 10.5 Help- If you can’t connect to your Mac from a Windows computer

    Simple guide to Leopard/Windows Home Networking

    Written by Intercepter121 and originally posted on the Apple Discussions here.

    If your network complies to the minimum requirements described below you should be able to share resources without any need to enter commands in the terminal to modify configuration files in your mac.

    Requirements
    1. A decent router
    2. Mac Os x 10.5.1 installed on your macs
    3. Windows XP or Vista
    4. Number of network devices <10
    5. Some network printers or drives (NAS)
    6. A decent ISP offering a good DNS service

    General Settings
    If your router offers DHCP and any of the device has power saving features there is a risk that the IP addresses are renewed. This can be problematic as the devices keep changing IP addresses. As this is your network is strongly recommended to reserve IP addresses to the MAC (Machine Address Code) of the various devices so that they can power on and off and still keep the same IP.This simple suggestion will greatly improve the browsing of the local network.

    Accessing Windows Resources from Leopard with no authentication

    Windows
    1. Check the settings of the PC and ensure the IP addresses on the local LAN are trusted
    2. Activate sharing on the desired devices ensuring the shares are read and write. If you use Vista ensure password protected sharing is disabled.
    3. Try to access the windows share from another windows computer if available to confirm no authentication is required

    MAC
    1. Go into system preferences->security-Firewall check that the setting is not on allow only essential services. Recommended settings is allow access to specific
    2. Go back into system preferences network. On the tab location click edit locations. Duplicate Automatic and call the new location Home. Now select the Home location and go into Advanced-WINS. In the workgroup field enter the same value that is on the other windows computers for example HOME. Now press enter then go back to the main screen. Select Edit locations and delete the location automatic. Now edit your location Home and rename it Automatic. This workaround is a leopard bug described here.
    3. Give 5 minutes to allow all the other machines to broadcast their IP address and the other computers should appear on the left side of your finder window. You can now select the shares you want to connect. As no authentication is active if you are prompted with a user name just press OK.

    The procedure to access a NAS is the same as above, just ensure permissions are set to files are read/write for anyone to avoid confusion.

    NOTE: There is no need to activate SMB sharing if you don't want to allow the PC to read folders on your MAC

    Troubleshooting
    After you have followed all the steps you don't see any windows PC.

    Identify the IP address of the machine you want to connect. In finder select Option+K and enter SMB://IPADDRESS. If you can connect you have a name resolution problem. Go into your router configuration and ensure that the option DNS assigned by ISP is selected and you don't have services like Open DNS in use and fixed IP addresses in that field. Apply the changes and reboot the router. You should start seeing windows PC in finder shortly after.

    Your ISP DNS service is poor and you must use Open DNS or similar
    If you are forced to use services like open dns you have the risk that the router propagates the DNS servers to your machines. As the implementation of SAMBA in Leopard effectively blocks the MAC to be a master browser for performance reasons you end in a situation in which tiger machines connect and leopard ones don't see a single share. Let's fix it.
    1. Go into System Preferences->Network then advanced DNS if you see here the IP addresses of the open dns servers this is the case. Unfortunately you will be forced to change the hosts file.
    2.Ensure you have reserved IP addresses to all your machines so that they always get the same IP.
    3. Now login into your mac as administrator and go into utilities=>terminal.
    4. Issue the following command sudo pico /etc/hosts
    5. Now scroll down and enter all the IP addresses and computer names of any device you want to browse
    6. Reboot your MAC
    The windows devices will now appear in finder and you will be able to connect with Option+K.

    You cannot access shares even entering the IP address
    You have not reserved IP addresses to each machine. Go into your router LAN set up and make sure that is the case.

    Accessing Leopard resources from Windows
    1. Go into system preferences->security-Firewall check that the setting is not on allow only essential services. Recommended settings is allow access to specific
    2. Go into System preferences->accounts and click on Guest flag the option Enable guest account to access shared folders
    3. Now into System preferences->sharing select file sharing and then options here flag SMB and select the user that has to be logged into the computer when the share has to be accessed. Ensure that the folder you want to share has read/write or whatever permissions you like it to have set for Everyone

    You should now be able to see your MAC in the windows network resources and access the shared folder with a double click without any password request.

    Troubleshooting
    You don't see any MACs from Windows

    Check the firewall settings at the start of this post. Then go back to the Network configuration hit advanced and then TCPIP check is using DHCP and not a fixed address. Then check the sharing is set as above with SMB clicked. If SMB is not set you won't even see your mac from windows.
    You see the MAC and the shared folders but you can't read or write on it
    Ensure you have set the guest account to access shared folders. Then check on the sharing preferences that there is at least one folder with read permission for everyone. The classic case here is Dropbox that leopard sets as read and write for the user of the MAC but no access for other users. You try to click on drop box and receive an error but when you actually try to write a file you can do it. Check the permissions on the subfolders of the share as those permissions will prevail on the home shared folders

    FAQ

    You may want to do more complicated things, but first ensure you can actually share files without security in place so you can identify the root cause of your possible problems

    I want to password protect my windows shares: once you have done the relative set up in windows vista and ensured you can connect from another windows machine you will need to use user name and password of the Vista user to connect.

    I want to password protect my MAC shared folders: Go into user account and disable guest access to shared folders is no shared folder has to be accessed without password otherwise leave it checked. Create a new user for sharing (better than giving away your password) so that this user only accesses the folders you want to share. In System preferences network select file sharing SMB and flag only the new user you have defined. Then go back to the folder section and set the permissions you like on the folder you want to share for this newly defined user.

    Good Luck
  • Wesley Level 2 Level 2 (265 points)
    Awesome!!!!

    Thanks!,
    Wesley
  • ScottK22 Level 1 Level 1 (0 points)
    And here is one more tidbit - I struggled with this issue for 4 months and tried everything - it turns out it was a little known tweak to windows xp.

    Here's a link to the thread that solved it for me: http://forum.notebookreview.com/showthread.php?p=2791954

    It ended up being an obscure Windows bug that means the IRPStackSize was broken.

    http://www.howtonetworking.com/winissues/irpstacksize.htm

    I increased my irpstacksize to 14, and after reboot I have no issues connecting to my XP system from Leopard.