5 Replies Latest reply: Jul 3, 2008 2:46 PM by greenmoon
tarahloves Level 1 (0 points)
Every time I click on iTunes store is says "iTunes could not connect to the iTunes Store. The network connection timed out. Make sure your network settings are correct and your network connection is active, then try again."

But I haven't messed with any network setting or firefox or internet explorer so I don't see the problem. My internet is working fine too.

Can anyone help me or show me what I could do to fix the problem?

  • PALERIDER Level 1 (5 points)
    Iam having the same problem and and have tried re installing itunes and changed the time and check firewall and i cannot log into itunes store when i want to buy or write reviews nothing? I also didn't do anything different all of a sudden it stopped me from logging in.Hopefuly someone can solve this problem.
  • Katrina S. Level 7 (24,095 points)
    Try the steps in this article, esp flushing DNS
  • imn2science Level 1 (5 points)
    I had the same problem. Flushing the DNS and turning off the firewall did nothing. I was running Norton 360 v1.0. After several hours of searching in the forums and trouble-shooting I ended up on Norton chat support. They suggested I uninstall and reinstall Norton 360, and even gave me a free upgrade from v1.0 to v2.0 Inbetween removal of the v1.0 and reinstallation, I tried iTunes and was able to connect to the store. After installing v2.0 I can still connect so I'm running again for awhile.... .until the next iTunes update. Other people running Norton have had similar problems and Norton updates fixed it.
  • PALERIDER Level 1 (5 points)
    Months later still can't purchase or write reviews or do anything but browse store?Help
  • greenmoon Level 1 (0 points)
    I have my first ever ipod (shiny green new ooh) and have spend 2 days battling with it. I could connect to all apple sites in normal way, but not to the itunes store from the link in my itunes program on desktop.
    I kept getting the 'timed out' message ...'check connections yada yada ya...'
    I have tried every bit on help info on here and this is what worked for me (I don't know if both steps were relevant)
    I changed my account to administrator status then restarted pc (control panel, user accounts) then I went along following route
    control panel.....security......internet options.....security tab.......trusted sites.........."sites".........type in apple website address.......UNCHECK the bottom box about requiring server verification https etc. then confirm - I think it was "add"
    I then restarted and it was all good.
    What a clever bunny - I self congratulate as I am totally pc illiterate and have to have everything spelled out clearly, and I am only writing this because it may save someone 2 days.
    I have Vista.....and Norton (although I didn't 'do' anything to Norton to solve this)