4 Replies Latest reply: Dec 8, 2005 5:11 PM by Mary Hasbrouck
Scott Ebright Level 1 Level 1 (105 points)
I have a SanDisk flash drive that has worked fine on OS 9.2 and a PC for over 18 months. I just bought a new Kingston flash drive. Both worked fine on my G4 at OS 10.3.9 at home and a similar G4 at work (OS9.2). Once my work G4 was upgraded to 10.4.2, my new flash drive died. It is going back to Kingston tomorrow for repair. My trusty SanDisk drive loaded up on 10.4.2, but freezes my home G4 when installed into the USB port. I rebooted in OS 9 and had the same thing happen. Any coincidence or is 10.4.2 causing the problem? Anone else have this problem?
  • Rajan Desai Level 1 Level 1 (0 points)
    I just got a new Memina Rocket 2GB flash key... and im having a related issue... the key runs fine on the PC systems however when I plug it into my powerbook (fully updated atleast according to software update) it mounts fine on my desktop and I can upload whatever files I want, but when I try to DOWNLOAD from the key it will go for like 9MB and then it will freeze and then cause Finder to get the "red color wheel" the only way I can fix this is by a Forced Restart (via power button)...

    I figure there has to be something wrong w/ the OS b/c it works perfectly download/upload with a PC and I am able to upload to it on my mac w/o a problem... its just taking files off thats teh problem...

    anyone else get this problem?
  • MacRN Level 3 Level 3 (640 points)
    Same problem here, SanDisk Cruzer works like a charm on both PC and Mac but new Kingston 1GB Data Elite only loads on PC. When I look at System Profiler on Mac, it recognizes the drive in the list, but does not mount.

    Also getting ready to ship mine back to Kingston for a replacement.
  • Scott Ebright Level 1 Level 1 (105 points)
    The mystery continues....my SanDisk that doesn't work in OS 10.3.9 worked fine on my work G4 with Tiger. As did my wife's new SanDisk, which opened once on 10.3.9 then disappeared and froze the computer. Sounds like I am not alone in this problem.
  • Mary Hasbrouck Level 1 Level 1 (0 points)
    I have been reading through this thread, and have a slightly different twist than the ones I've seen so far. I have 2 different USB flash drives (Lexar JumpDrive 128MB, SanDisk Cruzer Mini 256MB). When I first upgraded my eMac to 10.4.3, the flash drives refused to show up. Due to various other problems, I've had the hard drive replaced, installed a clean system, run Software Update several times - and now the Cruzer works okay ONLY if it's not left plugged into the USB port for a long time. So I can put it in, copy to it, and eject it - but if I leave it plugged in and try to copy to it later, it freezes the computer in a very nasty way. The Copy window starts up and won't go away, might make some progress for a second, but then just sits there. Force-Quit won't work, I have to go midieval on the whole situation with the Command-Ctl-Powerkey reboot.

    (The Lexar is out of the picture, since my husband thought it was dead when the symptoms started, so he threw it out.)

    Has anybody seen or heard of this problem?