Previous 1 2 Next 20 Replies Latest reply: Aug 18, 2008 7:00 PM by Grant Bennet-Alder
infestedsmith Level 1 (0 points)
My Dad owns a PowerMac G4 Quicksilver 867Mhz computer, with default parts installed, and no add-ons whatsoever. He was using it one night, and it was running fine, and then the next day, he tried to turn it on, and it wouldn't do anything. The light stays on while you're pushing on it, but turns off as soon as you release it. I have tried all the following:

CUDA Switch: Tried a dozen different diagnostic test with this switch, none worked.

Power Supply: Bought a fine new working power supply, switched them out, didn't work.

PRAM Battery: Took a brand new PRAM battery and put that into the computer, didn't work.

Power Cord: Switched out the old power cord with a fine working one, didn't work.

So after all that, what on earth can I do now? If I have to replace the Logic Board I can, but I'd be very surprised if it was the problem. We had no storms, no power surges, no "brown-outs" or anything that would disrupt or damage my Dad's computer, so I'm at a loss as to what it could be. If anyone has any ideas, EVEN if I've already tried them, please post. Thanks.

Power Mac G4 933 Mhz Quicksilver 2002, Mac OS X (10.4.10), 512MB RAM/60GB HD/128MB VRAM GeForceTi4600
Previous 1 2 Next