6 Replies Latest reply: Jun 14, 2008 8:53 PM by nilp
Sam827 Level 1 Level 1 (20 points)
I'm trying to install Ubuntu onto my mac so I am trying to create a new partition. In Disk Utility, I go to the partition menu for my disk, click the little plus sign or attempt to sshrink my Mac HD, but every time I get "Partition failed for disk Macintosh HD No space left on device"

Any help is appreciated.

2.16GHz MacBook with 2GB RAM, Mac OS X (10.4.10)
  • Allan Eckert Level 8 Level 8 (46,100 points)
    Hi Sam827;

    I have not tried to use Disk Utility to do this but may I suggest that it could be problem with the fact that you are booted from that partition. It might work if you boot from the install media and that attempt to change the partition.

    Allan
    tiger
  • dechamp Level 4 Level 4 (3,495 points)
    First, before trying to install Ubuntu, you should read and fully understand the steps that others have used:
    https://help.ubuntu.com/community/MacBook

    I think the first thing that is going wrong is that your hard drive is either very full or very fragmented. That is probably why you are not able to shrink your original partition or create a new one. It probably doesn't matter because...

    Second, you are supposed to be using the Bootcamp program to create the partition anyway.
  • Sam827 Level 1 Level 1 (20 points)
    I already have a Windows partition, so Bootcamp won't work for me.
    How shall I go about defragmenting my disk if it is?
    I'm going to try to do it from the install disk now.

    Thanks
  • Sam827 Level 1 Level 1 (20 points)
    OK. It didn't work from the install CD.
    I really don't think that Defragging will help. I've read MacOSX defrags itself on the fly.
    If I don't get an answer I'm gonna just do a clean install of Leopard and restore from my backup. But I really don't want to do that.
  • dechamp Level 4 Level 4 (3,495 points)
    iDefrag is the de facto program for defragging Mac OS volumes. Leopard will automatically defrag files that are under 20mb in size, but I don't think Mac OS will optimize the drive and put all of the unused space at one end of the partition (there may be unfragmented files at the end of your partion). iDefrag says they do optimize the drive. I don't use iDefrag because the same basic file-by-file copy system is used by making SuperDuper bootable clones.

    I don't know if you can resize the first partition after you have created a second one, and all of these partitions are going to make it very difficult to recover your drive when it fails.

    I didn't play any games with the partitions for Windows or Linux distros. I just used Parallels and work in VM drives. Easy to backup by copying the entire ~/Documents/Parallels folder to another drive. The only reason to install a partition for these other OS's is to play 3D games with direct access to the hardware for 3D acceleration. Parallels offers many Linux distro's already installed and set up to use.

    Of course, I exclude ~/Documents/Parallels from Time Machine so that they won't fill my TM drive by adding new copies everytime I launch one.

    My Mac is now able to run WinXP, Vista Business, Ubuntu, and Leopard all at the same time... and I don't have to reboot my machine just to check out a web page with other browsers.

    Get Ram, all you can fit.
  • nilp Level 1 Level 1 (15 points)
    I came across this message while researching this same error, and thought I'd answer even though it's two months later.

    I got the same message while trying to partition a 500GB drive into 100GB/400GB. There was plenty of space on the drive, since only 75GB of the 500GB was in use.

    I believe the issue is that OS X has to move a lot of files around during the partition process (yes, this is a defrag process), and if there's not enough space on the data-containing partition, it will fail with this error.

    After I moved 40GB+ of VMWare images onto an external HD, I was able to partition. If you can move files off to an external drive so maybe half of your data-containing partition is initially free, you probably won't have this issue.