Previous 1 2 3 Next 39 Replies Latest reply: Jun 2, 2008 4:26 PM by Cea
David Wang1 Level 1 Level 1 (5 points)
My iWork apps keep giving me missing font document warnings when I launch Pages, Keynote and Numbers documents. This is a problem already reported by many other iWork users but I haven't found a satisfactory solution and I'm hoping someone here can help.

When launching an existing Pages document, I get this document warning:

Image Hosted by ImageShack.us

Here's what I see in the Font Chooser. Helvetica has got some new variants like '.Light Oblique'. What the??

Image Hosted by ImageShack.us

But if I quit Pages and then create a new document, I don't get any warnings. The Font Chooser also behaves as usual:



I've validated my fonts, deleted the font cache, repaired permissions in an attempt to fix the problem with no success. What should I do?

MacBook 2.2GHz, iBook G4 14", Mac OS X (10.5.2)
  • shariba Level 1 Level 1 (10 points)
    I've been having the same problem, but my system is substituting Helvetica Narrow for the missing Helvetica... I hate dismissing the warning every time, but that's what I've been doing. Someone out there must have a solution.

    Thanks, in advance.

    Shari
  • Peggy Level 8 Level 8 (38,505 points)
    This has been an ongoing problem for quite a few users. Several things have been suggested that have worked for some users but not others. The most reliable “fix” is to copy the Helvetica.dfont from HD > System > Library > Fonts to your user account > Library > Fonts & restart your Mac. Make sure you copy, not move, the font.

  • shariba Level 1 Level 1 (10 points)
    Fonts have always been a bit mysterious to me. I have no Helvetica.dfont. After doing some research I found that Adobe might have replaced it when I installed CS3. How do I find Helvetica.dfont and if I find it... I wonder what might break if I drop it into the font folder...

    Thanks,
    Shari
  • shariba Level 1 Level 1 (10 points)
    More research... a long discussion on this forum.
    http://discussions.apple.com/thread.jspa?threadID=1170982

    I opened Font Book.app and disabled Helvetica Narrow. In fact, I might have disabled the Helvetica family altogether. I still have GrHelvetica and Helvetica LT Std. enabled. I opened one of the offending Pages documents... no warnings.

    We'll see how this move impacts my other workflows...
  • Level 8 Level 8 (41,780 points)
    Hello

    In Mac OS X, there is no ONE fonts folder. There are several Fonts folders.

    Apple took care to publish a technote describing which fonts are delivered with Mac OS X 10.5, where they are stored and which ones we are not allowed to remove or move.

    http://docs.info.apple.com/article.html?artnum=307069

    The Helvetica related fonts are in the "don't disable" fonts.

    HelveLTMM 001.006
    Helvetica LT MM 001.006
    Helvetica.dfont 6.0d7e1
    HelveticaNeue.dfont 6.0d5e1

    Yvan KOENIG (from FRANCE lundi 14 avril 2008 15:06:33)
  • David Wang1 Level 1 Level 1 (5 points)
    Thanks Yvan,

    However my problems only occur with older iWork documents. Documents created in the past 3 weeks are ok. I probably fixed some of the problems when I deleted my font cache 3 weeks ago.

    My question is how to fix all the old documents. Thanks for your help.
  • chake Level 1 Level 1 (0 points)
    The copying the font from System>Library>Fonts to User>Fonts solution didn't work for me. But I stumbled across a solution today (at least for my machine).

    Open Font Book. In the Collection pane, highlight Computer. Find Helvetica and click the little triangle next to it. The sub-fonts (?) appear. On my machine, the Narrow was listed as Off. Highlight Narrow and at the bottom of that pane, click the small checkbox to turn it on. My problem was solved. No more warnings in Pages, Numbers, Keynote, or iWeb.

    I know I never turned Narrow off because I never clicked any of those small triangles before so it was turned off by some program or came that way with my machine.

    Hope my solution can help others with the same problem.
  • chake Level 1 Level 1 (0 points)
    BTW, I should note that the error message I was getting was "Helvetica substituted for missing Helvetica Narrow font"

    If your error message differs, substitute your "missing font" for the Helvetica Narrow in my instructions above, look for it in the Computer Collection and see if it is listed as Off (Disabled).
  • SMB2 Level 1 Level 1 (0 points)
    I'd like to add perhaps a slightly different perspective to this problem. I'm a graphic designer and use Insider Software's FontAgent Pro to manage all of the fonts on my machine. I use Font Book only to manage the few system fonts that are necessary to run the OS.

    I keep the number of activated fonts to a minimum and regularly clean out the font caches to prevent any problems with all of the design apps that I use. I've done this for years and haven't experienced any font-related problems for a long, long time.

    When I want to use Helvetica/Neue Helvetica (which is rarely), I use PostScript Type 1 versions of those fonts. I don't want to reinstall the dfont version of Helvetica, because that will create conflicts with the fonts in my commercial work.

    Whenever I open or create an iWork document I get the Missing Font error mentioned in this thread. The new version of iWork lets me select a substitute font, but my choice never seems to "stick." Once I close the document and reopen it, the same message reappears. iWork seems to assume that every document must use the dfont version of Helvetica/Helvetica Neue, regardless of what I want.

    Why can't I specify what font I'd like to use, and have it become the default for all of the iWork apps? Until Apple fixes this problem the whole suite will have to remain shelfware and I'll keep using Office. I'd prefer to use iWork, but at least Office doesn't insist on nagging me about my font choices.

    SB
  • Level 8 Level 8 (41,780 points)
    Hello

    We often wrote the sentence which may help: _apply the rules and you will not met this problem._

    We are not allowed to remove/disable some fonts and Helvetica Neue is one of them.

    Look at:
    http://docs.info.apple.com/article.html?artnum=307069

    Yvan KOENIG (from FRANCE lundi 5 mai 2008 19:04:59)
  • Matt Sephton Level 2 Level 2 (250 points)
    Hi,

    Just bought a new Mac and am also getting this error. Running fully up-to-date Pages '08 (3.02)

    I get the error when choosing: New from Template Chooser.../Word Processing/Resumes/Business Resume (the last one in the list)

    Using the font panel, I get two lots of Helvetica Neue, even though I only have one installed.

    Therefore, I think the new Leopard-bundled version of Helvetica Neue has changed the way it reports it's internal name to the system and they've failed to update all the templates that use it? I doubt they're ever going to fix the Pages templates...

    ...so I was wondering what the recommended way of changing the fonts used in a document? The Styles drawer? Can I re-save Templates that I use often?

    Thanks,
    matt

  • shariba Level 1 Level 1 (10 points)
    Hello all,

    I had been following multiple threads on this issue for months. The problem isn't huge, just annoying. I tried a few suggestions but they never worked for me. I even purchased Helvetica from a third party vendor. Nothing seemed to make the error go away.

    But the other day, I followed someone's posted advice and it finally resolved the error.

    Here's what I did: Open the System Fonts folder: System/Library/Fonts... Hold the Option key (so you will duplicate) while selecting the font 'Helvetica.dfont'... Keep the Option key held down as you drag the font from the System Font folder into your Home Font folder: (user)/Library/Fonts/...

    FINALLY that annoying error has disappeared. I couldn't believe it. I also can't believe Apple hasn't addressed this. I hope this helps. My thanks to the person who finally came up with the answer.

    Shari
  • Matt Sephton Level 2 Level 2 (250 points)
    Sadly this approach does not work for me.

    matt
  • shariba Level 1 Level 1 (10 points)
    Ah... too bad.

    That is exactly why I think Apple should step in and address this. I also tried lots of "cures" that didn't solve the problem. It's too weird that some solutions work for some people and not others. The error came up after I upgraded to iWork '08. But I had also installed Adobe Creative Suite 3 Web Premium around the same time. I blamed Adobe for messing with my fonts. (such a loyal Apple-fan...) But who knows?

    Good luck. Hope you find a solution that works for you.

    Shari
Previous 1 2 3 Next