10 Replies Latest reply: May 22, 2008 5:24 AM by Grant Bennet-Alder
Glen Doggett Level 4 Level 4 (1,835 points)
Software Update was unable to install this update, it moved the .pkg file to the trash.
I moved the .pkg file back to the Desktop, tried again, it failed.
I downloaded the .dmg/.pkg from the Apple web, tried agagin, it failed.

Is anyone able to install the Security Update 2008-002 PPC on their G3 in 10.4.11? I was able to reboot fine, everything else seems to be working properly anyway.

PowerMacG3Desktop/SonnetG4/1GHz/768MB/DVR106D/ACARDRAID66/TangoUSBFW/ATI9200/OS9, Mac OS X (10.4.11), 2.16 GHz MacBook Core2Duo/3GB/Samsung204B/Airport Exreme Base Station
  • Allan Jones Level 7 Level 7 (33,120 points)
    There are time when something served up by SW won;t work but downloading the update from teh "Downloads" section and applying it does.

    That update is here:

    http://www.apple.com/downloads/macosx/apple/security_updates/securityupdate20080 02v10ppc.html
  • Glen Doggett Level 4 Level 4 (1,835 points)
    Yes, I did exactly that, I manually download the update from the web and it also failed. There is no trace of the update in /Library/Receipts so I thought I would look in the console.log and found that I have some kind of disc error:

    Apr 20 21:08:00 gossamer kernel[0]: hfsswapHFSPlusBTInternalNode: catalog key #73 invalid length (0)
    Apr 20 21:08:00 gossamer kernel[0]: node=29288 fileID=4 volume=SeaMax device=/dev/disk2s10


    I booted from the 10.4.6 Install DVD to run Disc Utility and it reported an "Invalid key length" error and could not repair the Volume. I guess I'll have to try something more powerful, or a reformat and restore from a clone backup. I wonder if this might be due to my RAID-0 stripe volume? I've not had any problems with it before.
  • Grant Bennet-Alder Level 9 Level 9 (53,420 points)
    I would not expect that disk problem to be caused by using RAID stripe organization, but it certainly is made more complicated.

    Under systems previous to about 10.4.4, you could not Verify a RAID Volume, because older versions of Disk Utility Verify required unmounting the drive to check it, and it could not be unmounted and still be a RAID array. This made it very difficult to be diligent about checking for Disk Errors. So errors tended to accumulate and get worse until it was near-disaster level before they were fixed.
  • Glen Doggett Level 4 Level 4 (1,835 points)
    I think you may be referring to a software RAID? My hardware striped RAID-0 shows up as a single drive when you flip the dip switch on the PCI card, and it works fine under OS 9 and X.

    I was able to repair the boot volume after a few passes with a more powerful utility. I never noticed any problems until the recent Software Update failed. I was able to install it after the disc was repaired.

    I am wondering if any data might have been lost during the repair, and if I should restore from my external FW drive, or just be happy that the repair worked? The disc errors found were related to the catalog, B-Tree, volume directory structure. (I don't remember ever having drive problems like this since the days when I was using 10.2 and Norton System Works.)
  • Grant Bennet-Alder Level 9 Level 9 (53,420 points)
    You are right, I was referring to Apple RAID software (included inside Disk Utility).

    Unless you notice that files have been lost, I would continue to assume that repairing the disk did not result in lost data.

    Failure of either drive in a striped array can lead to the loss of the entire array. You are increasing your speeds, but may be reducing Mean Time Between Failures (MTBF, aka reliability).

    It would be prudent to run "Verify" or "Repair" more often than more casual users to avoid compounding problems -- having two small problems add up to a disaster.
  • Glen Doggett Level 4 Level 4 (1,835 points)
    I have an external FW400 (OWC Neptune) bootable backup of the hardware striped RAID-0, which came in very handy in this situation. The machine was still operational, other than the failed Software Update I probably wouldn't have noticed anything was wrong.

    But even after running repairs on the disc and successfully applying the downloaded Security Update, the drive started showing the same errors again in the system.log. So, I decided to do a re-partition of the drive and restore the data from the external clone drive. So far that seems to have solved the problem. I guess I'll try to make a point of proactively verifying the disc regularly.

    On the Beige G3 the little extra performance boost of the RAID-0 is really noticable, 70MB/sec peak reads instead of 45MB/sec for a single ATA66 drive for uncached 256K blocks, per XBench. The external FW drive does a respectable 40MB/sec, considering the built-in ATA is like 16MB/sec. Booting and launching apps on the RAID is almost as snappy as my new MacBook.
  • Dan Lempesis (Omega) Level 4 Level 4 (2,420 points)
    Hmm. What kind of drives are you running? There are single drives easily capable of over 70MBps (100MBps+, actually).... is that just the PCI bus' limit, or are the FW drives you're talking about what you're running?

    I've wondered for a while what the limit of the beige's PCI bus is. Obviously it's theoretically 133MBps, but I'm guessing it's quite a bit lower than that.. probably below 100.

    Also, in your experience, is 10.4.10/10.4.11 any slower or faster for the beige than 10.4.9?
  • Grant Bennet-Alder Level 9 Level 9 (53,420 points)
    There are single drives easily capable of over 70MBps (100MBps+, actually)...


    There are drives whose rated transfer rates are those big numbers, and even some rated at 133, but (in case you have missed my sermons on this subject) consumer drives of 10,000 RPM and slower are NOT capable of producing more than a momentary burst of data at speeds over about 50 MBytes a second.

    The rest is just specsmanship. They are selling a big pipe attached to a comparatively modest data source. It's all Hype, especially sATA drives and their outrageous huge transfer rate numbers.

    There is currently a physical limit to how tightly they can pack the data bits, and a practical limit to how fast you are willing to pay to spin the drive. When the next big thing, probably vertical magnetic bits (a.k.a. "perpendicular" bits) starts to become available in consumer drives, it will all take a big step up in bit density.

    Message was edited by: Grant Bennet-Alder
  • Glen Doggett Level 4 Level 4 (1,835 points)
    I can't really say which of the 10.4.point OS versions is faster, I think 10.4 and 10.3 both ran really well on my G3 with the 1GHz G4 upgrade. Definitely better than 10.2. 10.4 seems faster, but that may be due to my striped RAID I'm now using, booting and launching apps is pretty responsive.

    In the too-much-information department...but since you asked, here are some of the peak numbers (uncached sequential read 256K blocks) from Xbench tests, not sure how good a test this is, but results will always vary a little from test to test. Is anyone getting much better performance than this, and if so what are you using?

    For the G3 Desktop: (some tests were done in earlier configurations of my machine that no longer match the config listed in my signature)
    15 MB/sec on built in
    40 MB/sec on PCI-ATA66: 60 GB Maxtor 5T060H6 ATA/100 7200RPM

    40 MB/sec: 320 GB OWC Neptune ST3320620A 7200RPM FW 400 on PCI-USB/FW external port

    45 MB/sec: 120 GB Maxtor 6Y120P0 ATA/133 7200 RPM on PCI-ATA66
    47 MB/sec: 120 GB Seagate ST3120026A ATA/100 7200 RPM on PCI-ATA66

    70 MB/sec: SeaMax 120+120 on a PCI-ATA66RAID, I know the drives don't match, but hey, they're close enough.

    My MacBook:
    43 MB/sec: 160GB 5400RPM Hitachi HTS541616J9SA00 SATA

    Is there a better benchmark utility to measure hard drive speeds? I am surprised the MacBook isn't faster with the SATA drive.
  • Grant Bennet-Alder Level 9 Level 9 (53,420 points)
    sATA drives only seem to be faster because only the newest mechanisms are being converted to sATA. There is nothing inherently faster about sATA. What is different about sATA is that in huge quantities, it is cheaper to manufacture. When those costs are passed on to me, I will recommend those drives. The difference today is all hype.

    The fastest-rated drives today have fiber-optic interfaces. Few consumers are willing to buy drives where the cheapest cable costs US$40. Today's consumer drives, whether sATA, pATA, SCSI, Fiber Channel, or any other interface are still bottlenecked by the bit density on the platters and the spin speed (RPM).