10 Replies Latest reply: May 30, 2008 1:38 PM by thurtell
mrivera21 Level 1 Level 1 (0 points)
I am trying to configure an AX newer model and continually get an error. The AX has a flashing amber light, due to the fact that I have reset it to factory defaults. I am able to connect to the internet, even though my connection icon in XP says I'm disconnected. I open the Airport Utility and it detects the AX, when I go to configure manually it runs through some progress bars and the gives me the following error:

"An error occured while trying to access the Apple wireless device. Make sure your network connection is valid and try again"

"error: -4"


I have version 5.3.1.9 installed of the utility, i tried to use 4.2, but it wouldn't recognize my device, said i had to use a version higher than 5.0 to detect my device. I tried with version 5.2 and no luck either, please help!!!

Only Windows PCs at home, sorry!

dell d620, Windows XP Pro
  • mrivera21 Level 1 Level 1 (0 points)
    By the way, it is an Airport Extreme
  • Totem Level 2 Level 2 (405 points)
    What type of encryption are you using? Try running the AX without. If it works, then you have to make sure that the key that you are using on your and wireless card is the same as that in the AX. Don't type in the passphrase as it will not generate the same key as your Windows products. You must type the key directly into the AX.
  • IIRC Level 1 Level 1 (0 points)
    I've had a similar problem with Airport Express(not Extreme)and received exactly the same error message as the original poster "error: -4".

    My system is a desktop running xp pro, Service Pack 2 (fully updated), Athlon 64 3000+.

    I installed the Airport utility 5.3.1. It recognised airport express, which was plugged in and flashing amber. But when I pressed 'continue' to set up the connection, it came up with the above error message repeatedly whether I connect to the router wirelessly or with an ethernet cable- makes no difference. The router is a Thompson Speedtouch 780. An Apple senior analyst talk me through different permutations of connecting the AE directly to the computer etc, doing numerous resets but all to no avail. Looks like I'll be returning it. Shame!
  • Dawg_01 Level 1 Level 1 (0 points)
    I'm also having the same problem. The utility will locate the AE, but it won't let me go anywhere when I click "Continue"...

    If anyone can help, I'd be very appreciative!
  • armyofclones Level 1 Level 1 (0 points)
    Same error here. I just reinstalled Windows a few days ago and was now trying to access my usb hard drive through the airport extreme. it wasn't able to connect to it, so I tried playing with the airport utility (which was working fine then)... since nothing was working to get the hard drive online, I tried to reset my airport. now I can't even access the config, it says "can't read configuration, error: -4" after reading the device for a loooong time. It does the same thing either with the latest version of the utility from apple's website, or with the one on my installation CD (5.2.1). What gives??
  • armyofclones Level 1 Level 1 (0 points)
    update:

    I plugged my computer and the airport on another router (my computer to the router's LAN port; the airport connected from its WAN to the router's LAN port), and was able this way to access and configure the airport with a wire. but only after a reset of the airport; if I change any configuration, the airport utility does not even detect it anymore, neither through LAN or wirelessly. So I tried to return my configuration to its original state, and I think I put everything back to normal. it works fine if I connect my computer through LAN, but I haven't been able to get a connexion through WIFI yet.

    This is very strange, it was working just fine before.
  • IIRC Level 1 Level 1 (0 points)
    I think you need to make sure an ethernet cable is connnected between AE and router, factory reset the AE, restart your PC, turn off your firwall, then try and continue with the set up and just 'pray! You might have to reset your router and restart your PC a couple of times because AE crashed my internet connection completely. It eventually worked for me and continues to do so even after removing the ethernet cable completely. Good luck.
  • armyofclones Level 1 Level 1 (0 points)
    Now this is where it gets embarassing. Firewall! I didn't even think to turn it off. Closed Zonealarm and it worked. I can detect/connect/configure the Airport Extreme wirelessly, I can access my wireless network and even my USB hard drive is recognized (which was my first issue).

    Thanks
  • Nanclus Level 1 Level 1 (0 points)
    Hey Army...

    I see you got everything to work after finally getting your PC to recognize your Airport. I had the same issue and your fix worked for me also thanks! I also see you have a USB drive attached, need alittle help getting that to work. I have the drive attached, it shows up in the AE utility so I know that is good, I open the workgroup in windows and its there, but when I double click on the drive it gives me an error and says I don't have permissions. When I attached the drive the AE utility asked for the password, and I entered it so not sure the issue.

    Thanks
  • thurtell Level 1 Level 1 (0 points)
    Please help - 6 hours later. I have downloaded Airport Utility for Windows 5.3.1 and when I try opening it finds my 'basestation'. I have a green light on the basestation - I have an icon at bottom of itunes screen showing speakers - t even plays music... I have a cable from my modem to the baseunit. But as I am using a laptop I want to be wireless. However when I ope arport utility and press continue - I get an error - 'An error has occured trying to access.... make sure network connecton is valid and try again error -6765. My laptop is wireless and it shows 'applenet' on that icon at bottom left. Music is playing!!! why can't I open airport tilities to configure it?? tried turning firewall off - read loads of forums but most go over my head - can anyone help?????? thanks