Previous 1 2 Next 15 Replies Latest reply: Sep 2, 2008 9:38 PM by pdgr
guillermoalvarez Level 1 Level 1 (5 points)
My Safari don´t open PDFs that I can read with no problems with Firefox.
Does anybody know what happens?

iMac Intel Core 2 Duo 2,16GHz, Mac OS X (10.5)
  • bediddleby Level 1 Level 1 (35 points)
    Anyone? I'm having the same problem; running Leopard 10.5.3, Safari 3.1.1 (also tried WebKit builds). PDFs won't open; I just get a grey screen with a spinning wheel. They open fine in Firefox.
  • Mulder Level 6 Level 6 (8,980 points)
    Firefox doesn't support opening PDF files; it has to use a plugin, so unless you've got that installed, you're misunderstanding what's happening. Safari supports opening PDFs in the browser natively, but it can be overridden by other software that you may have installed.

    Do you have any plugins installed, or Acrobat Reader?

  • bediddleby Level 1 Level 1 (35 points)
    I have the latest Adobe Reader installed (and re-installed it). I also removed the Adobe Reader plug-in from HD/Library/Internet Plug-ins and Safari gave me this error when I tried to open a PDF:

    Unable to load plug-in: attempted to load an Internet plug-in named “Adobe Acrobat and Reader Plug-in”, but the plug-in failed to load successfully.
  • Mulder Level 6 Level 6 (8,980 points)
    You need to launch Acrobat Reader, go to Preferences > Internet and uncheck the box labeled "Display PDF in browser using:". Then quit Acrobat Reader, open a Terminal window and type this:

    defaults write WebKitOmitPDFSupport -bool false

    and press Enter. Then quit Terminal and relaunch Safari and try opening a PDF file.

  • bediddleby Level 1 Level 1 (35 points)
    Wonderful! Thanks.
  • quaver8 Level 1 Level 1 (0 points)
    Mulder- thanks for the information you've already given on this thread. I have had a similar problem with Safari not being able to open PDF's online. Clicking on a PDF link I get a blank window with the Acrobat logo in the middle of the pane - Acrobat doesn't open as I have unchecked the "Display PDF in Browser using" in both my Adobe Reader 9.0 and Acrobat 8.0. under their respective preferences.

    I recently loaded up CS3 and wondered whether something within the Suite (Illustrator or Photoshop) might be trying to open the PDF instead of the default Preview and causing a problem.

    Not sure, just sitting here wondering if there's something obvious I've missed....

    Thanks in advance for any help.
  • Mulder Level 6 Level 6 (8,980 points)
    But did you run the Terminal command to be sure that opening PDFs within Safari is turned on? If not, you need to do that.

    For good measure, you can also go to Users/username/Library/Internet Plug-Ins and remove the Acrobat plugin.

  • quaver8 Level 1 Level 1 (0 points)
    Thanks Mulder - you are right - forgot to type in the Terminal window!
  • #1 Level 1 Level 1 (0 points)
    I too am having the same problem + have done everything recommended, including resetting internet prefs in both acrobat 9 + reader 8.2, running terminal command at least 3 x after closing safari 3.1 + acrobat, + removing safari adobePDFViewer.plugin after some failed attempts. Nothing seems to work. I hope that you can help. Thanks in advance.
  • bediddleby Level 1 Level 1 (35 points)
    What do you see when you click a PDF link. Do you get an error, or just a gray screen, or something else?
  • NYCFilmman Level 1 Level 1 (0 points)
    I tried many of the solutions given to remedy this Adobe problem. The one that worked for me instantly was to trash the reader app, then go into Library/Internet Plug-ins and trash the adobe reader plugin, now everything works fine!
  • John Harvey Level 1 Level 1 (0 points)
    Thanks. I had recently downloaded Adobe Reader9 and often get a message "unable to locate" an operable version of reader; or I just get a blank black screen. I tried the terminal command suggested earlier in the thread and that didn't help. Then I saw your post. I didn't trash the Reader9 app but I did trash the readerplugin from library/internet plugins. Voila! The PDF I had been trying to open was there in an instant when I next started Safari and went to the PDF page in the history.
  • Zoe Summers Level 1 Level 1 (0 points)

    I've had the same problem, and it only happened after installed Adobe Software - in my case Acrobat 8.

    I found this post, and after following the 'deletion list' line by line (where applicable) I didn't even have to reboot (gotta love Macs) and PDF's were happily loading in Safari again.

    Hope this helps, and thanks to the articles original author.

  • SunnyJim Level 1 Level 1 (0 points)
    I too have had Safari quit and/or hang when trying to view PDFs. I recently loaded Adobe Acrobat Professional 7.0 (CS2 version) so I was suspicious it might be the problem.

    Here was how I fixed it:

    1) Download latest Adobe Acrobat Reader (9.0 at this time) & install
    2) Quit Safari
    3) Open Adobe Acrobat Professional
    4) Select Acrobat:Preferences:Internet
    5) Click the top check box: "Display PDF in browser using:"
    6) Select Acrobat Reader in the list box
    7) Open Safari & navigate to a PDF link or try this one -
    8) Reader may ask you to input your password for access. Enter Password.
    9) Document should open now.
Previous 1 2 Next