9 Replies Latest reply: May 29, 2008 2:24 PM by mgroenne
mike.habermeier Level 1 Level 1 (5 points)
*Hello to all.*

This is my setup of an Mac OS X 10.5.2 Server. I have al lot of problems with permissions and i really do not know what to do now.

I reinstalled the server from scratch yesterday because of this threat:
http://discussions.apple.com/thread.jspa?threadID=1490460

After reinstalling the server i created a new group with 3 users.
Tanja is the PC user, Mike and Sven are the Mac Users.

Than i created a Folder in the root of the Startup Volume.
I changed the privileges of this folder via Terminal to 777.
Than I opened the Server Admin and configured a new Volume in this folder called "testordner2". Than I click to share this folder.
Than I changed the privileges and the type of sharing.

You can see it in the screenshots here:
http://www.joshuasdream.de/mac_server/privileges.jpg
http://www.joshuasdream.de/mac_server/smb.jpg
http://www.joshuasdream.de/mac_server/afp.jpg

Of course I applied all the privileges to this folder "acl and User/Group.."

This is what I think is the correct way.


Now I tested this configuration.
I opened Text Edit on the Mac and created a file on the mac
and saved it directly to the root level of this shared folder.

Now i check the privileges of this file via Server-Admin.
I think there is an error with the posix group or??
http://www.joshuasdream.de/macserver/privilegesfile.jpg

Now I went over to the pc and tried to open and edit this file. And I try to rename it. Everything works fine. I can rename it. Open it on the PC and type some text and saved it... Works perfect. The same on the other Macintosh Workstation.
After saving this file on the PC Workstation (in that example it was with the Word but it doesn´t matter which kind of application I use) the file has the following weird permissions.
http://www.joshuasdream.de/mac_server/permissions-pc.jpg

But everything works as expected. I can edit and rename the file with PC and Mac.

Now I will go a little bit deeper into it and created a folder with mac and saved a new file with Text Edit into this folder.
The Test Folder gets the following permissions:
http://www.joshuasdream.de/mac_server/permissions-folder.jpg

The file inside the Folder has the same permissions like the other on the root level.
So it seems to work perfect.

Now I create a folders on the pc and save a file into this folder from Word.
Permissions on the Folder:
http://www.joshuasdream.de/mac_server/folder-created-from-pc.jpg

Works perfect.

*And now it is getting interesting*

I rebooted the Mac. Opened Text Edit and created a folder and saved a file to it.
Now I get the following permissions on the folder and file.
http://www.joshuasdream.de/mac_server/wrong-permissions.jpg

I went over to the pc and tried to rename the file in this folder. No chance. I am not having the enough permissions to do that.

Thats weird or ??? What do you guys thinking of that. What am I doing wrong.
This is all not very stable or ??

I have not changed anything. I only rebooted the mac. That was all.
Than I get these kind of permission when I create a folder.
Before reboot: http://www.joshuasdream.de/mac_server/permissions-folder.jpg
After reboot: http://www.joshuasdream.de/mac_server/wrong-permissions.jpg

So if this is really a but. Than please Apple Fix it. That is horrible.

I hope you guys have an idea what to do in this case.

Thanx for all your help.

Mike

MacPro, Mac OS X (10.5)