7 Replies Latest reply: Dec 5, 2005 12:01 AM by Matt38
David Pischke Level 1 (5 points)
I just bought a Mac Mini with 100GB hard drive, SuperDrive and 1GB of RAM and it works perfectly except for a problem I'm having with the Internet. Everything works fine, but after a few hours my internet connection suddenly stops working. If I put the Mac Mini to sleep and wake it up again, the internet connection suddenly starts working again.

I only noticed this problem when I started using the Mac Mini (previously I had a Cube) and my ISP says it's nothing on their end. I'm using a Terayon Cable Modem from Rogers Hi-Speed Internet. I've tried looking at my network settings, deleting ".plist" files and everything, and I can't figure it out. Is it a problem with the computer?
  • Jan Johannsen Level 4 (2,395 points)
    Try the latest 10.4.3 OS X update.

    Also try alternating the powering down and on again both your cable modem and whichever brand router you have plugged into it to share out the connection to your computers.

    I have had weird situations with other routers before. I even had one where the PCs worked fine but the Mac wasn't. Power cycling the router fixed the Mac connection problem.

    I personally run the NetGear WGR614 v5 model at the house. It has never given me one bit of grief connection wise to my mini. I do connect over Airport Extreme at 802.11g speeds. My PCs were around when I wired the house with Cat 6, so they all have wired 100mbit connections to the router's switch backplane.

    Jan J.
  • Bud Olivares Level 1 (5 points)
    I've tried everything.......running mac mini AND powerbook, powerbook NEVER logs off my cable modem/netgear G router, while mini logs off after 15 minutes CONSISTENTLY.....sounds like a driver problem, not modem/router. HELP, mini is a pain in the __!

  • Tim Haigh Level 7 (24,185 points)
    Hello Bud

    sounds like a driver problem

    Drivers are not required to connect a Mac to an ethernet modem or router.

    Try using a different network cable. If that does not fix the problem then try connecting the Mini directly to the cable modem. If that fixes the problem then that would suggest your router is faulty.

    Try resetting your Pram and resetting the mini's PMU
  • Bud Olivares Level 1 (5 points)
    Reset both, still logging off......hooked directly to cable modem and still logs off. My Mini is now running thru airport with itunes wireless! ANY OTHER IDEAS
  • Tim Haigh Level 7 (24,185 points)
    Everything would suggest you have a faulty ethernet port on the mac mini, you should contact apple care.
  • Jan Johannsen Level 4 (2,395 points)
    The consistent thing bugs me.

    If it was random dropout times then it would be like some router units I experienced in the past. Downloading the latest firmware from the manufacturer and loading it on the router fixed a good number of these.

    If it is 15 minutes, always, on the clock, every time. This keeps me thinking you have a software setting somewhere buried as a candidate. My mini is set to sleep every 15 minutes, but it never has bumped my internet / wireless connections before.

    It still might be worth a check of the Energy Saver tab in Preferences and turning them off for a test if they are on.

    How did you set up the network parameters initially on the mini--I think we have eliminated the router from the loop with direct cable modem connect.

    Jan J.
  • Matt38 Level 1 (0 points)
    I've been having a similar porblem with my Blue and White G3. Connection is lost after a few minutes. I have found clicking the renew dhcp lease button in the nekwork preferences/ethernet restores it but only temporarily. ISP says the problem is not on there end. I was using 10.4.3 when this all started so I went back a version to 10.4.2 and I'm still having the problem. The only comonality I see between your situation and mine is the ethernet port. I'm going to have to spend about 200 bucks on a combo pci card to open up a slot to be able to put in an ethernet card to see if that clears up the problem. Sure wish I knew for sure before spend the money.

    By the way my computer is on 24/7 and never goes to sleep so it's not an energy saver issue. At least not on my machine it's not.