11 Replies Latest reply: May 12, 2008 4:21 PM by Braxxis
Braxxis Level 1 Level 1 (0 points)
Ok, I know this is a constant topic but here, try this on.. I have the same issue as everyone else. My router is fine, and my network shows on my iPhone that it is connected in the settings, and it always connected to WiFi at work and at Home. Now it has started defaulting to Edge for no reason. It still says its connected and available in the settings but yet still defaults to the ever so slow Edge network.

Now heres a question. Does the Edge network fall under the unlimited Data plan? Or is this an additional charge? If so It seems very coincidental that it defaults to Edge over all the available WiFi's. hmmmmmmm..

But I digress.. like I said, the first few days it always connected to my network at work and home, now just Edge only and OCCASIONALLY it will switch into WiFi. Is there a way to keep WiFi enabled but disable the Edge networK on the phone? Because the whole main features of this phone are for the Data access abilities.. and so far I'm not impressed.

Wave of the future right? Only never connect to the almost required WiFi to use half the features, no Java Games when MOST phones and a LOT of people play them, and no OVERLY used by many people, Multimedia Text Messages.

This phone is batting zero with me over the past week.

Q6600 Quad-core Processor, 4GB DDR2 800 RAM, 2x nVidia Geforce 8800GTS 640MB 320bit GPU in SLI, Other OS, Windows XP 64-bit
  • 1. Re: Not connecting to WiFi
    Ian Parkinson Level 6 Level 6 (10,400 points)
    You do not pay for any data that you use in the USA and that includes data that you use on Edge.
  • 2. Re: Not connecting to WiFi
    Braxxis Level 1 Level 1 (0 points)
    Ok kool.. that answers that.. now is there a way to Turn OFF edge so it will stop defaulting to that over my Network which it CLEARLY sees visible. (my router also sees it connected to it)
  • 3. Re: Not connecting to WiFi
    Ian Parkinson Level 6 Level 6 (10,400 points)
    No you can't turn off Edge.

    Are you sure it is not just turning of the WiFi connection when it is not in use?
    My iPhone does that, but as soon as I start to use something that needs the internet it connects to the WiFi again.
  • 4. Re: Not connecting to WiFi
    Jason L Community Specialists Community Specialists (9,475 points)
    Hey Braxxis,

    The iPhone will revert to the EDGE network when it cannot connect to the Internet over the Wi-Fi network.

    What is the iPhones IP address when it joins the Wi-Fi network? If it has a 169.254.x.x IP address this article will explain what's happening. http://docs.info.apple.com/article.html?artnum=58618

    This article provides basic tips for joining Wi-Fi networks.
    http://support.apple.com/kb/TS1398

    Jason
  • 5. Re: Not connecting to WiFi
    Braxxis Level 1 Level 1 (0 points)
    Unfortunately no, even when I start using it it stays in Edge mode, but again, my router clearly is showing up on my phone. as for the AirPort article that was just left.. i have NO clue what that is.. is AirPort mac only? Cuz I sure don't have it on my PC that I built. Either way ill check those settings on the Phone when I'm at home and it's connected, as well as double check my routers configuration.
  • 6. Re: Not connecting to WiFi
    Ian Parkinson Level 6 Level 6 (10,400 points)
    Airport is the Mac name for Wireless Networking (WiFi)
  • 7. Re: Not connecting to WiFi
    Braxxis Level 1 Level 1 (0 points)
    ok so my phone IS showing a 169.254.xx.xx ip, but the article doesnt explain how to remedy this.. it just explains technical gargan on WHY its happening but is NO help as to fix it.. so how do I fix this?
  • 8. Re: Not connecting to WiFi
    Jason L Community Specialists Community Specialists (9,475 points)
    Braxxis,

    A couple quick fixes you can try are power-cycling the router. You can also try tapping the renew lease button below to the IP address on the iPhone. Try disabling wireless security and MAC address filtering on the router.

    If that does not work we may need more information.
    What type of wireless router are you using?
    What type of wireless security and how many characters are in the password?

    The problem could be the type of wireless security. You should have a 5 or 13 character password for 40 bit or 128 bit WEP. http://docs.info.apple.com/article.html?artnum=108058

    Jason
  • 9. Re: Not connecting to WiFi
    Braxxis Level 1 Level 1 (0 points)
    ok.. so I turned on Mac Filtering on on my router.. added the iPhones WiFi address into it, then I saved it... then turned mac filtering back OFF and that seemed to do the trick for some reason... strange.. now its reading my ip on the iPhone as 192.168.xx.xx

    and i dont have a password on it.. thought I probably should right?
  • 10. Re: Not connecting to WiFi
    Jason L Community Specialists Community Specialists (9,475 points)
    Does the iPhone now connect to the Internet with the 192.168.x.x IP address?

    You don't necessarily need wireless a password on your network, though most people secure their networks. WPA 2 Personal is the best wireless security option.

    Jason
  • 11. Re: Not connecting to WiFi
    Braxxis Level 1 Level 1 (0 points)
    Yes iPhone now connects with the 192.168.x.x address.