Previous 1 2 Next 22 Replies Latest reply: Nov 1, 2009 9:16 PM by HighTechToolFan
baloo73mk Level 1 Level 1 (5 points)
Suddenly today when I connected my Iphone I was presented with the following message by Itunes " Itunes cannot sync information with the iPhone "iPhone" because syncing has been disabled on this computer. Do you want to enable syncing?".

So I was a bit confused as nothing has changed, but pressed yes only to presented another dialog box saying "Syncing cannot be enabled on this computer." I have two options Ok and Override, pressing either seems to let the iPhone sync (minus address book and calender)

Whats happened, I've searched high and low, i cannot see what has changed, I've tried re-installing OSX but still have same problem. Is anyone else out there having this problem, how do I overcome it?

Cheers

Imac Intel Core Duo 20", 2gb RAM, 256mb video and 256gb HD, Mac OS X (10.5.2), Macbook Intel Core 2 Duo, 2gb RAM
  • D.R.Photo Level 1 Level 1 (0 points)
    I am also having the same problem and it just happened for the first time today when I connected my iPhone to my Mac while on a call with someone. I have tried different USB ports and restarting the phone but no luck.
  • D.R.Photo Level 1 Level 1 (0 points)
    I just tried restarting my computer and then repairing the permissions on my drive which solved the problem. To repair permissions go to Applications->Disk Utility. Select Macintosh HD in the left section of the window and then press the "Repair Permissions" button on the right.

    I did this with iTunes closed but my iPhone was connected (I left it connected when restarting the computer). It shouldn't make a difference either way but you can try replicating my situation exactly if just repairing permissions doesn't solve your problem.
  • baloo73mk Level 1 Level 1 (5 points)
    Thank you, I seemed to have done everything except do that! Problem solved
  • Phil Richardson Level 1 Level 1 (0 points)
    I have exactly the same problem - however this time it is with a PC running vista. I hadn't realised that the contacts and calender were nolonger in sync and this is unhelpful! Any suggestions along the similar lines as the one for the MAC appreciated.

    thanks

    Phil
  • bdesilva Level 1 Level 1 (0 points)
    I'm having the same issue using Windows XP. I've only had my iPhone for a few days and it worked perfectly the first two days. Now I get this message every time I hook it up. Although I have another msg after the first.

    "iTunes was unable to load provider data from Sync Services. Reconnect or try again later."
  • Pferdly Level 1 Level 1 (0 points)
    I had the same problem in Vista and the following sequence allowed me to sync:
    in Vista: iTunes8>Edit>Preferences, Click on "Reset Synch History", OK. My iPhone was ables to synch again.
    Hope it helps!
  • Sam10001 Level 1 Level 1 (0 points)
    I'm having the same issue but in XP, I tried reseting sync history but that didn't solve anything! I even reinstalled itunes! Please help!
  • joe cain Level 1 Level 1 (0 points)
    iTunes will not even see the iPhone. The Iphone wakes up when plugged in, and will synch with Kodak Easy share, but iTunes does not wake up at all.
    I have tried all upgrading, rinstalling iTunes, resetting the iPhone, etc...

    what can make it work?? It was working smoothly and fine until I think I did one of the security upgrades to the Mac software.
  • chrisbone1234 Level 1 Level 1 (0 points)
    ^^^^ i am also having the same problem..

    the iphone charges when its connected to my macbook, but wont come up in itunes..

    any help???????
  • Korruptor Level 1 Level 1 (0 points)
    I had the same problem. I solved it by quitting iTunes, and moving ~/Library/Application Support/SyncServices/Local to my desktop (There're a load of folders in SyncServices, but just removing local did the trick).

    Restart iTunes and it'll start syncing all your devices again. One of my iPods thought it was syncing for the first time, but the phone was fine.

    Hope that helps...
  • Saillar Level 1 Level 1 (35 points)
    I tried the Reboot and ran Disk Utility and it didn't help.

    I had the same problem and fortunately it only showed up today and a google search took me to this (linked) site and I followed his simple directions and it was fixed rightaway. Hope this helps.

    http://blog.maccarocks.com/2008/10/15/fixed-unable-to-sync-iphone-with-calendarc ontacts/
  • stephanem Level 1 Level 1 (0 points)
    I have been having this issue with my IPhone on windows xp.

    After many hours of searching, I think I solved it in a couple of clicks without rebooting.

    With the iphone NOT plugged in.
    open the task manager (right-click on task bar and choose task manager).
    find SyncServer.exe in the list
    Select it, and click end Process. Click yes.

    Plug in your Iphone. Worked for me. A reboot should achieve the same thing I guess, but could not test.

    Hope this helps.
  • whreid Level 1 Level 1 (0 points)
    I had this same problem where iTunes would say "Unable to load provider data from Sync Services."

    I have since figured out the fix for it, however, I cannot take all of the credit since I adapted the solution that works for Mac OS X and made it work for Windows Vista.

    So, here is the fix (for Windows Vista):

    You need to make sure "Show hidden files is enabled" first
    From Windows Explorer, go to "Organise" > "Folder and Search Options" > "View" > "Show hidden files and folders" > Apply > Okay

    Now:
    Go to C: > Users > Your User Name > AppData > Roaming > Apple Computer

    We need to delete the folder in the Apple Computer folder called SyncServices. (You could just move the folder to the Desktop in case you wanted to keep the folder, but after we delete the folder and re-plug in the iPhone, iTunes will rebuild this folder anyways).

    If the folder doesn't delete, then we have an application that is open that is using that folder. Otherwise, if it deletes without any problems, go ahead and reboot your computer. Go back into the Apple Computer folder and verify that SyncServices is still deleted. If it is, go ahead and open iTunes and plug in the iPhone and the problem is gone. MobileMe will sync with your computer again and the errors in iTunes will be gone.

    However, if the folder does not delete on its own, then we need to stop the process that is using it.

    Press CTRL + ALT + DEL and open the Task Manager

    Find the process called SyncServer.exe and end the process.

    Now that the process is stopped, the SyncServices folder should delete without any problems.
  • Guy Tierney Level 1 Level 1 (0 points)
    this method worked for me but i haven't tried to sync my ipod again since setting up the phone.
Previous 1 2 Next