Previous 1 2 3 Next 37 Replies Latest reply: Aug 3, 2009 5:54 PM by BelugaBVI Go to original post
  • olalof Level 1 Level 1 (0 points)
    Anyone at Apple got an answer for this?

    I have the same exact problem with Mail 3.5 and Exchange 2007

  • jeffb007 Level 1 Level 1 (0 points)
    Also currently experiencing this problem, there is no pattern to the emails it is missing, and recreating the connection to the account seems to miss different emails everytime. Has anyone come up with a solution to this?
  • Jeffrey Thacher Level 1 Level 1 (10 points)
    Ditto.... seemingly random.
    My iPhone sees and has downloaded an attached MP3.
    Desktop MacMail has no attachment icon. View->Message->RawSource shows it's there. Seems like Mail gave up, or something.

    Sender is gmail user.

    Email in question is also missing To/From header...even when doing View->Message->Raw Source... though of course that may be unrelated.

    (Mac Mail 3.5, server)
  • Kenji Kono Level 1 Level 1 (0 points)

    Another "me too"

    Question: Does the problem of missing attachments seem to correlate, at all, to the lack of an "encapsulation boundary ... with two more hyphens at the end of the line" that should indicate no further body parts follow?

    Darned if I understand MIME and I don't have a very large set of bad emails to look at, but it almost seems like if a "body part" doesn't get "closed", Apple Mail ignores it. But some other programs just assume the end of the message closes all parts ... if that makes any sense ... I'm just Googling alot.


    The encapsulation boundary following the last body part is a distinguished delimiter that indicates that no further body parts will follow. Such a delimiter is identical to the previous delimiters, with the addition of two more hyphens at the end of the line:

  • Michel F Level 1 Level 1 (15 points)
    Many thanks to ramobrah !

    While the email not showing attachement(s) is selected, the File Menu ans Save Attachement item is giving the missing thing.

    Have a good day to all and to ramobrah
  • Seacookie Level 1 Level 1 (0 points)

    It seems this problem is related to the "view mode" you are looking at your mail. It seems to happen to E-Mails that have been written as HTML-Mail and then are looked at as "plain text".

    Switching the view mode of the E-mail to "next alternative" made the attachement to appear in the mail window again.

  • andresc Level 1 Level 1 (0 points)
    Not applicable in my case.

    I tried to save the attachments via the File menu as someone above suggested, but the option is grayed out. I tried to fiddle around with the "best alternative" option, but, again, the option is not available. And the attachment is there, you can see it in raw mode.

    The only way I have to get the files is to move the message from one folder to the other to get to read it again.

    Did someone find a solution for this? It is just annoying and the alternatives are anything but promising: neither Entourage nor Thunderbird are proper Mac OS X citizens (i.e. lack of integration with Address Book, iCal, etc).
  • Simon Bellis Level 1 Level 1 (0 points)
    Just to add my two pence.
    We regularly send emails with attachments, usually pdf's from within mail, for the past month clients have reported not receiving or seeing the pdf's even though the attachment is showing as being there.

    We are using entourage as suggested on this site but not an ideal situation, hope the fix comes soon
  • tomizza Level 1 Level 1 (20 points)
    i am using mail 3.5 under mac os x.5.5
    i have the very same problem phil townsend described at
    +»recently, attachments have not always been showing up when the email's file size and the paperclip icon indicates an attachment should be present.«+

    also his solutions apply to my situation
    a) *quicklook attachment*: +very often i can view the hidden attachment by either going to the file menu and choosing "quick look attachments"+
    b) *quicklook attachment*: +or by pressing the command and y keys simultaneously+ — which actually is the key-short-cut for solution a)

    furthermore, other solutions work for me:
    c) *save the hidden attachments*: +while the message with the hiding attachments is selected in the message viewer, go to the file menu and select "save attachments..."+ — as ramobrah described at
    d) *view message in different mode*: switching the view mode of the email to "next alternative" or "best alternative" via menu-->view-->message may makes the attachement to appear in the mail window again — as seacookie described at

    this last hint made me realize that currently my tries to view/render every message as plain text — even apple's own "hot news" rss feed ...
    mhmm, this was due to the "secrets" preference pane,, which i told to +"Always display mail in plain text when available+".
    reverting this — which can also be achieved by first quitting and then entering "_defaults write PreferPlainText -bool FALSE_" in the — solved my problems in so far, as now shows a message in its "best alternative", which usually allows the attachments to be visible ... even if it would not be visible in its plain text alternative (imho a bug with mail)
  • madconqueror Level 4 Level 4 (1,090 points)
    Thank you, this worked.
  • djbutt63 Level 1 Level 1 (5 points)
    I have the same problem in Mail 3.5.

    In my case, a booking from the Air New Zealand site will usually return an HTML formatted email with 6 .gif attachments (to format the email) and 2 PDF attachments and 1 .vcs atachment. In mail viewer, the message will appear in the list as having 9 attachments, but when I open the message, underneath the header it will say "6 Attachments" and only show the GIF files. Viewing raw message source shows the PDFs in base64 encoding

    The option for viewing in alternative forms is greyed out, so that doesn't work for me.

    Selecting (but not opening) the message and choosing File>Save Attachments lets me see the files

    Also would like to see this fixed!
  • John Allen2 Level 1 Level 1 (35 points)
    I had this problem of the hidden/missing attachment today. Must be a bug with Mail.App since my copy of Entourage can see the attachment just fine.

    I'm using 10.4.11 and OS X Mail 2.1.3
    Also my 10.5.4 mail app couldn't see the attachment either.

    Someone sent me a Word document and Apple Mail on my 10.4.11 shows '1 Attachment, 0 bytes"
    And there is no way to get at the attachment.

    If I look at the 'raw source' of the email I can see the file is attached....and I can save the raw source to my desktop and uncompress it with Stuffit Expander to get the Word doc to appear.

    Using Entourage v.X to check my mail, show the attachment just fine.

    If I use to check my email, it shows the same attachment twice, but with different sizes:

    Spreads_Photos.doc,Size: 590 bytes.
    Spreads_Photos.doc,Size: 44140 bytes.

    X-Mailer: Lotus Notes Release 7.0.3 September 26, 2007
    Message-ID: <>
    Date: Mon, 17 Nov 2008 11:25:56 -0600
    X-MIMETrack: Serialize by Router on Notes4/SVR/(Release 8.0.1|February 07, 2008) at
    11/17/2008 11:24:39 AM
    MIME-Version: 1.0
    Content-type: multipart/mixed;
    Content-Disposition: inline
    Status: R

    Content-type: text/plain; charset=US-ASCII

    email message here....

    Content-type: multipart/appledouble;

    Content-type: application/applefile;
    Content-transfer-encoding: base64

    Content-type: application/msword;
    Content-transfer-encoding: base64

  • jazzace_at_work Level 1 Level 1 (0 points)
    I believe tomizza has made the best summary, but I think I can add one more piece to the puzzle:

    I do indeed view my messages in Plain Text by default — and I like it that way. The problem seems to be when the attachment is embedded in the Rich Text (HTML) version of the message. Mail, being the good citizen that it is, sends out both a plain text and rich text version of your message if you create it in rich text. Unfortunately, the current version of Mail does not parse the HTML version for embedded attachments, which is where the problem attachments seem to be located. Here's an example (raw source, edited):


    Content-Type: text/plain;
    Content-Transfer-Encoding: 7bit

    Am I on the right track?

    Content-Type: multipart/mixed;

    Content-Type: text/html;
    Content-Transfer-Encoding: 7bit

    <html><body style="word-wrap: break-word; -webkit-nbsp-mode: space; -webkit-line-break: after-white-space; ">
    Am I on the right track?
    Content-Disposition: inline;
    filename="F06 Stats.pdf"
    Content-Type: application/pdf;
    name="F06 Stats.pdf";
    Content-Transfer-Encoding: base64


    Content-Type: text/html;
    Content-Transfer-Encoding: 7bit

    <html><body style="word-wrap: break-word; -webkit-nbsp-mode: space; -webkit-line-break: after-white-space; ">





    As a sender of messages, the best workaround (and the best policy, IMO) in Mail is to send your messages in plain text mode. As a reader, you can use the previously mentioned techniques.

    I don't believe the problem exists in Tiger, so I think this is a Mail bug.
  • BoVLB Level 1 Level 1 (0 points)
    I am having a similar problem. I see this primarily in mail from one source, which has a bunch of attached GIFs, PNGs and JPEGs plus one PDF. They always use pretty much the same format, and the PDF is always missing. When I view raw source, I can see that the PDF is there as the last attachment:

    X-Mailer: PHPMailer [version 1.73]
    X-Mailer: phplist v2.10.4
    Content-Type: multipart/related;
    Content-Type: application/pdf; name="January%202009%20newsletter.pdf"
    Content-Transfer-Encoding: base64
    Content-Disposition: attachment; filename="January%202009%20newsletter.pdf"

    I can see this attachment when I use MacOS 10.4.
  • Erich Lippert Level 1 Level 1 (30 points)
    I've witnessed the missing attachment issue occurring in Apple Mail clients running on 10.3 and 10.5, but not 10.4 interestingly enough. the 10.4 users may have not noticed the issue yet, though I'm running 10.4 on my desktop myself here at work and haven't noticed the issue during routine use. I did have it happen once on my 10.5 machine at home connected via VPN.

    We're running Exchange 2003 here. This issue seemed to start happening around the time when I recently turned on IMAP4 Fast Message Retrieval. The benefits of Fast Message Retrieval are good though, so I'm reluctant to turn it off, I'm investigating the issue further, and I'll let y'all know if it is the cause of the issue in our case.

    For more info on IMAP4 Fast Message Retrieval in Exchange, see this TechNet article: