Skip navigation
This discussion is archived

"iPhoto Library is locked, on a locked disk, or you do not have permission"

14108 Views 15 Replies Latest reply: Jun 4, 2008 3:21 PM by LooserFace RSS
1 2 Previous Next
JUSTANOTHERNOBODY Calculating status...
Currently Being Moderated
May 23, 2008 8:50 PM
Please HELP ! After spending $4,000.00 recently cash money for this computer ,,, I cannot get an answer from Apple !

My problem:
When I click on iPhoto I get this ERROR MESSAGE:
"The iPhoto Library is locked, on a locked disk, or you do not have permission to make changes to it."
I then click OK and the application iPhoto closes.
I've tried everything I could think of. I ran Disk Utility and checked "file Permissions" and "verify disk".
I reinstalled iPhoto from my original OS software disc.
Yet I still get this annoying ERROR MESSAGE that tells me NOTHING !

Can someone PLEASE help me ???
MacBook Pro 4.1, Mac OS X (10.5.2)
  • Brie Fly Level 5 Level 5 (7,925 points)
    So, what have you done in response to the error prompt? Have you opened your Pictures folder, selected your iPhoto Library Folder and looked at the folder's "Get Info..." window to see if the folder had somehow gotten locked? (I'm assuming that if you spent $4,000 on a Mac, you've got some fundamental knowledge of how the Finder works -- if not, we can walk you through the steps, but we need to have some idea where we're starting from).

    If the problem is an inaccessible file or data folder (as the warning prompt suggests), reinstalling an application can have no more effect on the file or folder's locked or permissions status than would replacing your car's engine to solve a locked door problem.
    24" iMac (Alum), Mac OS X (10.5.2)
  • Brie Fly Level 5 Level 5 (7,925 points)
    From your detective work it would seem that you (or someone with access) in the past three weeks has deleted your iPhoto Library folder from your active user account, and that explains why iPhoto is having difficulty opening it.

    You seem to be in luck since Time Machine appears to have a relatively recent backup. With your active user account's Pictures folder open in a normal Finder window, activate Time Machine. Within the Time Machine application, click on the "take-me-back" button, and it should come to rest just prior to the last change of that folder. If you don't see the missing iPhoto Library folder, go back some more until you do see it. Finally, click the big "Restore" button, quit Time Machine, and try iPhoto again.
    24" iMac (Alum), Mac OS X (10.5.2)
  • Brie Fly Level 5 Level 5 (7,925 points)
    Do you see those two big arrows on the right side of the stack of windows in Time Machine? Don't try to outsmart Time Machine, just click on the inward-pointing arrow and it will take you back to when the window you're looking at was last changed. You don't need to know when it happened -- that's what Time Machine takes care of.

    When you see your old iPhoto Library folder appear in that view of your Pictures folder, select it (with a single mouse click) and hit the "Restore" button on the right side of the bottom bar (with another single mouse click).

    From the Help menu in Time Machine, see the topic "Restoring items backed up with Time Machine".

    Message was edited by: Brie Fly
    24" iMac (Alum), Mac OS X (10.5.2)
  • Brie Fly Level 5 Level 5 (7,925 points)
    When you first saw this warning, it was determined that your Pictures folder contained no iPhoto Library folder. Does you Pictures folder now contain an iPhoto Library folder? If it does, have you looked at the locked/permissions status of that folder? If it's not locked, have you run permissions repair since restoring the folder to it's intended location?
    24" iMac (Alum), Mac OS X (10.5.2)
  • csutter@frontiernet.net Calculating status...
    HELP!! I have the same problem. I have an external HHD which has all my itunes and other music files. The volume is locked no matter how many times I have tried to unlock it via sudo commands, as many other posts have outlined. I have verified the disk, but cannot verify permissions because access is denied. The Get Info window shows that any and all permissions are "custom" and nothing seems to change. File shareing is on, I set up a 2nd admin account, and nothing will open that HHD.
    Does any one have any ideas??

    This is on a brand new, 4 day old MPB. I am really, really getting . .
    MBP 2.6, 4gb, Mac OS X (10.5.3)
  • Brie Fly Level 5 Level 5 (7,925 points)
    Just select the drive on the desktop and choose "Get Info..." from the Finder's File menu. Open the Sharing & Permissions disclosure triangle, and put a check-mark in front of "Ignore ownership and permissions on this volume"
    24" iMac (Alum), Mac OS X (10.5.2)
  • csutter@frontiernet.net Level 1 Level 1 (40 points)
    You'd think so, but you'd be wrong. After many hours and a crash course in unix commands and a call to apple care, there was NO WAY that drive was ever going open again. It had all my itunes music, around 36 gb. Finally, I went back to my PB g4, hooked up time machine and recovered the files with the music which I had backed up the day I got the MBP. Could not go through the bad hhd but could retrieve the FILE(s). Eventually, after doing a clean install on the MBP to straighten out the permissions mess, I wiped (and zeroed out) the locked drive completely. It now functions just fine as a data storage place for the MBP. Time Machine saved me. Now I will dedicate a whole new LaCie 750 gb HDD to my MBP for Time Machine.

    btw, Apple had no answer as to how or why the disc was irretrievably locked. SOL.
    MBP 2.6 4gb, G4 pb, 15", 23"ACS, Mac OS X (10.5.3)
1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.