Previous 1 2 Next 28 Replies Latest reply: Jun 10, 2008 6:55 PM by Ward Clark
phillat5dock Level 1 (0 points)
I purchased my iMac 24" in February.
After I had set up the machine I configured an IceCube Firewire 300 GB (Seagate) Hard Drive as a backup volume and flicked the switch in Time Machine. All went as expected. I even restored my whole hard drive from the Time Machine volume about a month ago after I repartitioned the boot volume to set up Boot Camp. No problems.
About a week ago I purchased a 500GB WD HDD and set it up inside the IceCube enclosure (I remembered to make it the "Master" disk too!!). I partitioned it with Disk Utility with a GUID Mac OS X (Journaled) partition for my Leopard boot partition, and as MS-DOS FAT32 for my Boot Camp external partition. I used Carbon Copy Cloner to copy all the Windows files across from Boot Camp to the new FAT32 partition and set up Time Machine to make a backup of the Leopard boot partition.
After several hours Time Machine stopped with the error message above. ("Time Machine Error. Unable to complete backup. An error occurred while copying files to the backup").
I have spent days formatting the new WD drive, repairing permissions on the boot drive, excluding large files and cache files from the backup in Time Machine to no avail. Every time I get the same message. I even set up another 200GB firewire drive to see if it was anything to do with the enclosure of WD HDD. Same result!!

I have searched these forums for any ideas, and have done wide searches with Google but nothing has worked.
I can not understand why my Mac worked perfectly with Time Machine before I installed the new Western Digital Hard Drive.
What have I missed?

iMac 24in 2.4 GHz 500GB, Mac OS X (10.5.2)
  • drdocument Level 4 (3,010 points)
    For what it's worth, I recently connected a Western Digital MyBook (FireWire) and had to update its firmware and drivers to get it to behave. Now all's well.

    If you haven't done that, check out WD's web site.
  • phillat5dock Level 1 (0 points)
    I think I may have solved this problem!!

    In desperation, with the inability of Time Machine to work, I set up another Firewire Hard Disk and used Sync Standard to make a clone of my iMac's Hard Drive. When it had finished I noticed a number of errors in Sync log.
    It had failed to copy several files (iTunes mp3 files as it happens), but HAD successfully copied the other several million files.
    When I inspected these particular files in iTunes they played OK. What now? On a hunch I opened the iTunes folder and attempted to copy these files to somewhere else. Everytime I got an error in the Finder. I know not why but I am still investigating.
    I then opened the incomplete Time Machine package and discovered that every time my TM backup failed it was to do with one or more of these files that Sync had flagged errors on.
    I replaced the shonky files with fresh copies and did a Sync backup again. This time with no errors.
    Next I formatted my Time Machine partition and restarted Time Machine. This time it completed a full backup.
    To test it further, the following day I updated some software with Version Tracker, downloaded my mail and wrote a plain text file, just to see that TM updated them all.
    It worked!!

    It seems that Time Machine falls over if it comes across a file that can not be copied for some reason. Simpler software such as Sync or Super Duper probably do a successful copy because they just flag the shonky file in their log and go onto the next one. Or that is what it seems to me.

    Of course Time Machine does a lot more than just copy files from one hard drive to another, but this could help others who get that dreaded Time Machine Error.
  • Liz M Level 1 (15 points)
    Thanks for the big hint... I am having this problem and so looked in my system.log (open Utilities/Console and look for messages from backupd. In the
    Here, you can see the copy failed on the .DS_Store for my Desktop. That can just be deleted; I'm hoping it will run to completion next time.

    May 31 18:03:46 snowdrop /System/Library/CoreServices/backupd[40318]: Starting standard backup
    May 31 18:03:46 snowdrop /System/Library/CoreServices/backupd[40318]: Backing up to: /Volumes/Snowdrop time machine/Backups.backupdb
    May 31 18:03:51 snowdrop /System/Library/CoreServices/backupd[40318]: No pre-backup thinning needed: 439.6 MB requested (including padding), 50.27 GB available
    May 31 18:03:54 snowdrop[1] (com.mcafee.virusscan.VShieldEPOInterface): Throttling respawn: Will start in 10 seconds
    May 31 18:03:54 snowdrop /System/Library/CoreServices/backupd[40318]: Stopping backup.
    May 31 18:03:54 snowdrop /System/Library/CoreServices/backupd[40318]: Error: (-43) copying /Users/liz/Desktop/.DS_Store to /Volumes/Snowdrop time machine/Backups.backupdb/snowdrop/2008-05-31-180348.inProgress/470AB022-35C4-43 5E-9671-54098414F370/Snowdrop HD/Users/liz/Desktop
    May 31 18:03:54 snowdrop /System/Library/CoreServices/backupd[40318]: Copied 17 files (1 KB) from volume Snowdrop HD.
    May 31 18:03:54 snowdrop /System/Library/CoreServices/backupd[40318]: Copy stage failed with error:11
    May 31 18:04:00 snowdrop /System/Library/CoreServices/backupd[40318]: Backup failed with error: 11
  • phillat5dock Level 1 (0 points)
    I would be interested to hear if after deleting this file your backup completed normally.
  • Liz M Level 1 (15 points)
    phillat5dock wrote:
    I would be interested to hear if after deleting this file your backup completed normally.

    I guess I forgot to say! Yes, it did complete successfully.
  • growler62000 Level 1 (65 points)
    I updated to 10.5.3 the 1st day it was available.  Today, I got the Time Machine error:

    “Unable to complete backup

    An error occurred while copying files to backup volume.”

    I tried a manual “back up now” & got the same error within 1 minute.

    I’ve had my iMac & my 500 GB LaCie backup HDD for 6 months & backup has worked perfectly until today.

    I read many posts about this. My LaCie has not just reached ~ 10 GB, it has ~ 84+ GB of data. Nothing on it except the Time Machine backup. I checked my Console & nothing listed about back up. Only had 3 things listed & no errors listed?  Maybe I needed to do something other than simply opening console? I did see the red dot when going to Time Machine Preferences & could click on the red dot to again see that error message.

    I rebooted, tried manual backup again & it worked!

    I have no idea what the problem is & this “solution” will most likely work for very few of those with the problem  as rebooting was probably tried by others without success.


    Good luck.

    I guess Macs don't always “just work.”
  • Liz M Level 1 (15 points)
    I've had this happen a couple more times, and, yes, it's disappointing.

    I'm beginning to think that this happens because Time Machine is trying to backup a file being accessed at the same moment. It would be nice if Time Machine would just skip the file and try it again after the rest of the backup completed or simply wait a second or two and try the file again.

    The reason I think this is that when the backup runs again, it just works, so this appears to be transient.

    For now, I think, just tell Time Machine to "backup now" and see if the error just disappears. If it doesn't, you'll have to look in the console logs...

    To check the logs:
    1. Start up Console (should be in Applications/Utilities).
    2. Click "Show Log List" on top left if necessary.
    3. Click "system.log" just under "LOG FILES" in the log list.
    4. Type "backupd" in the filter box at the top right.

    Look for an error near the bottom to find out what happened; it might help to make the window really wide. It should include the file that caused the problem. Then, you just have to figure out what you want to do with that file... No fun, I know; hopefully, the backup will just work most times on the second try.

    Hope this helps!
  • growler62000 Level 1 (65 points)
    Hi Liz,

    So far backup running hourly w/o problems.  I opened Console & now it has a huge amount of stuff. 920 messages! I clicked “Show Log List” &"system.log"; just under "LOG FILES" in the log list.

    I typed "backupd" in the filter search box at the top right & have a long list with “Backups.backupdb” (Should I have added a “b” after the “d” in the filter box?) I tried & got a much shorter list. In any event all the entries are dated 6-3-2008 & my problem happened on 6-1-2008.

    I wonder if the logs are erased every 24 hours?

    I just tried using Time Machine to see if I could look at the console logs as they appeared on 6-1-208 but console didn't open, just a window about console, version etc.

    Message was edited by: growler62000
  • nerowolfe Level 6 (13,065 points)
    growler62000 wrote:
    I updated to 10.5.3 the 1st day it was available.  Today, I got the Time Machine error:

    “Unable to complete backup

    An error occurred while copying files to backup volume.”

    I have no idea what the problem is & this “solution” will most likely work for very few of those with the problem  as rebooting was probably tried by others without success.


    Good luck.

    I guess Macs don't always “just work.”

    I have had this problem 3 times since updating to 10.5.3. It must be a known issue by now by Apple. I will file a bug report on it.
    Rebooting allowed me to make a backup as you discovered.
    However, the 3rd time it happened, I closed my and I could make a manual backup without booting, so I believe the issue with TM may be related to the mail "fix" it contained, or it may be that TM has a problem with open files.
    If you get the error, try closing all open apps and then seeing if a manual "backup now" works. If it does, it makes my case that the error is related to open files.
  • growler62000 Level 1 (65 points)
    I just got same error!
    Check logs shows:

    Jun 6 00:05:20 Iconoclasts-iMac /System/Library/CoreServices/backupd[5979]: Backup completed successfully.

    And then, next backup--problem!

    Jun 6 01:04:05 Iconoclasts-iMac /System/Library/CoreServices/backupd[6104]: Starting standard backup
    Jun 6 01:04:12 Iconoclasts-iMac /System/Library/CoreServices/backupd[6104]: Backing up to: /Volumes/LaCie/Backups.backupdb
    Jun 6 01:04:20 Iconoclasts-iMac /System/Library/CoreServices/backupd[6104]: No pre-backup thinning needed: 563.7 MB requested (including padding), 380.86 GB available
    Jun 6 01:04:22 Iconoclasts-iMac /System/Library/CoreServices/backupd[6104]: Stopping backup.
    Jun 6 01:04:22 Iconoclasts-iMac /System/Library/CoreServices/backupd[6104]: Error: (-43) copying /Library/Printers/Brother to /Volumes/LaCie/Backups.backupdb/Iconoclast’s iMac/2008-06-06-010413.inProgress/E327445C-11E9-4182-8DF4-075990511F3D/Macintos h HD/Library/Printers
    Jun 6 01:04:22 Iconoclasts-iMac /System/Library/CoreServices/backupd[6104]: Copied 67 files (186 bytes) from volume Macintosh HD.
    Jun 6 01:04:22 Iconoclasts-iMac /System/Library/CoreServices/backupd[6104]: Copy stage failed with error:11
    Jun 6 01:04:27 Iconoclasts-iMac /System/Library/CoreServices/backupd[6104]: Backup failed with error: 11

    I closed all programs & tried manual backup. It worked. I don’t know why.
  • RDP1 Level 1 (0 points)
    I get this same error message and this has happened five times since I upgraded to 10.5.3. The error message says, "backup failed with error: target volume is read-only". The console says,"Macintosh /System/Library/CoreServices/backupd[196]. Not sure why this continues. Have a lot of room remaining on the Maxtor 260 external HD. Any idea's??
  • Akhiris Level 1 (0 points)
    I still can't get this to work following everyone's advice. However, I noticed that I have no problem with my Mac Pro, which is on a wired connection only. My MacBook Pro is having a problem and it is only using wireless. What are you backing up over?
  • growler62000 Level 1 (65 points)
    WIred connection.

    I get this problem about 1x/day. I tried doing nothing & later a backup succeeded.
  • Tiffany95 Level 1 (0 points)
    I keep getting the Time Machine backup error too, like many others. Was fine until just the other day, now, nothing. Although my husband's backs up just fine. I assume it's the 10.5.3 bug everyone else has. I've tried reselecting the drive, running the disk utility, shutting everything on and off... help!
    Here's the console log- anyone know what this means?

    Jun 10 08:37:27 Tiffany-Dankos-computer-2 /System/Library/CoreServices/backupd[1683]: Starting standard backup
    Jun 10 08:37:27 Tiffany-Dankos-computer-2 /System/Library/CoreServices/backupd[1683]: Network mountpoint /Volumes/Library not owned by backupd... remounting
    Jun 10 08:37:27 Tiffany-Dankos-computer-2 /System/Library/CoreServices/backupd[1683]: Network volume mounted at: /Volumes/Library-1
    Jun 10 08:37:43 Tiffany-Dankos-computer-2 /System/Library/CoreServices/backupd[1683]: Disk image /Volumes/Library-1/Tiffany Danko’s Computer (2)_001b63baf698.sparsebundle mounted at: /Volumes/Backup of Tiffany Danko’s Computer (2)
    Jun 10 08:37:43 Tiffany-Dankos-computer-2 /System/Library/CoreServices/backupd[1683]: Backing up to: /Volumes/Backup of Tiffany Danko’s Computer (2)/Backups.backupdb
    Jun 10 08:37:48 Tiffany-Dankos-computer-2 /System/Library/CoreServices/backupd[1683]: Failed to create progress log file at path:/Volumes/Backup of Tiffany Danko’s Computer (2)/Backups.backupdb/Tiffany Danko's computer (2)/2008-06-09-065427.inProgress/.Backup.234797868.792920.log.
    Jun 10 08:37:48 Tiffany-Dankos-computer-2 /System/Library/CoreServices/backupd[1683]: Event store UUIDs don't match for volume: Macintosh HD
    Jun 10 08:37:48 Tiffany-Dankos-computer-2 /System/Library/CoreServices/backupd[1683]: Error: (-36) Creating directory 77B4FA27-3E65-4B81-897C-610DEE7BB187
    Jun 10 08:37:48 Tiffany-Dankos-computer-2 /System/Library/CoreServices/backupd[1683]: Failed to make snapshot.
    Jun 10 08:37:53 Tiffany-Dankos-computer-2 /System/Library/CoreServices/backupd[1683]: Backup failed with error: 2
    Jun 10 08:37:58 Tiffany-Dankos-computer-2 /System/Library/CoreServices/backupd[1683]: Ejected Time Machine disk image.
    Jun 10 08:37:59 Tiffany-Dankos-computer-2 /System/Library/CoreServices/backupd[1683]: Ejected Time Machine network volume.
Previous 1 2 Next