7 Replies Latest reply: Aug 26, 2008 8:16 PM by Mulder
jrecht Level 1 Level 1 (0 points)
I just got a new iMac and love it. However I am having major problems with Safari. Safari won't reconize any of its plugins.

If I go to "HD/Library/Internet Plug-Ins" I see several plugins listed (quicktime, flash, etc..).
If I open safari and select "Help/Installed Plug-Ins" it shows no plugins and is looking in "file:///Applications/Safari.app/Contents/Resources/English.lproj/Plug-ins.html ".

So, none of my plugins work! It is very disappointing. I have a Mac, running Quicktime and I can't view any of the quicktime movies on the Apple website.

VERY FRUSTRATED! And I have tried deleting and reinstalling the Quicktime plugin.

HELP! Any help would be greatly appreciated!

OS: 10.5.2
Quicktime: 3.1.1

Mac OS X (10.5.2)
  • Hawaiian_Starman Level 7 Level 7 (21,405 points)

    Welcome to Apple Discussions

    The plugin option for Safari may not be selected. Go to the Safari Menu>Preferences>Security panel. There, check at least the first 3 boxes (4th if you want to block pop-up ads). Then try a QT movie.
  • andyBall_uk Level 7 Level 7 (20,490 points)
    Hi jrecht

    one possibility is that javascript is disabled in Safari-Preferences-Security..... it would be odd for no plugins to show up via help-installed plugins ( assuming they are in the folder you say they are ), but javascript is needed for the list to be displayed, and indeed, very often used to call flash & QT movies.

    That may not be your issue of course, but worth checking it out.

    What do you see if you try to view this apple movie ?
  • dreaquinn Level 1 Level 1 (0 points)
    for the past two hours i've been searching for a solution for why my plug-ins all stopped working, seemingly out of the blue and your answer worked for me. thanks!
  • JaneyPaglini Level 1 Level 1 (0 points)
    Ok, I have been having the same problem all weekend. Adobe flash was working Sat morning. Tried to sign on for my fantasy football draft and had to update Flash. I guess since I did not delete previous versions of Flash, I messed something up. I followed advise on this forum and deleted all my flash files. Then I uninstalled Flash. It did nothing since there was no flash to uninstall. Since then trying to install flash has been unsuccessful. It is saying that I "do not have access privilages for the install" and that "1008:5. -5000 Access Denied Error.

    I had no problem viewing the Mac movie above.

    I know there has to be a toggle switch that needs to be turned on, but I can not find it.

    Fact is that it is getting worse. Flash does not work in either Firefox or Safari.

    any help would be appreciated.
  • dsltruck Level 1 Level 1 (0 points)
    I have upgraded to 10.5.4 and java does NOT work Mail will NOT even open. The Icon only bounces.
    I have 2 java folders and neither seems to work.
    I am totally stumped.
  • JaneyPaglini Level 1 Level 1 (0 points)
  • Mulder Level 6 Level 6 (8,980 points)
    If I go to "HD/Library/Internet Plug-Ins" I see several plugins listed

    Are you using the Admin account as your account, or did you create a separate user account for you when you first setup the Mac? If the former, that's a bad idea, since it will make it difficult to diagnose and solve problems later, as everything would be suspect. You need to create your own account just for what you do, give it Admin privileges, and install all applications there, unless they specifically install themselves in the Admin account.

    Do you have a Home/Library/Internet Plug-Ins folder, and if so, what plug-ins are in there?

    it shows no plugins and is looking in file:///Applications/Safari.app/Contents/Resources/English.lproj/Plug-ins.html

    No, it's not. That's the html file that generates that page; there are no plug-ins there.

    If you're running 10.5.2, you should update to 10.5.4, as it will address various bugs and security vulnerabilities. It will also update Safari to 3.1.2.