Previous 1 2 Next 16 Replies Latest reply: May 29, 2008 1:36 PM by TheGuyintheProjectionBooth
Dakbala Level 1 Level 1 (0 points)
Just got Qwest DSL yesterday. Connected the Actiontec M1000 modem directly to our IMac and things worked fine. Unfortunately, our office doesn't have a phone line and the permanent home of the modem is going to be elsewhere in the house. I tried to connect our D-Link wireless router WBR-2310 Rangebooster G to the Actiontec, phone jack--ethernet cable---actiontec---ethernet cable---d-link wan jack. Airport can "see" the wireless network we had setup before we switched to qwest dsl, but cannot connect to the internet.

I'm assuming there is communication problem between the dsl modem and wireless router.

How should my network settings be changed? Do I need to reconfigure the modem, or the wireless router, or both?

24" IMAC, 2.16 C2D, Mac OS X (10.5.2)
  • dechamp Level 4 Level 4 (3,495 points)
    Depending on how your router was set up in the past, you could be double routing. What happens if you plug the ethernet cable from the modem into one of the LAN ports instead of the WAN port so that the wireless router becomes just a wireless bridge?
  • etresoft Level 7 Level 7 (25,955 points)
    First of all, I assume you meant:
    phone jack--phone cord--actiontec--ethernet cable--d-link wan jack

    You probably have to setup PPPoE to connect to DSL. The device connected to the actiontec needs those settings. Since the d-link is now that device, you need to setup the appropriate values in the d-link's setup page and remove the PPPoE settings from the Mac. On the Mac, I suggest just creating a new network location for direct-to-DSL vs. WiFi link.
  • Dakbala Level 1 Level 1 (0 points)
    I'll give that a try when I get home tonight. That would be really nice if it was that easy.
  • Dakbala Level 1 Level 1 (0 points)
    OK, so I need to transfer my original "wired" ethernet connection settings on my Mac to the D-Link setup. Once I do that, should my previous network connection settings on the Mac for the wireless network still work, or would those change to?
  • etresoft Level 7 Level 7 (25,955 points)
    Your previous wireless settings should work. Your D-Link will automatically provide all the services that the Mac needs, once you configure the D-Link with PPPoE so that the Qwest modem will talk to it.
  • hinder90 Level 1 Level 1 (45 points)
    Also make sure your modem is set up to operate in bridge mode. If you normally connect it directly to your Mac via Ethernet, it would likely be set up as a rudimentary router, assigning your Mac a private IP. Once you get your modem acting as a bridge and your router's WAN link set to PPPoE you should be able to find the droids you are looking for.
  • Dakbala Level 1 Level 1 (0 points)
    After spending an hour talking with D-Link and a "senior" technician, they called it quits and offered me an RMA (exchange for new router). Their conclusion was that it was a bad router since we couldn't get a ping. They never could get my computer to connect with the router setup page.

    I then took 20 minutes and figured it out myself. I'm not 100% sure how I did it, but I started by disonnecting the qwest modem and only had the router plugged into the Mac. Then I accessed the router setup, and used DHCP as it was originally using ppoe. I then reconnected the modem, and what do you know? I'm in business.

    Now, I must say that the 3mbps download speed I'm apparently paying for has never been achieved. The fastest I got was 1.4mbps when hardwired. Now with the wireless I'm only around 750 kbps. I'm only twenty feet away and one wall from the router. Any suggestions on increasing this performance?
  • dechamp Level 4 Level 4 (3,495 points)
    {quote}
    Now, I must say that the 3mbps download speed I'm apparently paying for has never been achieved. The fastest I got was 1.4mbps when hardwired. Now with the wireless I'm only around 750 kbps. I'm only twenty feet away and one wall from the router. Any suggestions on increasing this performance?





    Very few sites can actually send you 3mb/s. You can test your connection here:
    http://www.speakeasy.net/speedtest/
    or here:
    http://speedtest.net/

    If your speeds don't seem to be inline then you will have to deal with your broadband provider.

    At 54mb/s your wireless is not the bottleneck, the internet is.

    I'm getting 6mb DSL and it tests perfect, but I wanted the extra speed because I'm running 6 or 8 machines online at all times, and you usually get a faster upload speed with the deal. This can be very important for sharing files and sending emails with attachments, etc.
  • Dakbala Level 1 Level 1 (0 points)
    I have used both of those. My best result was 1.4

    I guess I will call Qwest about it.

    I'm assuming that there are no "tweaks" I can do in the router or modem setup that will help right? Once I got the connection to work, it should work at full capability? Like I said above, I kind of just stumbled across getting the network setup correctly. Plug and unplug enough times, change settings to every possible combo, and eventually it has to work.
  • hinder90 Level 1 Level 1 (45 points)
    How long has the modem been on since you got the service? AT&T tells their customers they won't get full speed until up to 10 days of continuous operation of the DSL modem so they can "optimize" the link. I found this to be the case, but Quest may have a different WAN operation entirely.
  • etresoft Level 7 Level 7 (25,955 points)
    dechamp wrote:
    At 54mb/s your wireless is not the bottleneck, the internet is.


    It could also be the router, or the router/modem interconnect, or the router/wifi interconnect. A couple of years ago I had been running fine with my B wireless and an old iBook and iMac. I bought a Macbook and a G router to go along with it. In theory, since even B was faster than my broadband at the time, I shouldn't have noticed any difference with external connections. In practice, the Macbook with G and a Linksys (I think) router was much slower than B. I even switched back to my old Netgear B router to get better speed. I finally returned the Linksys and got a Buffalo and finally got the speed I expected.

    To make a long story shorter, it can be complicated.
  • Dakbala Level 1 Level 1 (0 points)
    It has only been on for 3 days now.

    I guess I can give it some time.
  • hinder90 Level 1 Level 1 (45 points)
    It can't hurt send them an email about that while you wait.

    In any case, it seems very unlikely that your wifi or router is the bottleneck. If you are using a new DSL modem that is designed for that bandwidth (older DSL modems often cannot handle more than a certain speed) then either they haven't optimized your connection or they didn't provision your connection according to your plan.
  • TheGuyintheProjectionBooth Level 2 Level 2 (195 points)
    Qwest is PPPoA and you have to use the Actiontec to log into the account. UNLESS, your router will do PPPoA. Then you can put the M100 in bridge mode and use the DLink exclusively.

    I have the M1000 and it is DHCP'd to a Netgear Wireless Router that feeds everything. The Actiontec is set to 192.168.1.1 and the Netgear to 192.168.1.2. The Netgear then DHCP's to the LAN at 192.168.0.x. All works great and has for years.
Previous 1 2 Next