12 Replies Latest reply: Sep 29, 2008 5:49 PM by blacksti
TwiceNightly Level 1 (0 points)

I've been using my iPhone for some time now with my Linksys WRT54GS router.

Last night it stopped working with it for some reason. It can see the network but it won't use it for anything - anyone know why?

If I look in the settings for the network on the iPhone all the fields like IP address, DNS server, etc are all blank.

I have DHCP turned on on the router and the iPhone.
I have reset the router
I made the iPhone forget the network and reconnect a few times, it connects after I type in my WEP key and shows the wifi icon briefly but it then flicks back off
I have also "Restored" the iPhone

Don't know what to do here really. I can connect to the same router at work with no problems so I assume something may have gone wrong with my router, but then again my laptop, PS3 and printer all work fine with it?

Thanks for any help, it's much appreciated as I don't know what to do next!!

Vaio, Windows XP
  • Andrew T. Level 4 (3,210 points)
    Hello TwiceNightly

    I have a couple suggestions.

    1. Turn WiFi Security off on the router, Then allow Router to reboot.

    2. Reboot iPhone, Press and hold down the home button & sleep/wake button. Let go once you see a Silver Apple logo. And allow iPhone OS to reboot.

    3. Go to Settings - WiFi - Tap on Network - Network should not have a padlock so should connect quickly. Do you get an IP address now?

    4. If you get no IP address, Disconnect power to router for 5 min, Then reconnect allow it to power up then try iPhone again.

    5. If needed please contact Linksys, And have them assist you with updating you're routers firmware software to the latest version. Once this is done try iPhone again and see if it will connect with an IP address

    If it does Success If not please post back.
  • TwiceNightly Level 1 (0 points)
    Hi Andrew T,

    Thanks for your suggestions, I really appreciate it. I tried the things you suggested with no luck so I spent a lot of the weekend trying to sort it out and got there in the end, here's what the problem was just incase somebody else is having the problem......

    My router is set to DHCP, and therefore gives out an IP address to any of my gadgets that ask for it. I have about 6 items in my house that were askign for IP addresses and I think this was causing the problems.
    It seems that whenever you "wake up" the iPhone with wi-fi enabled it will ask for an IP address from the router again and after a bit of intense use (i.e doing this several times, whilst on my PC, with my PS3 running and my wife playing on the Wii) it seemed to make the iPhone "fall over" and not get a new IP address any more.

    The solution to this problem was to give each of the items that use my home wi-fi network a fixed IP address. This is very easy to do, and you can still leave DHCP enabled.

    Once I did this my iPhone works perfectly with my home network!!
  • Lawrence Finch Level 7 (34,005 points)
    There was a problem with an older version of the Linksys firmware. If you upgrade your firmware to the latest version (easy to do on their web site) it should fix the DHCP problem.
  • juniorm9 Level 1 (0 points)
    I got the same problem.

    My iphone does connect to a linksys WRT54G router, but does not find the server. I cannot receive my emails and cannot open any internet page.

    I have disable all security settings, my firmware is upgraded, I have correctly rebooted the router and I can't still get this problem solved!
    I think it has something related with the quantity of devices connected to the network because when I brought another laptop and an ipod touch, my iphone stopped working! I did configured my wireless devices with an static ip, but my iphone can't still get connected.

    Does anyone has a different solution for this?
  • p0110 Level 1 (0 points)
    Same problem

    wrt54gs v5
    firmware 1.52.5

    can´t connect properly my iphone to the wi-fi, connects randomly, and just after reboot the router

    done the tips of Andrew T. and nothing

    any suggestions?

    Message was edited by: p0110
  • Thomas_Mck Level 1 (5 points)
    I have the same problem. It didn't start happening until the 2.0 upgrade for the Iphone, which I installed.

    I get an IP address, everything looks good, I can even connect to the WRT54GS using it's IP address with Safari. But getting past the WRT54GS is now impossible.

    I've tried just about everything and no luck.
  • Thomas_Mck Level 1 (5 points)
    I replaced my router with a NETGEAR WNR834Bv2, N series router ($89 at Office Depot), and my iPhone works great on my wi-fi now. The linkssys is already in the garbage.
  • flyingstudio Level 1 (0 points)
    Had all these same problems with my new iphone. Updated the firmware on the linksys router and so far everything is now working
  • blacksti Level 1 (0 points)
    I have been having issues trying to network my new iPhone, one week old. I picked up a new router today (Linksys WRT160N)and have had a painstaking time configuring it to work with the iPhone's wi-fi. The only way I have gotten a DCHP connection to work was when the security of my router was off, and in this method I was able to grab all the information from the DCHP fields. I then entered that info into the static fields (which I am now using) and I turned the router security to use WPA2 Personal. I entered my passphrase, all uppercase, and connected. However, no matter what I do I cannot connect using DCHP and security turned on, this is of little consequence to me though.

    My main concern is that I have no internet, mail or data coming in or out. My phone says that I am connected to my network, but I can't do anything with it, it is useless. The only way I can check email is after the phone gives up and switches to 3G. I have restarted both the router and restarted the OS on the iPhone (both buttons) and there is no change. Access restrictions are turned off, in case anyone was wondering.

    Please help.
  • daej920 Level 1 (0 points)
    I have a NETGEAR WNR834B router at home but my iPhone can't connect to the network. Wi-Fi is turned on and I can see the NETGEAR network on my iPhone but when I enter the password, this message pops up: "Unable to join the network" Also, when I click the blue arrow to see the details, everything is just blank and I don't even have the option "Forget this network" that everyone seems to be talking about. I have re-checked my password a dozen times, turned the iPhone and the router on/off, and even reset the network settings on the iPhone. Any other tips on how I can fix this?
  • blacksti Level 1 (0 points)
    I talked to a linksys representative and we changed a few settings. I am now running good. Hope this helps someone else...

    1. In wireless|basic wireless setup, I changed it from wi-fi protected set-up to manual.

    2. Changed Standard Channel from Auto to #1 - 2.412ghz (he said 1 or 11)
  • blacksti Level 1 (0 points)
    I talked to a linksys representative and we changed a few settings. I am now running good. Hope this helps someone else...

    1. In wireless|basic wireless setup, I changed it from wi-fi protected set-up to manual.

    2. Changed Standard Channel from Auto to #1 - 2.412ghz (he said 1 or 11)