8 Replies Latest reply: Jun 10, 2008 1:02 PM by F Holden
passion4dance Level 1 Level 1 (0 points)
I am not able to view PDF files in Safari. A window pops up and asks me to select the application to view the pdf file in. Preview is greyed out so I cannot select it. If I use firefox, it opens the PDF file. I do not want to have to open firefox everytime I run across a pdf file to open. Please help!

MacBook Pro, Mac OS X (10.5.2)
  • Mulder Level 6 Level 6 (8,980 points)
    Do you have Adobe Reader installed? If not, you can Quit Safari after downloading it, then install it and try viewing the PDF file that way.

    But Safari 3.1.1 has the ability to view PDF files even without Adobe Reader, although it may not be enabled. Try opening a Terminal window and entering this command:

    defaults write com.apple.Safari WebKitOmitPDFSupport -bool false

    press Return after you enter it, then type exit, and Quit Terminal.

    Now relaunch Safari, go back to that site where you want to view a PDF and try it again. It should work.

  • passion4dance Level 1 Level 1 (0 points)
    I entered the command through the terminal but now when I try to open the pdf in safari, the file never opens. It is just clocked the whole time.
  • passion4dance Level 1 Level 1 (0 points)
    I also download adobe reader and it is still clocking....
  • Mulder Level 6 Level 6 (8,980 points)
    Okay, try this instead:

    Launch Adobe Reader and go to Preferences (Command-K).
    Select the Internet category and look for a checkbox on the right that says: Display PDF in browser using:… and uncheck the box if it's checked.
    Close Preferences window and Quit Adobe Reader.

    Now, Quit Safari if it's running.
    Open your HD and go to HD/Applications/Safari.
    Control-click on Safari and choose Show Package Contents.
    Double-click on the Contents folder; inside is a group of other folders. If you see one labeled Frameworks, send it to the Trash and then close the window.

    Also, go to ~/Library/Internet Plug-Ins and look through the list to see if you have one labeled "PDF Browser Plugin"; if not, that's good, so don't install one. If you do have one, remove it to your Desktop or the Trash, but don't empty the Trash yet.

    Relaunch Safari and try to view a PDF again; post again with results.

  • passion4dance Level 1 Level 1 (0 points)
    hmmm...I unchecked the box as you said and restarted safari but now I am getting the error

    The page “http://www.davidbartongym.com/chicagoyoga.pdf” attempted to load an Internet plug-in named “Adobe Acrobat and Reader Plug-in”, but the plug-in failed to load successfully.
  • passion4dance Level 1 Level 1 (0 points)
    I redid everything and it worked. I uninstalled adobe reader. Then I installed it again and unchecked that box. I shot down Safari and restarted and it worked! Thanks.
  • Mulder Level 6 Level 6 (8,980 points)
    That error suggests that Safari is not set to display PDFs in the browser, because it's still looking for a plugin that isn't installed.

    I would try removing Acrobat Reader, quitting Safari, then entering the Terminal command I suggested earlier and trying that PDF again. I have no problem loading it, so I know there's nothing wrong with the file itself.

  • F Holden Level 1 Level 1 (0 points)
    Thank you, it worked.

    Was working fine for years, then several weeks ago would only open some PDF's. An up grade bug?

    Thank you