12 Replies Latest reply: Jan 6, 2009 1:06 PM by tripineapple
holmesy Level 1 Level 1 (0 points)
has anyone got the solution for endless restore / recovery loop yet for ipod nano?
constantly recovering / restoring, can't use it for anything, can't turn it off

yes - I have changed my drive letter
yes - I have reinstalled itunes
yes - I have got it in disk mode
yes - I have done the 5 r's
yes to all other suggestions on apple's hints etc
yes - I have reformatted the ipod using windows explorer


I can look at my ipod in windows explorer (I have it as X drive), and it has the label "IPOD", but has no files or directories under it - is that normal? shouldn;t there be some files at least for the operating of the ipod?

Is it a firmware problem? can I get the firmware and put on the ipod using another program?

HP, Windows XP
  • 1. Re: the ipod "restore" "recovery"  endless loop for ipod nano 8gb
    MJMGraaf Level 1 Level 1 (0 points)
    I am experiencing the same problem. After installing thelatest FW upgrade. When connecting my NANO it is identified to be in recovery mode. I have to restore it. It restores, restarts and does not reappear in Itunes. Even worse, it is not recognized by windows as a valid USB device. It does not appear even under My Computer. I have just had a similar problem with a Sandisk MP3 player and I replaced it by an Ipod. I was not able to recover the Sandisk player anymore. How do I get help on this? I am rather desperate!
  • 2. Re: the ipod "restore" "recovery"  endless loop for ipod nano 8gb
    MJMGraaf Level 1 Level 1 (0 points)
    Pfffft, another computer did the trick. Once I got the ipod going on the other computer, my original was fine too. Don't know what trick MS did on me, but it was scary...
  • 3. Re: the ipod "restore" "recovery"  endless loop for ipod nano 8gb
    StuM Level 1 Level 1 (0 points)
    I have the same problem but my ipod works on the store computer when I took it in. Any solution to this. I am running NOD 32 which had issues with itunes for a start.
  • 4. Re: the ipod "restore" "recovery"  endless loop for ipod nano 8gb
    N1cholas Level 1 Level 1 (0 points)
    Same problem occurred on two computers running Windows XP SP2 with 3rd Gen Nano 8Gb straight out of the box.

    Rightly or wrongly, I'm returning the unit to aApple to see if it;s a hardware fault.

    From your comments its sounds that it s likley not to be this.
  • 5. Re: the ipod "restore" "recovery"  endless loop for ipod nano 8gb
    biedross Level 1 Level 1 (0 points)
    I had the same problem - happened just after I updated itunes- and I also tried all the fixes you listed! Just like MJMGraaf , I then used another computer (XP), and it successfully restored. Now it works and syncs fine on the orginal computer (Vista). Hopefully it won't happen again?
  • 6. Re: the ipod "restore" "recovery"  endless loop for ipod nano 8gb
    Kinyen Level 1 Level 1 (0 points)
    I had the same problem with BOTH of my iPods. This KB article was posted to another thread on the same issue (seems rather prolific to me...).

    http://support.apple.com/kb/TS1456 -- Basically all you do is change the drive letter associated with the iPod. However, if you use a USB thumb drive or any other removable media that may change the drive letter assignments, there is a possibility the drive letter initially used by the iPod will be stolen by another device.

    I suggest using driver letter from the second half of the alphabet -- something past M or N. I have a number of card slots in my PC (SD, Memory Stick, etc), each of which has its own drive letter, so I ended up choosing P: for the iPod.

    Why doesn't this happen on the Mac? Because MAC OS doesn't use the braindead 1980's concept of "drive letters".

    And people wonder why I hate Microsoft so much....;)

    "Hello...I'm a PC....and I run LINUX"
  • 7. Re: the ipod "restore" "recovery"  endless loop for ipod nano 8gb
    The UK Level 1 Level 1 (0 points)
    Hi, just to say thankyou very much for the sound advice about changing the drive letter - I am now able to restore and sync my Ipod! I'd never have worked that one out so thanks again.
  • 8. Re: the ipod "restore" "recovery"  endless loop for ipod nano 8gb
    daveca99 Level 1 Level 1 (0 points)
    Sorry I do not have an answer but I am getting exactly the same problem.

    I have 3 iPods and am running the latest version of iTunes. 8.0.1.11
    2 of them connect without a problem (80Gb Classic and 1Gb shuffle) however I have just got a brand new 8Gb (4th Gen) nano and this will not appear in iTunes.

    Problem: Autoplay runs every time with the nano and occasionally I get messages from iTunes that the iPod needs to be formatted for windows or is corrupt and needs restoring. I do this and the iPod restores but then does not appear in the iTunes window after restore.
    Windows XP seems to think it is a USB disk and runs Autoplay everytime I connect.
    I have tried changing the assigned drive letter in case of conflict andalso disabling autoplay but nothing has helped. I have sent the nano back to apple and it has been returned saying everything is fine.

    It should not be this difficult!
  • 9. Re: the ipod "restore" "recovery"  endless loop for ipod nano 8gb
    Lucky 0702 Level 1 Level 1 (0 points)
    Someone please help.I have a 3rd generation nano 4GB.I have "Connected Eject Before Disconnecting" frozen on the screen. I can't reset,restore or anything.Holding down select,menu does nothing.
  • 10. Re: the ipod "restore" "recovery"  endless loop for ipod nano 8gb
    daveca99 Level 1 Level 1 (0 points)
    This is now resolved with a replacement iPod. Despite the first one coming back from repair with the message, "Our technicians have been unable to reproduce the symptom(s) you reported when you requested the repair. As a result of our tests, we can confirm that your product meets Apple specifications for performance, usability, and functionality". It still did not work.

    Apple phone support eventually agreed to a replacement which worked perfectly. I don't know why the first one was diagnosed as no fault found as it definitely refused to work under windows XP.
  • 11. Re: the ipod "restore" "recovery"  endless loop for ipod nano 8gb
    frustratedipoduser1 Level 1 Level 1 (0 points)
    I am having the same problem with my 8GB nano. It keeps giving me a -48 error code as well. It seems to of loaded most of my music onto it as I found it when looking at the ipod through My Computer but my ipod denies all knowledge of the files and says there are no music files. I haven't yet tried changing the drive letter as I am a bit useless and could someone explain how to do this..... Thank you!
  • 12. Re: the ipod "restore" "recovery"  endless loop for ipod nano 8gb
    tripineapple Level 1 Level 1 (0 points)
    I am having EXACTLY this problem! Has anyone found an answer?