5 Replies Latest reply: Aug 12, 2008 4:06 PM by nopantsjack
momoli Level 1 Level 1 (0 points)
Is there any I can do for my ipod classic. When I charge it,it has the sign,about the battery being so low. When I hook it up it just doesn't charge,nor shows on itunes? Even on windows.

So please help! BTW: When I do the diagnostics on Itunes,I pass all tests,but on the ports no ipod is found,even though it is plugged in.

dell vostro, Windows Vista
  • 1. Re: Ipod classic not charging when hooking in
    btabz Level 7 Level 7 (26,635 points)
    Welcome to Apple Discussions!

    See this article...
    http://support.apple.com/kb/HT1435

    Leave the battery connected for a good 30 minutes to an hour to see if it will take the charge. You could also try to Reset iPod after that time period while it's connected to the computer.

    btabz
  • 2. Re: Ipod classic not charging when hooking in
    momoli Level 1 Level 1 (0 points)
    That doesn't help my ipod at all. It still won't show up on my computer,or itunes at all.
  • 3. Re: Ipod classic not charging when hooking in
    btabz Level 7 Level 7 (26,635 points)
    Does the iPod, after being connected for that long, still show the battery icon? Does it show another icon? Does it even say "Do Not Disconnect"?

    btabz
  • 4. Re: Ipod classic not charging when hooking in
    Diane Harper Level 1 Level 1 (50 points)
    I'm having the same problem with charging my 80G IPOD.

    Via car, plug and speaker system (IPOD lights up, shows music, shows battery charging symbol and will play) Once it unplugs, it doesn't come on at all.

    When plugged into the USB, I have the battery ICON, with the notation "Please wait, very low battery"

    I've tried resetting and still nothing.

    Thanks for your assistance.
  • 5. Re: Ipod classic not charging when hooking in
    nopantsjack Level 1 Level 1 (0 points)
    I'm also having this problem, the iPod will not charge from my power adapter charger or from a usb cable, both of which are iPod branded.
    I have kept it on charge for hours and when on the power adapter charger it says it is charging, and will play, then when I remove it it shows 0 battery then switches off.
    On the USB it doesn't even charge at all and just says "please wait, charging" or something similar and never progresses.
    I have read the article and none of this helps, I have tried resetting my iPod several times and this also has no effect.