1 2 Previous Next 15 Replies Latest reply: Sep 10, 2008 7:55 PM by ivarjohnson
jlweber_us Level 1 Level 1 (0 points)
I have a 12" Powerbook G4. When I try to connect at Starbucks, I'm unable to pull up the T-Mobile/AT&T login screen. The Airport card says I'm connected to the network, but when I launch a browser..either Firefox or Safari...I can't get the login screen to pull up. I just get an error on the page. Anyone know what's going on? I can connected at home with no problem and have connected elsewhere....hotels and airports. Thanks!

Powerbook G4, Mac OS X (10.4.3)
  • 1. Re: Connecting at Starbucks
    SDDave Level 1 Level 1 (55 points)
    I had the same problem, got on the phone today with AT&T to debug so I can get on with my Starbucks card.
    Unfortunately, the AT&T guy couldn't find anything "wrong" on their end and basically threw up his hands.
    Did you get any resolution since your post?
    I'm not sure what to try next. My MBP also shows that I'm connected to attwifi, but nothing from Safari/Firefox/Opera. No login page. Just "server not found".

    My iPhone works just fine, connecting to attwifi at Starbucks.
  • 2. Re: Connecting at Starbucks
    jlweber_us Level 1 Level 1 (0 points)
    I haven't found anything new. My iPhone also works like a charm. I haven't been back to Starbucks lately, but am going to release my IP before launching a brower. If you're interested and don't know how to do it, here are the steps. Let me know how it works and I'll do the same.

    1. Close any open Internet applications (such as Web browsers and email). Be sure to save any changes to any open documents.
    2. Choose System Preferences from the Apple menu.
    3. Choose Network from the View menu.
    4. Choose Active Network Ports from the Show menu.
    5. Deselect the "on" checkbox for port you use to connect to the Internet (such as Built-in Ethernet or AirPort).
    6. Click Apply Now.
    7. Reselect the checkbox for the port.
    8. Click Apply Now.
    9. Open a Web browser, and attempt to connect.
  • 3. Re: Connecting at Starbucks
    SDDave Level 1 Level 1 (55 points)
    Hi, thanks for the suggestion.
    On 10.5, could not find a "Show" menu, looks like the Active Network Ports are listed on left column of the Network page of the View menu. Anyway, from there, I made AirPort inactive, applied the change, then turned AirPort back to active, applied, launched the browser.

    Unfortunately, same old thing, "Server not found."
    I'll try it again tomorrow, in case maybe I made a mistake. Maybe reboot or something. ?
    Strange & frustrating.
    The iPhone continues to go right to the attwifi login page, and I'm surfing the Web at Starbucks...
  • 4. Re: Connecting at Starbucks
    jlweber_us Level 1 Level 1 (0 points)
    Darned! It was worth a shot. I haven't been back to Starbucks. Its strange that you and I are having the exact issue, yet I haven't found any article or post that others have had the same issue. I'm going to keep looking. If you find something let me know and I'll do the same. Good luck.
  • 5. Re: Connecting at Starbucks
    SDDave Level 1 Level 1 (55 points)
    Okay, how's this for strange:
    When I was on the phone with ATT assistance the first time, he was noticeable taken aback when I said I was on a Mac. On a hunch, I went back to Starbuck's the next day, this time I used Bootcamp and booted into Windows. Same problem as before, called up ATT assistance. This time, the assistance person somehow decided something needed to be changed, reset my password, told me to try again, voila! Straight to the ATT login page. I'm in. I didn't even ask about the Mac side, I'm Web surfing.
    Now it gets even stranger: I shut down. Booted immediately back into Mac.
    I'm on the Web! Didn't even have to log in to ATT (maybe the router never detected my shut down and reboot).
    That was yesterday. Came back today to test. Mac: initially, no go. Boot into Windows: fine, I'm in. Shut down, boot into Mac, I'm still connected to ATT WiFi.
    I don't understand it, just reporting my experience. I've only been using a Mac for two years, but networking with Windows (i.e., ROW) continues to be an adventure!

    I also think it is puzzling that no one else on these discussions has reported a similar ATT WiFi connection problem. Are there Mac users out there who are regular ATT WiFi subscribers and who have had no connection problems?

    Anyway, maybe later I will try the deactivate/activate procedure again, to see what happens. Maybe even get ATT WiFi on the phone again. Very strange.
    Thanks for your assistance/ideas.
  • 6. Re: Connecting at Starbucks
    The Zach Level 2 Level 2 (380 points)
    I tried to logon at a Starbucks the other day, and after spending 15 minutes on the phone with AT&T and Starbucks reps learned that the service doesn't work with Safari or Firefox for Macs. There was no estimate on when it would be offered.

    When I tried to logon the AT&T network, I was forwarded to a rejection page from T-Mobile: AT&T said this was a known issue. The AT&T rep changed my password, but that didn't fix the problem. We only discovered the issue when she referred to "Internet Explorer" and I told her I was using Safari. She quickly added that Safari doesn't work on Starbucks's network. Nor does Firefox on a Mac.

    Ironic that the iPhone carrier of choice can't handle Macs on its Wi-Fi network.
  • 7. Re: Connecting at Starbucks
    SDDave Level 1 Level 1 (55 points)
    Hi Zach, interesting that AT&T can't seem to get Macs to work on Starbuck's network. I wonder if that trouble extends to the AT&T WiFi network as a whole? Surely AT&T has Mac subscribers, so it must be a Starbuck's problem. It is ironic, with the Starbuck's-Apple marketing tie-in over the iPhone, and yet Starbuck's apparently can't handle Macs for login.

    What I've had to do at Starbuck's is to boot into Windows, and then do the AT&T login through Internet Explorer (my Firefox on Windows won't do it!). Then I shut down and boot right back into OS X, like I never left. I don't know what the router polling interval is, but I figure I must be getting back on before the router knows I've shut down my Windows side. Really annoying. Most coffee shops I go to that have WiFi run open networks, no problems using OS X.
  • 8. Re: Connecting at Starbucks
    The Zach Level 2 Level 2 (380 points)
    Here's the response I got from my e-mail to Starbucks (summary--we know about the problem, no idea when it will be fixed):

    Hello Zach,

    Thank you for your interest in Starbucks Coffee and for taking the time to contact us. We welcome questions and feedback from our customers at any time.

    In regards to the technical issues that you are experiencing with the AT&T WiFi, please know that our technical department is aware of the situation and currently working to resolve them. At this time, we do not have an estimated date of availability. We sincerely regret any inconvenience.

    Acting on feedback is essential to Starbucks continued success. If this does not happen, I realize that you and others may go elsewhere for your coffee needs. I assure you that Starbucks values your comments. Therefore, I shared your experiences with our Starbucks Card department for their attention.

    Thanks again for your interest in Starbucks Coffee and for giving us the opportunity to address your concerns and improve our operations. If you have more specific questions not answered at the Starbucks site, please feel free to e-mail us at CardInfo@Starbucks.com or call any of our phone representatives at 800-STARBUCKS.


    Sincerely,

    Alexandra S.
    Starbucks Card Services
    Starbucks Coffee Company
  • 9. Re: Connecting at Starbucks
    hyuan Level 1 Level 1 (0 points)
    This isn't really a solution to the problem, but a couple of anecdotes:

    1. I have been able to connect with my Mac at some point in the last month - but in the last two weeks, I've not been able to connect successfully.

    2. I can't connect with either my Macbook Air or my iPhone.

    However, I have discovered a workaround which some folks may find useful - it seems that I can connect with my Mac using IE7 running on VMWare Fusion. Once I connect with Windows, I can go back to the Mac side and things work.

    Regardless of which platform I try to connect, login page does seem to take a while to pull up. Also, for completeness this is the page that my browser is trying to access:

    https://secure.sbc.com/outbound_login.adp?NetworkURL=https%3A%2F%2Fservice1.hots pot.t-mobile.com%2Fclickthrough%2Finbound%2FpartnerLogin&RemoteHostName=attwifi& NetworkName=T-Mobile&LocationDescription=Starbucks&AssociatedSSID=attwifi&Return URL=https%3A%2F%2Fservice1.hotspot.t-mobile.com%2Fhome

    This problem might be localized to California users possibly?
  • 10. Re: Connecting at Starbucks
    jlweber_us Level 1 Level 1 (0 points)
    I've been able to connect once with my Powerbook, but have never had an issue with my iPhone. I've connecting with IE with no luck.
  • 11. Re: Connecting at Starbucks
    hyuan Level 1 Level 1 (0 points)
    I just got in with my iPhone today, still can't connect with my Mac however at TWO seperate Starbucks locations.
  • 12. Re: Connecting at Starbucks
    hyuan Level 1 Level 1 (0 points)
    It looks like some changes were made yesterday and is visible from one location that seems to have no T-Mobile ties whatsoever. Now when I pull up a browser, I am directed to a Starbucks page where it lets me login to attwifi directly.

    I was directed straight to the Internet with none of the previous drama.

    I think this problem is solved now.
  • 13. Re: Connecting at Starbucks
    eWee Level 1 Level 1 (5 points)
    same problem, my MacBook works at Barnes & Noble (attwifi), not at Starbucks. iPhone works at starbucks. I think the problem at starbucks is that the router (attwifi) is set to t-mobile hot spot first, then it forwards to sbc (owned by AT&T)
  • 14. Re: Connecting at Starbucks
    Uberfiend Level 1 Level 1 (0 points)
    I'm not sure what the problem is. I am logged in right now on one of my accounts with my MacBook Pro (t-mobile) and sort-of connected with my girlfriend's MacBook (OS X 10.4.11). I say "sort-of" because (a) it took forever for the tmobile network to appear in her list of wireless networks in the AirPort menu. (It appears instantly on the MBP.)

    iStumbler reports that the router MAC address is 00-19-A9-CF-8D-30 (apparently a Cisco router), on Channel 1. The advertised name of the network bounces back and forth between "attwifi" and "tmobile," so both appear in my list.

    The local authentication page in both instances comes from service1.hotspot.t-mobile.com. Once I'm on the network with either machine I can ping the authentication server. The MacBook Pro average latency is about 606 ms, where the MacBook is about 4500 ms, average. The network "works" in that, if you wait long enough you can view a website, but isn't much more usable than IP over smoke signals would be.

    The results are similar for another guy's MacBook Pro who is here as well (also using 10.4.x).

    Seems like a hardware problem, rather than software.
1 2 Previous Next