9 Replies Latest reply: Jul 9, 2008 3:10 PM by BigDogues
Jeff Mourich Level 1 Level 1 (0 points)
For the last year I have had issues with Safari and MSN:

* To login to Hotmail (.msn.com account) I enter my password and it fails. Enter it a second time and it works. This does not fail on FireFox this way. This does not fail with other users that have .hotmail.com accounts.

* www.msn.com is our start page on Safari. When Safari starts with http://www.msn.com/ I get a blank page. After resetting everything, empty cache and many other things no luck! Then I tried http://www.msn.com/ , hit delete key to get rid of / and the page is starts. Bit in the address line it shows http://www.msn.com/ .

Does Safari and MSN not play well together? Is someone else having issues?

Thanks,

Jeff Mourich

Mac 20" Intel CPU, Mac OS X (10.4.11)
  • Mulder Level 6 Level 6 (8,980 points)
    The problem is that Hotmail doesn't play well with others. Microsoft has constructed their web site so that it works only if it detects the IE browser, which you're obviously not using. The only way to overcome that is to go to the Develop>User Agent menu and select an IE browser there. After you do, the page should reload automatically and show the content.

    But a long-term solution would be to not have your start page be anything having to do with Microsoft. You could make it news.google.com, your local newspaper, or even a blank page.

    Mulder
  • Jeff Mourich Level 1 Level 1 (0 points)
    Hi,

    "Develop>User Agent menu and select an IE browser there."

    Is this a Mac/OS setting, Safari setting or something on the MSN page?

    I can't find it on any menu or settings for the above?

    Thanks,

    Jeff
  • Mulder Level 6 Level 6 (8,980 points)
    The Develop menu is for Safari, but it must be activated in Safari Preferences first. Open Safari, go to Preferences?Advanced and check the box at the bottom that says "Show Develop menu in menu bar".

    Mulder
  • Jeff Mourich Level 1 Level 1 (0 points)
    Ok I did find the check box to turn on Develop.

    I selected Agent> IE 7.0 and it worked! http://www.msn.com/ opens.

    But when I close Safari we are back to the same issue.

    Safari resets the Agent to Default (automatically chosen)

    How do you have Safari stop reverting back to Default?

    Also the Disable Cashes Check mark resets. I had luck empt cashes and the page
    would open.

    This issue only started (won't load http://www.msn.com/ (blank page))
    on Friday?

    Any ideas?

    Thanks,

    Jeff
  • Mulder Level 6 Level 6 (8,980 points)
    Unfortunately, I can see no way to choose a Default User Agent other than Automatically Chosen; if there is a way it's probably a matter of altering the application code itself, which is very dangerous and could likely result in Safari not running at all.

    You can always choose Empty Cache from the Safari menu if you need to reload that page again, but other than that, you're probably better off not making it your home page.

    Mulder
  • BigDogues Level 1 Level 1 (0 points)
    I have the same problem. MSN has been my home page for over a year. It has only been recently that I get a blank page when starting Safari or when I click the home button. However the strange thing is that if I click reload MSN comes up just fine.
  • resonantmedia Level 1 Level 1 (0 points)
    ditto. Same. Exact. Circumstances.

    msn homepage since I bought my machine in Oct 2007; just within last month msn.com won't loadie on first try. CMD-R to reload (or click), brings it to life.
  • John W. Kenney Level 1 Level 1 (0 points)
    Jeff,

    I have the same problem with my MSN homepage not loading and haven't been able to find a fix for it yet. I did however find a blog page that works well for getting around the hotmail thing. Go to http://winliveid.spaces.live.com/blog/cns!AEE1BB0D86E23AAC!138.entry?wa%3dwsigni n1.0&wa=wsignin1.0 and click the hotmail button on the Windows Live menu bar. That usually gets me in without a problem. It's an extra step to check your mail but at least you're not waiting for Safari to error out loading the hotmail page every time. I saved this page in my favorites and use it everyday to check my mail instead of the MSN home page.
  • BigDogues Level 1 Level 1 (0 points)
    Okay, so today it is working again.
    Go figure...